Bug 150287 - Row height is not preserved from the default style, on insertion of a new sheet, when using custom calc template
Summary: Row height is not preserved from the default style, on insertion of a new she...
Status: RESOLVED DUPLICATE of bug 81397
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-06 13:19 UTC by mb
Modified: 2022-08-06 21:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mb 2022-08-06 13:19:46 UTC
Description:
When I create a template with a custom default cell style then create a document with that template, the default cell style is not completely preserved on new sheets inserted after 'Sheet1'. The initial 'Sheet1' has the correct formatting, however, when a new sheet is added the row heights on the new sheet appear to use the libre calc default and not the format of the template and original sheet. My customization included padding so it may be the padding not being honored or the optimal-height setting not being honored.

Steps to Reproduce:
1. Open blank worksheet.
2. Open styles manager, right click on 'default' style and select 'modify'.
3. On font tab change font to 'Calibri'.
4. On the 'Borders' tab increase padding to 3.0pt on all 4 sides.
5. Save worksheet as template, with 'use as default' checked.
6. Create new document, which will have a single initial sheet with the new formatting.
7. Insert a new sheet using the '+' or from 'Sheet'->'insert sheet'

Actual Results:
The new sheet row height is not preserved on the new blank worksheet.

Expected Results:
I expect that every new sheet will look exactly like the initial default blank sheet that is there at the creation of a new datasheet.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
I can correct the problem by taking an extra step of selecting the entire newly created sheet, right clicking on the rows and selecting 'optimal-height' and then my new sheet looks like what I have on my initial sheet.
I don't know if other style properties are also not displaying correctly. Also, I can't tell if it's a row height property or maybe just the padding that is not being displayed.
Comment 1 m.a.riosv 2022-08-06 21:35:33 UTC
Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 81397 ***