Bug 150535 - FILEOPEN Crash in: operator new(unsigned __int64)
Summary: FILEOPEN Crash in: operator new(unsigned __int64)
Status: RESOLVED DUPLICATE of bug 150452
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-21 16:11 UTC by matt.chambers42
Modified: 2022-08-21 18:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["operator new(unsigned __int64)"]
Regression By:


Attachments
41k rows mapping hanzi to pinyin (421.08 KB, application/octet-stream)
2022-08-21 16:11 UTC, matt.chambers42
Details

Note You need to log in before you can comment on or make changes to this bug.
Description matt.chambers42 2022-08-21 16:11:31 UTC
Created attachment 181934 [details]
41k rows mapping hanzi to pinyin

This bug was filed from the crash reporting server and is br-5f35ba1b-ac99-418a-b9b3-39b2b43e8592.
=========================================

The attached TSV is simply 2 columns with 41k rows. It crashes when I try to copy/paste it or open it directly. I upgraded my stable install to the latest to see if the bug was fixed and it wasn't.
Comment 1 matt.chambers42 2022-08-21 16:25:56 UTC
I think there's some Unicode in there that Calc really doesn't like. If I just try to open the last 11k rows it also crashes. The first 30k open fine.
Comment 2 matt.chambers42 2022-08-21 16:36:00 UTC
If I split the last 11k rows into 6 files, I can open about 4 of them before it crashes. But if I only open one at a time, I can open all of them.
Comment 3 Julien Nabet 2022-08-21 18:31:54 UTC
Fixed from next LO release 7.3.6

*** This bug has been marked as a duplicate of bug 150452 ***