Bug 150544 - Persian/Arabic text get dislocated when adding parentheses "(" at beginning
Summary: Persian/Arabic text get dislocated when adding parentheses "(" at beginning
Status: RESOLVED DUPLICATE of bug 103492
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Hossein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-22 12:25 UTC by Kurosh Tavassoli
Modified: 2022-09-01 18:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Zip file containing the bug (14.90 KB, application/zip)
2022-08-22 12:25 UTC, Kurosh Tavassoli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kurosh Tavassoli 2022-08-22 12:25:32 UTC
Created attachment 181949 [details]
Zip file containing the bug

The bug should be clear in the attachment file.

One file is .ODS which is the bugged spreadsheet
One file is .png which is the screenshot of the bug

This bug happens *if and only if* we put a parentheses "(" at the beginning of a word/phrase. For example:
(لیبره آفیس
Comment 1 خالد حسني 2022-08-22 18:10:07 UTC
I can reproduce in 7.3.5 but not in master. Can you try the daily builds from https://dev-builds.libreoffice.org/daily/master/current.html and see if it is fixed for you as well? Probably a duplicate of bug 103492.
Comment 2 Hossein 2022-08-23 00:17:25 UTC
Confirmed in 7.2:

Version: 7.2.4.1 / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Also in 7.4:

Version: 7.4.0.1 / LibreOffice Community
Build ID: 43e5fcfbbadd18fccee5a6f42ddd533e40151bcf
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

But fixed in:

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 947a6455d23bff290319313734c8c30e8f495773
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 Xisco Faulí 2022-08-23 09:00:26 UTC
Hi Hossein,
RESOLVED FIXED is incorrect unless you know the commit fixing the issue.
This issue got fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=895843ad466954b63f6f99a1b6319b7813d0dbe1
Closing as duplicated of bug 103492

*** This bug has been marked as a duplicate of bug 103492 ***
Comment 4 خالد حسني 2022-08-29 19:59:06 UTC
*** Bug 149889 has been marked as a duplicate of this bug. ***
Comment 5 Kurosh Tavassoli 2022-09-01 18:17:29 UTC
Thank you guys for your great work! <3