Bug 150562 - Clipboard issue between Writer and Calc if use accented characters
Summary: Clipboard issue between Writer and Calc if use accented characters
Status: RESOLVED DUPLICATE of bug 150151
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-08-23 14:08 UTC by streamstat
Modified: 2022-08-24 16:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description streamstat 2022-08-23 14:08:05 UTC
Description:
Most accented characters do not transfer from Writer to Calc using the clipboard.

Steps to Reproduce:
1. Enter the following text in Writer: "Árvíztűrő tükörfúrógép"
2. Copy from Writer (ctrl+c) and paste (ctrl+v) this text into a cell in Calc.

Actual Results:
The pasted text in the cell will be "Árvztr tkrfrgp".

Expected Results:
In cell the original text should have appeared.


Reproducible: Always


User Profile Reset: No



Additional Info:
This bug was not present in older versions of LibreOffice 7.2.
Comment 1 Balázs Meskó 2022-08-23 15:01:14 UTC
Just to add some extra info. Not only Hungarian characters are affected, but most accented letters, ie. umlauts, slavic letters with diacritic signs, and also some Chinese and Korean letters. A notable exception is the French è, that works.
Comment 2 m.a.riosv 2022-08-23 18:12:40 UTC
Pasting as unformatted text works fine for me or in the input bar.
Version: 7.4.0.3 (x64) / LibreOffice Community
Build ID: f85e47c08ddd19c015c0114a68350214f7066f5a
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: en-US (es_ES); UI: en-US Calc: CL

With normal paste, in my case results in calc 'Liberation Mono; Courier New' while in writer it's only 'Liberation Mono'
Comment 3 Timur 2022-08-24 12:48:32 UTC
By description this looks like a duplicate of bug resolved in master 7.5+ and upcoming 7.4.1.
Please confirm by testing master or after 7.4.1 is out.

*** This bug has been marked as a duplicate of bug 150151 ***