Bug 151141 - Enter ググ\t Search or Replace \t Crash(Writer and Calc)
Summary: Enter ググ\t Search or Replace \t Crash(Writer and Calc)
Status: RESOLVED DUPLICATE of bug 151148
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.6.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks: Crash-Assert
  Show dependency treegraph
 
Reported: 2022-09-23 03:29 UTC by tadashi
Modified: 2022-09-24 14:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (12.05 KB, text/plain)
2022-09-23 20:56 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tadashi 2022-09-23 03:29:31 UTC
Description:
In Writer, enter

ナ\t\t\t\t\t
ナッ\t\t\t\t\t
ナッツ\t\t\t\t\t
ナッツグ\t\t\t\t\t
ナッツグラ\t\t\t\t\t
ナッツグラノ\t\t\t\t\t
ナッツグラノー\t\t\t\t\t
ッツグラノーラ\t\t\t\t\t
ツグラノーラ\t\t\t\t\t
グラノーラ\t\t\t\t\t
ラノーラ\t\t\t\t\t
ノーラ\t\t\t\t\t
ーラ\t\t\t\t\t
ラ\t\t\t\t\t

グ\t
グ\t\t
グ\t\t\t

ド\t\t\t\t\t
ッド\t\t\t\t\t
レッド\t\t\t\t\t
ブレッド\t\t\t\t\t
トブレッド\t\t\t\t\t
ートブレッド\t\t\t\t\t
ョートブレッド\t\t\t\t\t
ショートブレッド\t\t\t\t\t
ショートブレッ\t\t\t\t\t
ショートブレ\t\t\t\t\t
ショートブ\t\t\t\t\t
ショート\t\t\t\t\t
ショー\t\t\t\t\t
ショ\t\t\t\t\t
シ\t\t\t\t\t



Replace all (L)   \t   to null
not all \t replaced to null






And Enter

ググ\t

and Replace All (L) \t  to null
then crash.

Writer and Calc crashed.


Steps to Reproduce:
1.ググ\t
2.Replace all \t to null
3.

Actual Results:
crash

Expected Results:
ググ


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.3.6.2 (x64) / LibreOffice Community
Build ID: c28ca90fd6e1a19e189fc16c05f8f8924961e12e
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: ja-JP (ja_JP); UI: ja-JP
Calc: threaded
Comment 1 Julien Nabet 2022-09-23 20:51:57 UTC
On pc Debian x86-64 with master sources updated today, I got an assertion just when doing this:
Enter just this line:
ナッツグ\t\t\t\t\t

Then Replace All with:
\t
null
Comment 2 Julien Nabet 2022-09-23 20:56:17 UTC
Created attachment 182650 [details]
bt with debug symbols
Comment 3 Julien Nabet 2022-09-24 14:09:40 UTC
On pc Debian x86-64 with master sources updated today (including https://cgit.freedesktop.org/libreoffice/core/commit/?id=222e56157c6317435088e09e52a0705bc6a1a83a
tdf#151148 Finding KATAKANA which has voice consonant mark wrong
regression from
    commit c7551e8a46e2f9f8142aa7921a0494221ae096e8
    Author: Noel Grandin <noel.grandin@collabora.co.uk>
    Date:   Thu Sep 16 10:36:48 2021 +0200
    speedup CharacterClassificationImpl::toUpper)

I don't reproduce this anymore, I suppose a duplicate then.

Sorry, the other one should have been the dup since it was more recent but the patch quoted the other one.

Anyway, don't hesitate to reopen this tracker if you still reproduce this with a daily build from master which includes the patch (you must wait at least 24h/48h to have a daily build available which includes it, see https://dev-builds.libreoffice.org/daily/master/).

*** This bug has been marked as a duplicate of bug 151148 ***