Bug 151210 - 7-4-2-1 calc commas in decimal numbers are not converted to decimal-point, German surround
Summary: 7-4-2-1 calc commas in decimal numbers are not converted to decimal-point, Ge...
Status: CLOSED DUPLICATE of bug 151886
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2022-09-28 08:07 UTC by gerdl
Modified: 2023-01-04 18:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

calc-sheets made with version 7-4-2-1 (with bug) (7.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-09-28 16:21 UTC, gerdl

Note You need to log in before you can comment on or make changes to this bug.
Description gerdl 2022-09-28 08:07:41 UTC
only in version 7-4-2-1 pre-release
open calc
Language = German
select any field
type =3,2+6 enter
you see error #name
if you type
=3.2+6 enter
you see 9,2

the (german) decimal-point on the keyboard is not interpreted as decimal-point
only in 7-4-2-1
all previous versions work without bug

thank you
Comment 1 m_a_riosv 2022-09-28 08:09:43 UTC
Can you attach a sample file?
Comment 2 Eike Rathke 2022-09-28 08:31:42 UTC
Do you by chance have English function names activated? That would explain, because it now sets the formula expression context to English.
Comment 3 gerdl 2022-09-28 15:14:26 UTC
thank you for this comment.

indeed, english functions names are activated (since about ten years).

I tested it under 7-4-2-1 with no english function (ergo german-) names, and then it works properly.

but in 7-4-1-2 german commas on the decimal-block on the keyboard worked well, even if english function names have been activated.

mfg G.E.
Comment 4 gerdl 2022-09-28 16:21:10 UTC
Created attachment 182712 [details]
calc-sheets made with version 7-4-2-1 (with bug)
Comment 5 QA Administrators 2022-09-29 03:57:03 UTC Comment hidden (obsolete)
Comment 6 Eike Rathke 2022-09-29 14:20:48 UTC
(In reply to gerdl from comment #3)
> but in 7-4-1-2 german commas on the decimal-block on the keyboard worked
> well, even if english function names have been activated.
Yes, that changed with the implementation for bug 135993 that was fixed for 7.4.2, and some related, which now places such formula into English context.
I'd rather regard it as bug that previously using English function names still used the localized context.

It is more logical that when using English function names the formula syntax uses an English context with the corresponding decimal separator as well because that finally enables one to copy-paste sample formulas found on the web like on the ask.libreoffice.org site.
Comment 7 Mishy 2022-12-30 17:44:11 UTC
Previously I accidentally comentend to a not correct BUG (152034)
This is the right one, sorry.
My comment from the mentioned bug:

Same issue happens with all "," (comma) separator using languages, like Hungarian, German...

It should be fixed, as it happens frequently to type numbers first in a cell, then need to adjust it later with a simple "multiply" or "add" like: "4,5" to "=2*4,5" or "=B1*4,5". Or using complicated functions gathered from our older documents and we need to readjust the numbers every time when we need to modify it and the text in a cell could be 100+ char long, with constants in some random places with decimal separator!

Localized function names not only used for Copy-Paste but for easier handling and finding. English function names mostly better than some pretty brain-dead loalized function names what I would not find ever AND I do not want to learn all of them in any other laguage what I may facing with!

If you (QA) think that it is normal to use DOT instead of COMMA in eglish functions, think about the tousends of scientific users who SHOULD use localized numbers BUT they dealing with lot of abbreviations and names in almost only ENGLISH.

I guess the best would be to set a checkbox beside the "Use English Function Names" with option like "Use dot in functions for decumal separator" which maybe defaulted to ON but can be set by user.
And not the opposite! As under the Language Setting I have "decimal key = ," set, and even than, it is not handling the comma within fuctions just shows the comma in the results.


Other comment:
Tested system: Linux x64, 5.4.0-132-generic, Xubuntu 20.4.5
LibreOffcie: 7.4.2~rc3-0ubuntu0.20.04.1~lo1 (
Comment 8 Eike Rathke 2023-01-04 18:36:03 UTC

*** This bug has been marked as a duplicate of bug 151886 ***