Bug 151396 - Find and Replace malfunction with some Japanese words in Calc
Summary: Find and Replace malfunction with some Japanese words in Calc
Status: RESOLVED DUPLICATE of bug 151148
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: zexcel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-10-06 23:44 UTC by zexcel
Modified: 2022-10-07 09:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
This is a test bed to show Find and Replace works wrong (5.52 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2022-10-06 23:48 UTC, zexcel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zexcel 2022-10-06 23:44:51 UTC
Description:
Find and Replace works worry with some Japanese words.

Steps to Reproduce:
1.in Calc, input イロハモミジ ABC123
2.Find ABC and replace with XYZ


Actual Results:
イロハモミジ AXYZ23

Expected Results:
イロハモミジ XYZ123


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: ja
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 zexcel 2022-10-06 23:48:40 UTC
Created attachment 182891 [details]
This is a test bed to show Find and Replace works wrong

This is a must patch bug.
Comment 2 Julien Nabet 2022-10-07 09:41:38 UTC
I may be wrong but seeing the description and since it concerns KATAKANA, it should be a dup of tdf#151148.
If it's the case, it's fixed from next release 7.3.7 (for 7.3 branch) which should be released at the end of October (see https://wiki.documentfoundation.org/ReleasePlan/7.3#7.3.7_release)
or 7.4.2 (for 7.4 branch) which should be released in about 1 week (see https://wiki.documentfoundation.org/ReleasePlan/7.4#7.4.2_release)

There's also prerelease for 7.4.2 (see https://www.libreoffice.org/download/pre-releases/)

*** This bug has been marked as a duplicate of bug 151148 ***