Bug 151764 - LibreOffice, Linux Mint 21 x86-64: Media_without_Macros.odb Report error thrashes disk.
Summary: LibreOffice, Linux Mint 21 x86-64: Media_without_Macros.odb Report er...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2022-10-26 10:57 UTC by tneeve
Modified: 2022-11-01 14:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description tneeve 2022-10-26 10:57:12 UTC
LibreOffice, Linux Mint 21 x86-64.
OK, so I have two databases open, my Korean grammar and vocab database on PostgreSQL and your Media_without_Macros.odb.

(I will try again later with just Media_without_Macros.odb).

In Media_without_Macros I am following your BaseGuide for LibreOffice 7.2, as that seems to be the latest.

Get to page 21, and try to open 'Reports', get error:

    The document "Recall" could not be opened.

When I close the error message box my disk is thrashing (I know this because it is a hard drive not SSD and I can hear it). At the same time, the "Embedded database" and "HSQLDB Embedded" messages keep appearing and disappearing at the bottom of the Media_without_Macros.odb window. Both thrashing and messages disappear if I click "Recall" to get the "Could not be opened" error again, and reappear when I close the error message box.

Steps to Reproduce:
1. Open Media_without_Macros.odb
2. Follow BaseGuide for LibreOffice 7.2, as that seems to be the latest.
3. Try to open report as per page 21.

Actual Results:
Disk thrashing

Expected Results:
Whatever else is going on (user profile or not), it should not be thrashing the disk. Is it repeatedly connecting and disconnecting the HSQLDB database, or in a loop trying to generate the report?

Reproducible: Didn't try

User Profile Reset: No

Additional Info:
Version: / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-GB
Ubuntu package version: 1:7.3.6-0ubuntu0.22.04.2
Calc: threaded
Comment 1 tneeve 2022-10-26 11:14:56 UTC
Note that when I closed Base, I then had:
"Due to an error, LibreOffice crashed. Alll the files you were working on will now be saved..." etc"
Comment 2 tneeve 2022-10-26 14:26:55 UTC
1. Created new linux user libreofficetest so anything from my work not included.
2. Unzipped "Sample-databases.zip" so new copy of Media_without_Macros.odb.
3. Opened BaseGuide for LibreOffice 7.2 in Xreader so no influence on LibreOffice.
4. Opened Media_without_Macros.odb in LibreOffice.
5. Started at page 15 of BaseGuide.
6. Opened Loan form tried:
    g + OK :    2 entries displayed
    %g + OK:    3 entries displayed
    %g% + OK:   3 entries displayed
    g% + OK:    2 entries displayed

OK so far.
7. Checked Greta Garbo return date fields drop down to todays date, but did not enter it - OK.
8. Checked Greta Garbo new loan request blocked, hit "Refresh" - OK.
9. Checked can't delete row from "Return" - OK.
10. Switched from Forms to Tables, double clicked "Loan", displayed OK.
11. Switched from Tables to Queries, double clicked "Media_Loan_Balance_time", displayed OK. (4 database windows open now).
12. Switched from Queries to Reports (should have been Forms..), double clicked "Recall", got error message:

    The document "Recall" could not be opened ... xfactory.cxx:227

13. Clicked OK to kill error message and switched from Reports to Forms.
14. Double clicked "Recall", displayed OK on entry for Greta Garbo, 3 - Traditionelle und kritische Theorie - by Horkheimer, Max. ...
15. No recall date or number displayed. Put in todays date, hit return. Moves to next line with date entered but no recall number. (5 database windows open now).
16. Switch from Forms to Reports. Double click "Recall". Get Recall could not be opened message as before (see 12 above). Click OK to close error, no problems.
17. Back on Recall form, hitting return with cursor in Recall Date now writes a "1" to Recall No.  What other user input is required to create recall notices in this database???
18. Double clicking "Recall" in "Reports" gives Recall could not be opened message as before (see 12 above). Click OK to close error, no problems.

19. Gave up trying to reproduce error.

In short, I was unable to reproduce the error.
Comment 3 Robert Großkopf 2022-10-26 17:13:26 UTC
No problem to open report "Recall" from "Media_without_Macros.odb" here with LO on OpenSUSE 15.3 64bit rpm Linux.
Version: / LibreOffice Community
Build ID: 382eef1f22670f7f4118c8c2dd222ec7ad009daf
CPU threads: 6; OS: Linux 5.3; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded

Special packages from OpenSUSE won't work here with any report created with Report Builder.
You are using a special LO package from Ubuntu (Build ID: 30(Build:2)). Please try the original packages from LO.
Comment 4 Alex Thurgood 2022-10-28 08:21:31 UTC

Presumably, you have both of the following packages installed?




If you have, then the behaviour and error message you are describing would be an Ubuntu packaging bug (unfortunately, still far too common). Absent a missing package installation, I haven't seen a release yet of LibreOffice packaged by Ubuntu that didn't come with its own ugly bugs, and I've had LibreOffice on Ubuntu for a very long time, over multiple distro-releases.

It could also be a Mint-specific bug, to the extent that the Mint developers adapt the Ubuntu LO packages in any way.
Comment 5 Alex Thurgood 2022-10-28 09:33:39 UTC
FWIW, no repro for me with Community
Ubuntu package version : 1:7.3.6.-0ubuntu0.22.04.2

on Linux Ubuntu 22.04

I can open the Recall report, or the Media_Chart report, without a problem, and without disk thrashing.

How I tested:
1) Load Media_without_Macros.odb
2) Click on the Reports icon on the left hand side of the main Base window.
3) Double-click on Media_Chart or Recall
4) Report is executed and displayed.
Comment 6 Alex Thurgood 2022-10-28 09:35:44 UTC
@tneeve : Given that I appear to have the same Ubuntu LibreOffice package version as you, what you are reporting would either seem down to either a missing report builder package, or else some tweaking with the Ubuntu-provided packages by the Mint team.
Comment 7 tneeve 2022-10-31 17:16:22 UTC
Installing report builder packages fixes the report problem, still no idea why it was thrashing/crashing tho...
Comment 8 QA Administrators 2022-11-01 03:33:56 UTC Comment hidden (obsolete)
Comment 9 Alex Thurgood 2022-11-01 14:02:11 UTC
(In reply to tneeve from comment #7)
> Installing report builder packages fixes the report problem, still no idea
> why it was thrashing/crashing tho...

Well calling an incompletely installed component would probably do that.

Marking as resolved works for me.