Bug 152019 - Header/Footer popup tab causes lag (repeatable)
Summary: Header/Footer popup tab causes lag (repeatable)
Status: RESOLVED DUPLICATE of bug 147802
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer
  Show dependency treegraph
 
Reported: 2022-11-13 08:58 UTC by jansenart
Modified: 2022-11-14 14:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.odt of a book from Project Gutenberg (537.30 KB, application/vnd.oasis.opendocument.text)
2022-11-13 19:28 UTC, jansenart
Details
Screencast (340.80 KB, image/gif)
2022-11-14 06:49 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jansenart 2022-11-13 08:58:21 UTC
Description:
In Libreoffice Writer, after I accidentally click on the header/footer margin areas and summon the blue Header/Footer tab menus, highlighting text and opening the right-click menu will take between 1 and 2 seconds to display. (described in the Design section of https://wiki.documentfoundation.org/Design/Whiteboard/Writer_SpecialIndicators#Header.2FFooter_Indication).

I noticed this only on a Book View document with a custom page size (5.25x8", paperback size), doesn't happen as noticeably on default 8.5x11, in that the delay for highlighting is less, but still there.

I found the same issue described here, but without understanding its cause:
https://ask.libreoffice.org/t/highlighting-very-slow-in-libreoffice-writer-v-7-0-3-1-00/59685

If I go into the stupid pop-up menu and "delete" the header AND footer (which are blank and I thankfully don't have to use yet), then wait for the text to settle, then save, then reopen the document, things go back to normal, but this is highly disruptive to workflow, which involves a lot of window-swapping.

Steps to Reproduce:
0. in LibreOffice Writer
1. click on the upper/lower header/footer margins
2. summon the blue tabs which should fade in and out (useless feature)
3. highlighting text becomes a total PITA

Actual Results:
Clicking and dragging to highlight text takes between 1 and 2 seconds for the highlight to display.

Expected Results:
The highlighted field ought to follow the click/drag at no less than half the native screen refresh rate, whether or not the header/footer had been activated during the process' uptime.


Reproducible: Always


User Profile Reset: Yes

Additional Info:
I think I saw that the fade-in/out was decided in version 2? Doesn't even fit in with the rest of the UX of writer, now, frankly. Feels misplaced.

Be advised: I use multiple monitors and always have some video streaming on the other one. Like any normal human.
Comment 1 Mike Kaganski 2022-11-13 10:41:38 UTC
(In reply to jansenart from comment #0)

Thank you for filing it. It is a valid perf issue; someone just needs to be able to repro - unfortunately I can't repro using Version: 7.4.3.1 (x64) / LibreOffice Community
Build ID: 3793858a34d8fef5b92f8fee233f97766f05e281
CPU threads: 12; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: zh-CN (ru_RU); UI: en-US
Calc: CL

It might need a sample document where it happens - maybe it depends on the size of a document, or some specific elements in it (ToC? Images? open navigator? ...)

> ... stupid ...
> ... (useless feature)

Please avoid claims that show that you indeed know what everyone needs, and above all, that you consider others inferior.

> I think I saw that the fade-in/out was decided in version 2? Doesn't even
> fit in with the rest of the UX of writer, now, frankly. Feels misplaced.

I don't know version 2 of what you refer to (LibreOffice had never had a version 2; the first its version was, aligned to respective OOo version of that time, 3.3.0). If you refer to OOo 2, then no, you are wrong: it was introduced in LibreOffice 3.5 [1].

You can disable the feature if it is not needed to you. It is configurable under Options->LibreOffice->Advanced->Open Expert Configuration; look for UseHeaderFooterMenu (it is under org.openoffice.Office.Writer/Content/Display), and set its value to false.

[1] https://wiki.documentfoundation.org/ReleaseNotes/3.5#Writer
Comment 2 jansenart 2022-11-13 19:28:50 UTC
Created attachment 183567 [details]
.odt of a book from Project Gutenberg
Comment 3 jansenart 2022-11-13 19:34:01 UTC
Disabling the blue tabs works great, thanks Mike, but I worry about anyone else stumbling on this problem.

I find that it's most noticeable in large documents with a custom page layout size.

I've attached a copy of one of Teddy Roosevelt's autobiographies where I was able to reproduce it after toggling the footers on (seems more of an issue with footers).
Comment 4 Mike Kaganski 2022-11-14 06:49:16 UTC
Created attachment 183575 [details]
Screencast

Repro. This doesn't depend on the specific view mode (i.e., also happens in 1-page view).

I screencasted it using debug build, to emphasize the effect.
Comment 5 Stéphane Guillou (stragu) 2022-11-14 09:20:53 UTC
The lag is a regression, I don't have it in:

Version: 7.1.8.1 / LibreOffice Community
Build ID: e1f30c802c3269a1d052614453f260e49458c82c
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

And seems to start lagging in:

Version: 7.2.7.2 / LibreOffice Community
Build ID: 8d71d29d553c0f7dcbfa38fbfda25ee34cce99a2
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Still reproducible a recent master build:

Version: 7.5.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 6e66b5d75b4cda0314b64f4d12ef9e4350751470
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 6 Stéphane Guillou (stragu) 2022-11-14 10:07:42 UTC

*** This bug has been marked as a duplicate of bug 147802 ***