Bug 152717 - DDE linking in calc is broken since 7.4.3 RC1
Summary: DDE linking in calc is broken since 7.4.3 RC1
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.4.3.2 release
Hardware: All All
: high major
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.6.0 target:7.4.6 target:7.5.0.2
Keywords: bibisected, bisected, regression
: 153067 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-12-29 10:55 UTC by devseppala
Modified: 2023-01-24 10:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Cell A1 contains a DDE link to Sheet1.A1 in document C:\DDE_test\data.ods (7.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-12-29 10:55 UTC, devseppala
Details
Test DDE target document for this bug, Cell A1 just contains value 1234 (7.65 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-12-29 10:57 UTC, devseppala
Details

Note You need to log in before you can comment on or make changes to this bug.
Description devseppala 2022-12-29 10:55:22 UTC
Created attachment 184381 [details]
Cell A1 contains a DDE link to Sheet1.A1 in document C:\DDE_test\data.ods

DDE links do not work in Calc 7.4.3 RC1 and newer (I tested 7.5 beta1 also). Linked cell just shows up empty and there is no error sign. DDE links in 7.4.2 are working fine.

I will provide two example documents. Save them to folder C:\DDE_test\ 

Version: 7.4.3.1 (x64) / LibreOffice Community
Build ID: 3793858a34d8fef5b92f8fee233f97766f05e281
CPU threads: 16; OS: Windows 10.0 Build 19045; UI render: Skia/Vulkan; VCL: win
Locale: fi-FI (fi_FI); UI: en-GB
Calc: CL
Comment 1 devseppala 2022-12-29 10:57:00 UTC
Created attachment 184382 [details]
Test DDE target document for this bug, Cell A1 just contains value 1234
Comment 2 Xisco Faulí 2022-12-29 11:23:38 UTC
Regression introduced by:

author	Mike Kaganski <mike.kaganski@collabora.com>	2022-10-08 22:10:44 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2022-10-09 00:16:51 +0200
commit 94df17f58fe6269452b7252b712a89978c444bec (patch)
tree 88b9f4ced823c739e134504f84420c2ea4b2447a
parent 8cf717efbdf8126a360f766d2c14c02cae497ac6 (diff)
tdf#151429: don't convert OUStrings to system encoding

Bisected with: bibisect-linux64-7.5

Adding Cc: to Mike Kaganski
Comment 3 Mike Kaganski 2022-12-29 17:55:48 UTC
https://gerrit.libreoffice.org/c/core/+/144810
Comment 4 Commit Notification 2022-12-29 20:11:38 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/37723413115baafdc7d13ad26d11aa5f917c2036

tdf#152717: ScDdeLink::DataChanged may get OUString directly

It will be available in 7.6.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2022-12-30 08:59:30 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/8407a506f0cffb902190858fa67559bd2685e502

tdf#152717: ScDdeLink::DataChanged may get OUString directly

It will be available in 7.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2022-12-30 08:59:33 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-7-5":

https://git.libreoffice.org/core/commit/7e60f5dd6422b1409204f97e4704d7163ada73c2

tdf#152717: ScDdeLink::DataChanged may get OUString directly

It will be available in 7.5.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2023-01-12 06:59:53 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f65d7fb18c5b850a381727a67c97fc94128082d2

tdf#152717: sc: Add UItest

It will be available in 7.6.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2023-01-17 13:27:49 UTC
*** Bug 153067 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2023-01-24 10:36:18 UTC
7.4.5 was a hotfix release, updating target in status-whiteboard