Bug 155664 - Reopening of calc sheets --off by 1-- size increase (WM_CLASS handling)
Summary: Reopening of calc sheets --off by 1-- size increase (WM_CLASS handling)
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2023-06-03 14:14 UTC by Przemysław
Modified: 2023-06-10 17:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

LO info (140.38 KB, image/png)
2023-06-05 17:55 UTC, Przemysław
explanation + imgs (37.45 KB, image/png)
2023-06-09 09:50 UTC, Przemysław
Bug numbers (209.58 KB, image/png)
2023-06-10 15:35 UTC, Przemysław

Note You need to log in before you can comment on or make changes to this bug.
Description Przemysław 2023-06-03 14:14:17 UTC
I've created many Calc files which are opened by me every time my Debian is started/reloaded. I do open them in groups in few Desktops of IceWM. They are then manually set to 950x1025 points sizes to have at least two of them visible side by side (in 1920x1080 display size). I run a short Bash script from IceWM menu to populate the desktops in proper sequence.

The BUG:
every time I open LO calc files anew all files gain new sizes enlarged by 1 px.
E.g. I've set them manually to 950x1025. When I reloaded system, or LibreOffice, I got new numbers, here 951x1026. Another opening of LO calc files (closed all files using the global option "Close LibreOffice", then opened again via Bash script) increase their sizes, now it'd be 951x1026, next time it will be - 952x1027, then 953x1027 etc., respectively. As for now I have to correct the calc windows manually.
Comment 1 Przemysław 2023-06-05 17:47:57 UTC
I forgot to add such info:
    OpSys  Debian 12 Bookworm GNU / Linux 6.1.27-1 (2023-04-22)
 X System  X.org
       WM  IceWM 3.3.1
    Shell  Bash 5.2.15(1)
NV Driver  nouveau
  systemd  252 (252.6-1)
Comment 2 Przemysław 2023-06-05 17:55:48 UTC
Created attachment 187738 [details]
LO info

Dammit! I cannot edit my own comment!
LO application description cannot be copied (WTF! WTS! (what a shit!)):
Comment 3 Adam664 2023-06-08 23:48:45 UTC
Thank you for reporting the bug. Can you give some step by step instructions so that we can try and reproduce the bug? What bash command is used to open the files? How is the display size of the files set? It would also be helpful if you could provide a sample file to open.

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Note that the attachment will be public, remove any sensitive information before attaching it. See the QA FAQ Wiki for further detail.)
Comment 4 Przemysław 2023-06-09 09:50:23 UTC
Created attachment 187803 [details]
explanation + imgs


You cannot understand how deeply I abhor using this CRAP bugzilla, I've tried to answer to Adam664 via Yandex Mail, but it way bounced back. Here it doesn't accept small images. I HATE it. But I must. The "hate" increases to square!

I've checked it further. There's no need for the script(s). You can repeat it manually - from LO basic soffice program window or directly from console
$ /opt/libreoffice/program/scalc file,
ANY spreadsheet file shows the bug, new empty one too.
You may run it from IceWM menu
prog      "LOff Office"       libreoffice-main      /opt/libreoffice/program/soffice
prog      "LOff Writer"       libreoffice-writer    /opt/libreoffice/program/swriter
prog      "LOff Spreadsheet"  libreoffice-calc      /opt/libreoffice/program/scalc
prog      "LOff Draw"         libreoffice-draw      /opt/libreoffice/program/sdraw
prog      "LOff Impress"      libreoffice-impress   /opt/libreoffice/program/simpress

/here img/
1) I can hurdle the bug using IceWM options. You can run a script to open any number of calc files in any number of Desktops, e.g.
3 in D1, 4 in D2, 3 in D3 (pay attention numbering in IceWM)
# WS: 0 1 2 3 4 5 6 7 8  9 10 11  ->  WorkSpaces
# DT: 1 2 3 4 5 6 7 8 9 10 11 12  ->  DeskTops
Then you have to focus opened calc window in toolbar, click right context then Tile -> Left/Right Half. It sets windows in correct sizes.
But ANY other method does not works.
/here img - IT CANNOT BE ATTACHED! Oh, God! Why I'm using such CRAPs as LibreOffice and the f***g bugzilla?! I've had to be in despair.../
Even WM_CLASS applied to $ ~/.icewm/winoptions (find using xprop) fails:
# LibreOffice
libreoffice.libreoffice-calc.geometry: 950x1025+0+0
LO is so bitchy that the bug has been going on for many, many years. It has been appearing out from search efforts with dates back from 2010 up to 2022.
Comment 5 QA Administrators 2023-06-10 03:14:39 UTC Comment hidden (obsolete)
Comment 6 Adam664 2023-06-10 14:41:16 UTC
> LO is so bitchy that the bug has been going on for many, many years. It has
> been appearing out from search efforts with dates back from 2010 up to 2022.

Please provide any other bug numbers that come up in a search so this can be marked as a duplicate.
Comment 7 Przemysław 2023-06-10 15:34:24 UTC
From search "LibreOffice doesn't read WM_CLASS". As you are more knowlegeable than me you could make the homework yourself.

▶Libreoffice wm_class error : r/qtile

When I open libreoffice, the client hooks are fired twice. The first time I get an empty list for wm_class but, the second time, the value is correct. You could probably just check for an empty list and ignore it. Reply reply. ... Instead of wm_class, I match for title, using regex to cover all LibreOffice programs. The function goes like this: Match(title=re.compile('.*LibreOffice.*')) So for it's worked in every case I'd expect it to, and never in unexpected cases, so I haven't bothered to try out other potentially more safe methods. I believe you'll need to import re in your config for regex. Скрыть

▶Unable to match LibreOffice wm_class for spawning into...

Does it work for all windows listed in wm_class? I think (but haven't checked) that, for wm_class, the code works by checking whether the client's wm_class is in the list of classes in the Match object. So, yes, I think it should actually work. For LibreOffice, maybe there's an issue with the splash screen that comes up first. ... Is there any way I can maybe write a quick sentence about this on the qtile wiki in case anyone is interested in targeting LibreOffice's wm_class or is it not worth it as people can just search the issues? Sorry, something went wrong. Copy link. Скрыть

▶701757 – can't get proper WM_CLASS association for...

my current guess is that libreofice changes WM_CLASS after mapping the window and we don't handle that correctly and are racy <notting> wmclass: libreoffice-calc, <untracked> <walters ... Indeed, you guys wanted WM_CLASS set to libreoffice-something and it is.  

▶Bug 649315 – can't get proper WM_CLASS association for...

Ideally, LibreOffice would set the correct WM_CLASS before even mapping a window. It would be nice to get a base "base" application on startup too. But if we want this to work, we need to monitor the WM_CLASS property and adapt to changes. Comment 2 Bill Nottingham 2011-05-03 19:47:56 UTC. Note that if I open documents of multiple types, they're grouped under the icon/class of whatever the first one opened was. ... This should help detect applications for windows that set their WM_CLASS after mapping. Comment 5 Colin Walters 2011-05-24 23:41:30 UTC. Oh crap, sorry Jasper - I didn't see you'd already worked on this. Your mutter patch looks fine, but I think my gnome-shell one is better. In my testing we actually need to recalculate the focus-app. Скрыть

▶119202 – LibreOffice apps should not change their...

When you launch (for example) LO Writer, it creates a generic window with the class WM_CLASS "libreoffice LibreOffice 6.0". After a moment, it changes the WM_CLASS to "libreoffice libreoffice-writer". This causes issues in KDE Plasma: https://bugs.kde.org/show_bug.cgi?id=396871. ... With gtk3 under wayland we don't change the WM_CLASS (or equivalent) which gives rise to the issues of bug 100158. See vcl/unx/gtk3/gtk3gtkframe.cxx with the // rhbz#1334915, gnome#779143, tdf#100158 comment so it is possible to survive without changing the WM_CLASS. that said we've changed the WM_CLASS for years and years, so "This bug affects all LO 6.x apps. It was not present in 5.x." sounds odd to me wrt the WM_CLASS hackery. Скрыть

▶Unable to match LibreOffice wm_class for spawning into group

I am trying to get LibreOffice (including Impress, Calc etc…) to appear in a certain group when spawned. I have managed to do this for lots of other programs. Below is the relevant section in my config. ... I checked with xprop and I am in fact targeting the correct wm_class, but I cannot seem to get it to work. I disabled the splash screen but still no success. Does anyone have any experience with this kind of problem? Скрыть

▶Unable to match LibreOffice wm_class for spawning into...

matches is a list of Match objects, so you need a new Match for each wm_class, rather than a list of classes. Try: Group( "6", label="DOC", matches=[. Match(wm_class="libreoffice-writer"), Match(wm_class="libreoffice-calc"), Match(wm_class="libreoffice-impress"), Match(wm_class="libreoffice"), Match(wm_class="atril"), ] ), from qtile. JoaoDDuarte commented on February 24, 2023. ... Is there any way I can maybe write a quick sentence about this on the qtile wiki in case anyone is interested in targeting LibreOffice's wm_class or is it not worth it as people can just search the issues? from qtile. elParaguayo commented on February 24, 2023. Скрыть

▶[gentoo][awesome] LibreOffice - не открывается... | Форум

Ошибка в том, что запуске libreoffice он открывается на _текущем_ теге, но когда нажимаю, например, Ctrl+P (печать) - то окно печати открывается на _заданном_ 4-ом теге. Классы окон взял из xprop. Кто как настроил работу офиса для awesome? В чем ошибка и как ее исправить? Скрыть

▶[Solved] LibreOffice Writer misbehaving / Applications...

It's the same behaviour I get when I run libreoffice --writer on the console.
22 сентября 2022
XdndAware(ATOM) = BITMAP WM_NAME(STRING) = "Untitled 1 - LibreOffice Writer" _NET_WM_NAME(UTF8_STRING) = "Untitled 1...
23 сентября 2022

▶Libreoffice wm_class error - r/qtile

i want to assign libreoffice apps to workspaces. it works with everyother app, but doesnt work with libre office. I get this error: Traceback (most recent call last): File "/usr/lib/python3.11/site-packages/libqtile/hook.py", line 404, in fire i(*args, **kwargs) File "/home/parham/.config/qtile/config.py", line 536, in assign_app_group wm_class = client.window.get_wm_class()[0] ~^^^. IndexError: list index out of range. ... I use a bit of a hack to get LibreOffice on one workspace. Instead of wm_class, I match for title, using regex to cover all LibreOffice programs. The function goes like this: Match(title=re.compile('.*LibreOffice.*')) Скрыть

▶python - WM_Class ignored and icons of running app...

17 авг 2021 · 1 ответ
So why does it not combine the icons if I already put the WM_CLASS property in the desktop file? 2.32.3-0ubuntu0.18.04.1 amd64 JavaScript engine library from WebKitGTK+ ii libreoffice-gtk3 1:6.0.7-0ubuntu0.18.04.10 amd64 office productivity suite -- ...

> readonly - Libre Office Base; Opens reports in read-only
3 ответа
16 дек 2014

> Open LibreOffice writer and load/close a document using C#...
2 ответа
13 янв 2020

> Command `libreoffice --headless --convert-to pdf test.docx...
6 ответов
7 сен 2021

> Building libreoffice gives an error and I don't know how to fix it
29 авг 2019

▶Libreoffice и тайловые wm (вроде бы баг, если кто-то...)

Описание на багтрекере. По-русски: 1. Запускаем что-нибудь из состава LibreOffice (например, calc). 2. Нажимаем на кнопку «формы», «заливка фона» или «цвет шрифта».
21 июля 2012

▶Офис и Текст - [решено] Libre Office не работает...

...ExceptionFlags: 00000000 NumberParameters: 2 Parameter[0]: 00000000 Parameter[1]: ffffffff Attempt to read from address ffffffff.
7 февраля 2023
Selected: LibreOffice 7.5.1 for Windows. Прямая ссылка на 32-разрядную версию
16 февраля 2023

▶Can't run Libreoffice at all - Crash at the beginning - English

I’ve tried reinstalling java, I’ve reinstalled Libreoffice - nothing works. I’m running Fedora 28, but the problems were already persistent running 27. # uname -r 4.20.17-100.fc28.x86_64. Verbose looks like this: # libreoffice -v javaldx: Could not find a Java Runtime Environment! Warning: failed to read path from javaldx /usr/lib64/libreoffice/program/soffice.bin: error while loading shared libraries: /lib64/liborcus-0.13.so.0: file too short. ... libreoffice -v javaldx: Could not find a Java Runtime Environment! Warning: failed to read path from javaldx LibreOffice 00(Build:3). I’ve reinstalled all Java and all libreoffice applications. dnf reinstall *java* dnf reinstall *libreoffice* dnf reinstall *openjdk*.
Comment 8 Przemysław 2023-06-10 15:35:53 UTC
Created attachment 187824 [details]
Bug numbers

Adam664 asked for it.
Comment 9 V Stuart Foote 2023-06-10 17:56:52 UTC
(In reply to Przemysław from comment #2)
> Created attachment 187738 [details]
> LO info

transcribed for the lazy ;-)

Version: (x86_64)/LibreOffice Community
Build:  9f56dff12ba03b9acd7730a5a481eea045e468f3
Environment:  CPU threads: 2; OS: Linux 6.1
User Interface:  UI render:default; VCL:gtk3
Locale:  en-US (en_US.UTF-8);UI:en-US
Misc:  Calc:threaded