Bug 160607 - Chart does not update when an unrelated worksheet is duplicated
Summary: Chart does not update when an unrelated worksheet is duplicated
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2024-04-10 04:06 UTC by Ronald
Modified: 2024-04-10 09:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:

Chart not updating when unrelated worksheet duplicated (41.11 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2024-04-10 04:06 UTC, Ronald

Note You need to log in before you can comment on or make changes to this bug.
Description Ronald 2024-04-10 04:06:39 UTC
Created attachment 193591 [details]
Chart not updating when unrelated worksheet duplicated

I have a workbook with detailed calculations in Year worksheets, and a summary worksheet which refers back to the year worksheets.  The summary worksheet has a details and a summary table and these have charts that display their data.

If I update the data the charts change to reflect the update.

However, if I duplicate a year worksheet, then the charts stop updating until I press CTL + SHIFT + F9.

Instructions to recreate the bug

In attached workbook 
Summary sheet update cell h2 to 50% see chart change
Duplicate tab - SimpleCalculator2022
Try updating Summary sheet cell h2 to 50% see chart not change

Cell h2 is just a number, you can update other cells in the table and the chart does not change.  I was changing the formulae for a column to add the 2023 results.  It is easier to just make a simple change like 3.5% to 50% to see the effect.

I am running 
Version: (X86_64) / LibreOffice Community
Build ID: 420(Build:3)
CPU threads: 8; OS: Linux 6.6; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.utf8); UI: en-GB
Calc: threaded

I had the same issue last year with an earlier version of LibreOffice, but did not report.  I run manjaro so would have been on a reasonably upto date version last year.
Comment 1 Robert Großkopf 2024-04-10 08:55:18 UTC
Might be this one is a duplicate of
Comment 2 Robert Großkopf 2024-04-10 09:05:14 UTC
Seems it isn't a duplicate. Could reproduce it with older LO-Versions. F) only doesn't work. It has to be CTRL + SHIFT + F9.

Tested it in different versions. Falso also in
Version: / LibreOffice Community
Build ID: 6d497ff5e83a906a307eb25cce314d40c0b8624f
CPU threads: 6; OS: Linux 6.4; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded

Might be it never worked.