Bug 30495 - Custom animated text disappears content during slide transition with effect "Fade through black"
Summary: Custom animated text disappears content during slide transition with effect "...
Status: RESOLVED DUPLICATE of bug 33333
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: All All
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-30 05:06 UTC by Kami
Modified: 2013-06-05 15:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Impress file to show the problem (12.58 KB, application/vnd.oasis.opendocument.presentation)
2010-09-30 05:06 UTC, Kami
Details
Please see Comment 8 (12.76 KB, application/vnd.oasis.opendocument.presentation)
2010-12-13 22:49 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kami 2010-09-30 05:06:57 UTC
Created attachment 39069 [details]
Impress file to show the problem

When you set custom animations for specific part of presentation, that part will hide during the slide transitions. To represent the problem I attach an example.

Ubuntu 10.10B 32bit / OxygenOffice 3.2.1.45
Comment 1 Thorsten Behrens (CIB) 2010-09-30 05:09:11 UTC
Taking. Thx for reporting.
Comment 2 Rainer Bielefeld Retired 2010-12-12 01:19:54 UTC
Modified some selections due to current status of the Bug.

Unconfirmed with "LibreOffice 3.3.0 RC1 - WIN XP German UI  [OOO330m17 (build 3.3.0.1", everything works fine. Additionally I doubt that that's a LibO problm.

On Sourceforge I read "OxygenOffice Professional(OOOP, O2OP) is an enhanced version of free OpenOffice.org", and so I wonder what the relation to LibO might be.

Currently I believe here we only can handle problems directly in LibO code.

@Kami:
Can you contribute a LibO version with what that problem also is visible?
Comment 3 Kami 2010-12-13 10:00:27 UTC
However I tried on a notably different machine, this bug is still reproducable. That machine was a laptop with ATI Mobility Radeon 3740 (Open Source Radeon driver) this machine is a desktop machine with propertary drivers featuring Geforce GTX 460.

LibreOffice 3.3.0 RC1 / Ubuntu 10.10 64 bit

Note OxygenOffice was based on Go-OO and now it will based on LibreOffice...

If you want I can test it on that laptop too.
Comment 4 Kami 2010-12-13 10:02:33 UTC
Rainer, please check after the custom animation has appeared. Note: the attached file may not shows the problem on Windows (I haven't tried it, but I will).

KAMI
Comment 5 Rainer Bielefeld Retired 2010-12-13 11:26:16 UTC
After F9 I see:
1. Test "This is static" appears
2. After click "This is custom animated" appears with effect "wheel"
3. after click second page with 2 texts "This is the second page" appears

That's all as I expect.

@Reporter:
To me everything looks as expected and totally equal to OOo 3.1.1

My questions:
What EXACTLY do you want to say with "that part will hide during the slide transitions"? Please explain!
Does behaviour on your PC differ to my observations?
Did you observe that in a different way with a different OOo version?
Comment 6 Kami 2010-12-13 15:49:56 UTC
The custom animated text will disappear during slide transition.
Comment 7 Rainer Bielefeld Retired 2010-12-13 21:01:06 UTC
@Kami:
repeating an already used sentence dos not contribute new information. 

During the slide transition from slide 1 to slide 2 all contents of slide 1 will disappear and be replaced by slide 2, so I still do not see any problem problem. 

Unfortunately you did not answer my questions, you did not tell whether my observations are the sime like mine, I'm afraid I can't help here.
Comment 8 Rainer Bielefeld Retired 2010-12-13 22:02:51 UTC
I CAN help, sometimes standing under the shower helps ;-)
[Reproducible] with "LibreOffice 3.3.0 RC1 - WIN XP German UI  [OOO330m17 (build 3.3.0.1"
I created a new sample from  Kami's, that shows the problem more clearly. The differences to the original sample are the slow slide transition speed and the transition effect "Fade through black". In the original sample document transition is so fast that the bug is invisible, additionally when I open it I see no transition effect selected.

My observations with "Newsaple.odp" after <f9>
1. Test "This is static" appears, slide fades in slowly
2. After click "This is custom animated" appears with effect "wheel"
3. after click 
3a. slide starts to fade out, text "This is static" remains as expected
3b. Text "This is customanimated" disappears quickly immediately after click, 
    that is unexpected. Text should stay with second text until slide 2 
    will fade in.

For me the problem is visible with transition effect "Fade through black", but not with "Fade Smoothly". Other transition effects not tested.

Also visible with custom effect "Diamond squares", others not tested.

Same problem with OOo 3.1.1 and OOo 3.4-dev
Comment 9 Rainer Bielefeld Retired 2010-12-13 22:49:32 UTC
Created attachment 41098 [details]
Please see Comment 8
Comment 10 Julien Nabet 2012-08-06 14:59:00 UTC
Rainer: just to give an update about this bug, on pc Debian x86-64, with master sources updated today, I've got something different from your test with your attachment:
1. "This is static" appears after a while having typed F9 (then doesn't fade)
2. After click "This is custom animated" appears with effect "wheel" (so idem as you)
3. after click 
3a. slide fades out quickly, text "This is static" doesn't remain
3b. "This is the second page" appears
Comment 11 bfoman (inactive) 2013-05-16 10:22:31 UTC
This bug has not been touched by its owner for a long time. To make it clearer which bugs should be fixed by someone else please take following action:
- If you are the owner, and you are actively working on the bug, please give it an update. 
- If you are the owner, and you do not plan to work on it in the near future,
please reassign it to the default assignee and change its status to NEW.
Comment 12 Thorsten Behrens (CIB) 2013-06-05 15:07:50 UTC
Duplicate, closing in favour of the more general bug report

*** This bug has been marked as a duplicate of bug 33333 ***