Bug Hunting Session
Bug 30713 - [FILESAVE]: Images only shown as placeholders in docx
Summary: [FILESAVE]: Images only shown as placeholders in docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium major
Assignee: Luboš Luňák
URL:
Whiteboard: (target:3.4)
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-08 10:59 UTC by Nadav
Modified: 2013-02-17 08:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Please see Comment 3! (13.40 KB, application/winzip)
2010-12-16 08:30 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nadav 2010-10-08 10:59:07 UTC
* create new document
* add header
* inset image
* save it as docx
* reopen it

Document load without the image in the header.
Comment 1 Noel Power 2010-10-26 03:59:05 UTC
I guess this is still unsupported stuff to be exported, does the import work for you? ( e.g. use Word to create a doc with a image in header ) does libreoffice open it
Comment 2 Katarina Behrens 2010-12-07 02:08:17 UTC
Lubos, would you please look at this docx export issue?
Comment 3 Rainer Bielefeld Retired 2010-12-16 08:29:26 UTC
Version pikcer: assumption!

[Reproducible] with "LibreOffice 3.3.0 RC1 - WIN XP German UI  [OOO330m17 (build 3.3.0.1"
In my attached testkit you find a text document "sample1.odt" and the export result "sample1.docx" (with used image "zuerledigen.png")
In "sample1.docx" only  placeholders are visible instead of images (with LibO and MS WORDVIEWER), but not only in heading, also in normal text. With that version it seems that Image export completely fails. That would be a serious limitation.
Comment 4 Rainer Bielefeld Retired 2010-12-16 08:30:57 UTC
Created attachment 41177 [details]
Please see Comment 3!
Comment 5 Luboš Luňák 2010-12-20 08:49:01 UTC
Reporter: Can you reproduce the problem reliably?
Comment 6 Nadav 2010-12-21 01:36:53 UTC
Installed LO RC1

Rainer Bielefeld case wasn't reproduce.
export work fine (although the text was align to right)

Bug case sill happen!

Why does the bug in Keywords of need info?
Comment 7 Rainer Bielefeld Retired 2011-01-20 04:41:17 UTC
Currently no further info required?!
Comment 8 Luboš Luňák 2011-03-30 08:49:52 UTC
This problem appears to have been fixed for version 3.4.
Comment 9 Rainer Bielefeld Retired 2013-02-17 08:42:16 UTC
Very vague assumption concerning fix. I see progress with 3.4.5.

Reincarnation of some aspects in "Bug 60990 - FILESAVE as .docx (MSO2007): background pictures lost when reopen"?