Download it now!
Bug 30729 - formula editor, symbols in "insert symbols" show as empty squares (also empty squares in formulas)
Summary: formula editor, symbols in "insert symbols" show as empty squares (also empty...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
: 30699 33086 33482 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-09 05:46 UTC by fsando
Modified: 2012-04-24 13:11 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (png) of faulty rendering of math characters (17.44 KB, image/png)
2010-10-14 09:22 UTC, fsando
Details
screenshot of missing symbols in the symbols dialog in math editor (15.12 KB, image/png)
2010-10-14 09:24 UTC, fsando
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fsando 2010-10-09 05:46:36 UTC
To reproduce:
Insert formula object
Click on the "insert symbol" icon.
All icons look like empty squares

This can be edited to work:
For each symbol:

choose "edit"
select font "Times New Roman"
Choose symbol
click "modify"
click "ok"
Comment 1 RGB 2010-10-09 07:03:16 UTC
Cannot reproduce the problem with 64 bits version on openSUSE 11.2
Comment 2 Jan Holesovsky 2010-10-14 04:23:41 UTC
Can you please provide us with the screenshot showing the problem?
Comment 3 fsando 2010-10-14 09:22:57 UTC
Created attachment 39448 [details]
screenshot (png) of faulty rendering of math characters

I have attached a screenshot of the problem in math editor
Comment 4 fsando 2010-10-14 09:24:54 UTC
Created attachment 39449 [details]
screenshot of missing symbols in the symbols dialog in math editor
Comment 5 fsando 2010-10-14 09:28:04 UTC
Ups I should, of course, add

I use Ubuntu 10.04 32bit

2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:26:08 UTC 2010 i686 GNU/Linux
Comment 6 Michael Meeks 2010-10-15 08:29:46 UTC
Riight - could well be a missing opensymbol font I suppose.
Can you have a look for opens___.ttf on your system ? Interestingly, I'm getting the same problem with a developer build / install - and opens___.ttf is in place and opened: most odd.

Hmm ;-)
Comment 7 fsando 2010-10-15 14:33:02 UTC
The opens___.ttf font is there. The math editor works perfectly in Openoffice and formulas created in libreoffice will look correct after being opened and closed (i.e. no editing just updated) in ooo. Math objects created in ooo will look wrong after open/close in LO and again look correct in ooo.
Comment 8 ancanus 2010-10-15 20:03:54 UTC
I can confirm this issue.

My OpenSymbol is correctly installed since I can do Insert -> Special Character in Writer, select OpenSymbol and everything shows up correctly.

However, selecting the Catalog option in Math shows boxes instead of symbols. If I edit one of them, I can fetch the correct glyph, modify it, and that particular symbol will be fixed.

It seems the issue is that the mapping between the Catalog symbols and the OpenSymbol font got corrupted somehow.

(In reply to comment #0)
> To reproduce:
> Insert formula object
> Click on the "insert symbol" icon.
> All icons look like empty squares
> 
> This can be edited to work:
> For each symbol:
> 
> choose "edit"
> select font "Times New Roman"
> Choose symbol
> click "modify"
> click "ok"
Comment 9 Giorgi Maghlakelidze 2010-10-24 16:31:20 UTC
I confirm this bug for LibreOffice 3.3 beta2 on Ubuntu 10.10 Maverick Meerkat x86. Quite easy to reproduce. 

VERY important.

That's the reason why I had to swtich back to OpenOffice. :(
Comment 10 Caolán McNamara 2010-10-27 06:38:16 UTC
I'm informed that this might be 
http://qa.openoffice.org/issues/show_bug.cgi?id=113586
i.e. there may be *another* older opensymbol font being used first ?

http://qa.openoffice.org/issues/show_bug.cgi?id=115038
Comment 11 Caolán McNamara 2010-10-28 00:52:09 UTC
What's the output of...

fc-list -v |grep opens

I can reproduce this problem if I install libreoffice onto RHEL-5 without uninstalling the pre-installed OpenOffice.org which places its older opens___.ttf into the system-wide shared fonts dir. Meaning that the older opensymbol font is discovered first by libreoffice.

i.e. if its the same problem then it'll "go away" when distros move over to libreoffice entirely.
Comment 12 fsando 2010-10-28 03:34:27 UTC
Replacing the old OpensSymbol font with the new one solves the problem (form my short testing it's completely solved)
Comment 13 Caolán McNamara 2010-10-28 07:42:37 UTC
*mumble* Debugging this I see that when two fonts with equal attributes are discovered, the first one found gets priority over the other which is rather arbitrary.
Comment 14 Thorsten Behrens (CIB) 2010-11-24 12:48:04 UTC
removing needinfo, closing as not our bug - distro packages will properly conflict, and fontconfig should get a fix - Caolan, could you forward?
Comment 15 Caolán McNamara 2010-11-24 13:06:16 UTC
I've no special hotline to fontconfig devs these days FWIW.

I'm rather swayed towards the thought that LibreOffice should be pulling the font version id out and using it as input into the existing mechanism we have for favouring one font above the other when two or more candidates exist. i.e. this case is a more striking example of what probably happens every day for the "vanilla" packages and the bundled DejaVu fonts etc which generally already exist on the system.

Its a low priority for me to fix this though at the moment, given that it "goes away" for the "distro" bundled case. Leave this with me for the moment, and I'll have another poke eventually and either formulate a convincing fontconfig test-case or accept that we should compare font versions ourselves
Comment 16 Caolán McNamara 2010-12-10 03:33:04 UTC
*** Bug 30699 has been marked as a duplicate of this bug. ***
Comment 17 Caolán McNamara 2011-01-10 06:43:24 UTC
*** Bug 32052 has been marked as a duplicate of this bug. ***
Comment 18 Alexander O. Anisimov 2011-01-14 12:12:39 UTC
*** Bug 33086 has been marked as a duplicate of this bug. ***
Comment 19 Artem Petrov 2011-01-26 00:53:46 UTC
*** Bug 33482 has been marked as a duplicate of this bug. ***
Comment 20 Caolán McNamara 2011-04-08 06:31:05 UTC
now fixed for 3.4