Bug Hunting Session
Bug 30797 - Missing language names in the LO Windows installer
Summary: Missing language names in the LO Windows installer
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-12 03:18 UTC by Petr Mladek
Modified: 2011-01-15 04:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot whowing the problem. (28.81 KB, image/png)
2010-10-12 03:18 UTC, Petr Mladek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Mladek 2010-10-12 03:18:44 UTC
Created attachment 39376 [details]
Screenshot whowing the problem.

I tried to enable more localizations in the custom installation of LibO_3.3.0_beta2_Win_x86_install_multi.exe. I saw STR_NAME_MODULE_LANGPACK_XX instead of human readable language name in some cases.

Steps to reproduce:

1. Start LibO_3.3.0_beta2_Win_x86_install_multi.exe
2. Select custom installation
3. Try to enable more optional localizations

See a also the attached screenshot.
Comment 1 Noel Power 2010-10-26 05:28:35 UTC
for tor I guess
Comment 2 Don't use this account, use tml@iki.fi 2010-11-17 03:16:24 UTC
More specifically, the strings in question are:

STR_NAME_MODULE_LANGPACK_BO
STR_NAME_MODULE_LANGPACK_OC
STR_NAME_MODULE_LANGPACK_OM
STR_NAME_MODULE_LANGPACK_SI
STR_NAME_MODULE_LANGPACK_UG

The language codes mean: bo = Tibetan, oc = Occitan, om = Oromo, si = Sinhalese, ug = Uyghur.

Would it be enough to add entries for these to scp2/source/ooo/module_langpack.ulf ? Probably. Did that. Note that this breaks the string freeze that I think is in force for the libreoffice-3-3 branch.
Comment 3 sophie 2011-01-15 04:37:35 UTC
Closing - Sophie