Bug 30850 - Beta2: Installer stalled in the final phase on WIndows 2000
Summary: Beta2: Installer stalled in the final phase on WIndows 2000
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Don't use this account, use tml@iki.fi
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-13 21:26 UTC by Cesare Leonardi
Modified: 2012-01-24 22:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The point of the lock (25.77 KB, image/jpeg)
2010-10-13 21:26 UTC, Cesare Leonardi
Details
JRE6 exception on calling JREProperties.class (677 bytes, text/plain)
2011-01-06 09:52 UTC, Cesare Leonardi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cesare Leonardi 2010-10-13 21:26:01 UTC
Created attachment 39424 [details]
The point of the lock

After installing successfully LO under Win2000 SP4, then uninstalling to make some test for #30467, now i'm not able to installing it anymore.
The setup process hang in the final step represented in the attachment.
Clicking on cancel, the program ask for confirmation then nothing happen. I have to kill the unopkg.bin to exit, then LO says it is installed successfully.

Looking in the process list during the hang, i can see java.exe and unopkg.bin trottling to gain cpu usage.
The VC runtime is already installed.

I have tried uninstalling LibreOffice and VC runtime many times and the "repair" function of LO, but without effect: it stops in the same point.

If i run LO applications, they seems to work, but i've not used them deeply.

I've no idea how to debug this problem but i'm available to make some test do diagnose this problem.
Tomorrow i'll try to upgrade Java6 to the latest version.

Cesare.
Comment 1 Cesare Leonardi 2010-10-14 15:24:03 UTC
With Java uninstalled the setup completed correctly (before i had JRE6u21 and a release of JRE5).

Ciao.

Cesare.
Comment 2 Noel Power 2010-10-26 06:35:46 UTC
Adding Tor to cc who might help unwinding the mysteries of the windows installer. Any idea Tor?
Comment 3 Tor Lillqvist 2010-10-26 06:44:20 UTC
No idea now, but will eventually try to reproduce in a Windows 2000 virtual machine.
Comment 4 Don't use this account, use tml@iki.fi 2010-11-19 05:37:51 UTC
Taking this, will try to reproduce.
Comment 5 Don't use this account, use tml@iki.fi 2010-12-02 03:57:50 UTC
Have not been able to reproduce. In my Windows 2000 virtual machine: I installed Java, installed Beta 3, tried it, uninstalled it, rebooted (just to be sure), and installed Beta 3 again. No problem. Resolving as WORKSFORME, please reopen and add more detailled reproduction instructions if you can reproduce with Beta 3 or later.
Comment 6 Rainer Bielefeld Retired 2010-12-20 10:54:05 UTC
@Cesare:
New results with LibO 3.3 RC?
Comment 7 Cesare Leonardi 2010-12-21 14:49:56 UTC
After filing this bug i've always tested LO without Java installed and in that situation the bug doesn't happen.

I'm very busy ATM, but after the christmas period i will hopefully be able to retest the setup with Java installed.
Even if, i admit i'm more interested in helping LibreOffice in getting rid of Java.

Cesare.
Comment 8 Cesare Leonardi 2010-12-25 11:24:20 UTC
I've download LO 3.3.0rc2, uninstalled rc1, installed JRE 6u22, launched rc2 setup.

The problem is the same: i've waited for 10 minutes for the process to end, then killed unopkg.bin. The installer then showed the end screen.
I confirm that there are two process reaching the higher cpu usage: unopkg.bin and java.exe but somethimes also jqs.exe and setup.ovr appears near the top.

The java.exe process keeps on vanishing and reappearing, making me think of a loop that go on launching the same process again and again.

Since nobody else reported the same problem, it's probably something related to my pc configuration. There is an old JRE 1.3.1 on that machine that i can't really uninstall: maybe there is some sort of interference. What if the java.exe i see is from JRE1.3.1 rather than 6.0?
If you have a hint on how to debug, i can try to go deeper.

Cesare.
Comment 9 Don't use this account, use tml@iki.fi 2011-01-03 05:27:28 UTC
Is it possible to see the full path to the executable in Task Manager in Windows 2000? If not, try if Process Explorer still works on Windows 2000. That might give some hints if it is the 1.3.1 JRE that interfers.
Comment 10 Cesare Leonardi 2011-01-06 09:50:55 UTC
(In reply to comment #9)
As requested by Tor, i've tried to uninstall rc2, install JRE 6u22, delete the LibO folder under %programfiles%, reinstall rc2.

No, under Win2000 Task Manager doesn't show processes' full path, so i installed Process Explorer, as suggested.

I see that unopkg.bin is busy on calling ciclically three different java.exe process:
1) %programfiles%\Java\jr6\bin\java.exe
2) %programfiles%\JavaSoft\BIN\1.3.1
3) C:\WINNT\system32\java.exe

Asking for properties to the java.exe under system32, it reports that belongs to JRE 6u22.

For each the three Java calling, here is the command line reported by Process Explorer:
java.exe -classpath c:\programmi\LibreOffice\URE\bin JREProperties

I've attached what Java says when i try to launch this command line at the command prompt, but perhaps LibO installer setup a different environment to the JRE, so this could be useless.

So yes, JRE 1.3.1 is called but JRE6 is called too and seems to fail as well.

Cesare.
Comment 11 Cesare Leonardi 2011-01-06 09:52:44 UTC
Created attachment 41715 [details]
JRE6 exception on calling JREProperties.class
Comment 12 Cesare Leonardi 2011-01-06 10:05:36 UTC
I have a news.

When i was diagnosing for the previous post and doing something else, i've left the setup process busy in its Java loop. When i came back to it, the LibO setup process was finished, with no more Java running.
I've left it running more than 15 minutes, but i can't be more precise.

So seems unopkg calls is not in an infinite loop, but in a slowed down loop?

Cesare.
Comment 13 Cesare Leonardi 2011-03-10 08:03:52 UTC
Evidently it's a corner case bug, since no one seems to have reported the same problem.
But today i've upgraded 8 machine in parallel (all Win2000) to LibreOffice 3.3.1 and 4 of them have experienced this problem. The steps followed was:

- uninstall previous version: i remember two OOo 3.1, two LO 3.3.0 and the rest was go-oo 2.4.1.
- delete what remained in %programfiles%
- delete what remained in the user startup folder
- delete what remained under the program menu
- install JRE6u22
- install LO 3.3.1

For one of them i've waited for about half an hour, then the setup completed. For the others i simply couldn't wait so much, so i followed this workaround:

For the next PCs i've adopted this workaround:
- kill the LibO setup.
- uninstall any JRE.
- install LibreOffice or restore a previous setup with "Modify".
- reinstall JRE (6u22 for me).

I reopen this bug since it's not a problem of a single PC.

Cesare.
Comment 14 Cesare Leonardi 2011-03-25 16:35:17 UTC
I'd like to add details to my latest post: every machine updated, have only *one* JRE installed, JRE6u22. Not as in my PC (first post), where i need also JRE 1.3.1.
So in these cases doesn't look like interactions between different JRE versions.

Moreover, on the pc of the initial post, i've just installed 3.3.2 and i confirm that:
- the problem is still present
- the installer complete after a huge wait (more than 20 minutes): so i confirm that it's busy on something.
- looking from process explorer, unopkg keep calling java, that ends almost immediately then gets recalled, in loop. With the 3.3.2 i see calling java from %programfiles%, then from system32, but they are always from jre6. No more calls to jre 1.3.1.

Tor, any other suggestion on what to look to reach the root of this bug. It's rather annoying.
What JRE did you use to make tests?

Cesare.
Comment 15 noname 2011-08-08 10:27:44 UTC
I've been able to install LO under Win2K upto 3.4.2 Final and jre6 update 26 without any setup problems. Maybe it's time to close this report ?
Comment 16 BerniCL 2011-09-04 12:12:22 UTC
I've just upgraded to LO 3.4.3 on one of the Windows 2000 PC i've talked abount in this bug, with JRE6u27, and the final hang is no more.

Good, this bug can be closed.
Comment 17 Rainer Bielefeld Retired 2012-01-24 22:01:06 UTC
<https://bugs.freedesktop.org/page.cgi?id=fields.html#status>