Download it now!
Bug 30929 - Crash when printing particular documents
Summary: Crash when printing particular documents
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) All
: high blocker
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 31865
  Show dependency treegraph
 
Reported: 2010-10-16 15:27 UTC by dubelhugen
Modified: 2012-05-07 09:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
test sample causes printing crash (210.33 KB, application/vnd.oasis.opendocument.text)
2010-11-23 21:44 UTC, Yifan Jiang
Details
crash stack (27.62 KB, text/x-log)
2010-11-23 21:46 UTC, Yifan Jiang
Details
maybe Irrelevant - original document from which the sampe file converted via odf-converter. (297.80 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2010-11-23 21:47 UTC, Yifan Jiang
Details
Another sample to cause printing crash. (17.42 KB, application/vnd.oasis.opendocument.text)
2010-11-23 21:48 UTC, Yifan Jiang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dubelhugen 2010-10-16 15:27:20 UTC
LibreOffice beta 2 crashes when I try to print a document in a different format than the printers defaults (which is letter size, portrait, double sided).

This is apparently a regressive bug, as the document prints just fine in the beta 1 on the same systems (Kubuntu 10.10 Maverick and LinuxMint 9 Isadora KDE (which is Kubuntu 10.04 Lucid).

The printing dialog shows in the beta 1, crashes beta 2 when called.

Please look into that, because it renders the beta 2 useless for me.
Comment 1 Muthu 2010-10-20 05:58:25 UTC
It would be great if you could attach the backtrace and strace for us. This would help us debugging this faster. Thank you!

[It seems to work for me thou, but with the latest build]
Comment 2 dubelhugen 2010-10-20 13:43:14 UTC
(In reply to comment #1)
> It would be great if you could attach the backtrace and strace for us. This
> would help us debugging this faster. Thank you!
> 
> [It seems to work for me thou, but with the latest build]

I am sorry, but as I had to reinstall the b1 to print my document, I cannot reproduce the bug on my Linux machines at this time. However, I tried the b2 on a WinXP-Home-SP3 machine and had the same problem with a similar document. That means the problem is apparently not related to the OS. I need my machines as reliable "production" units, so I will not be able to install and re-install back and forth.

Printing letter size portrait document works fine, but as soon as there is a document formatted as half-letter size for brochure printing the print command (File/Print...) or the print button, calling the print dialog, crashes LOb2 completely with the message that the document will be recovered at restart (and that's what LO actually does...). I could send you the specific document, if that would help... As I said, it prints fine in b1 and in OOo3.2.1 (on both Linux and Win systems).
Comment 3 Noel Power 2010-10-26 07:39:24 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > It would be great if you could attach the backtrace and strace for us. This
> > would help us debugging this faster. Thank you!
>... As I said, it prints fine in b1 and in OOo3.2.1 (on both
> Linux and Win systems).

I think attaching the document would be useful, could you do that?
Comment 4 Don't use this account, use tml@iki.fi 2010-11-23 04:22:41 UTC
Also, please tell us if you see the same problem in Beta 3.
Comment 5 Yifan Jiang 2010-11-23 21:43:48 UTC
Hi, I am not sure if this is related with printer settings, but I just by chance met similar problem today when I was indeed playing with printers.



Platform: SLED 11 sp1 i586
build info: LibreOffice 3.2.99.3

[Steps]

    1. Open the attached odt file (picturetools_2010-rc1-win-32.odt it was
    converted from docx using odf-converter)
   
    2. File->Print... (or \C-p)

[Problem]

    LibO crashes immediately.

[Extra Information]

    + Instead of a generic problem, it happens to some files only, I just got 2 
    samples as follows.

    + It happens on Novell LibO beta3 build as well, I do not have debuginfo
    packs installed on my vanilla Libo build, so Novell LibO crash
    stack is attached here - (crash-printing-novell-libo-beta3.log)

    + The original docx file attached (picturetools_2010.docx -which does not
    cause the crash)

    ----------
    
    + Just for reference, another sample file I found also cause the same crash
    was attached. (ODFFaxDraftSample.odt)
Comment 6 Yifan Jiang 2010-11-23 21:44:55 UTC
Created attachment 40527 [details]
test sample causes printing crash
Comment 7 Yifan Jiang 2010-11-23 21:46:24 UTC
Created attachment 40528 [details]
crash stack
Comment 8 Yifan Jiang 2010-11-23 21:47:43 UTC
Created attachment 40529 [details]
maybe Irrelevant - original document from which the sampe file converted via odf-converter.
Comment 9 Yifan Jiang 2010-11-23 21:48:43 UTC
Created attachment 40530 [details]
Another sample to cause printing crash.
Comment 10 Yifan Jiang 2010-11-23 21:57:25 UTC
Hello dubelhugen,

Still please attach your sample and crash logs, so that we can see if you are meeting similar crash as I did. Thank you!

I think this bug is still in info needed.
Comment 11 Yifan Jiang 2010-11-24 18:30:19 UTC
Hi Cedric,

For c#5,

I am not sure who would be interested in printing area, since it happens with odt files, so may be you wanna take a look? Please re-assign if not properly, thank you!
Comment 12 Cédric Bosdonnat 2010-11-25 00:32:14 UTC
(In reply to comment #11)
> Hi Cedric,
> 
> For c#5,
> 
> I am not sure who would be interested in printing area, since it happens with
> odt files, so may be you wanna take a look? Please re-assign if not properly,
> thank you!

I can't reproduce the bug here... but it seems to be related to the print data. I can handle it, but I would need to get some help to reproduce it ;)
Comment 13 Rainer Bielefeld Retired 2010-11-26 05:19:48 UTC
[Reproducible] with "ODFFaxDraftSample.odt" and with "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.3)]" printing on Okipage 14ex (or other printers). LibO terminates immediately (and shows the recovery notice) when I click "File -> Print". I modify OS due to my results.

I can't contribute any confirmation concerning reporter's suspect concerning document page size or similar. May be we have different issues in this Bug. 

No problem with PDF export.

I agree, as long as we do not know the reasons for the crash, this is a blocker.
Comment 14 Petr Mladek 2010-11-29 07:58:08 UTC
I am able to reproduce it with LibO-3.3-beta3 build.

It works with the last test build => it seems to be fixed.

Feel free to reopen the bug if you reproduce it with the next official build.
Comment 15 sophie 2011-01-12 06:42:51 UTC
Closing - Sophie
Comment 16 Björn Michaelsen 2011-12-22 05:37:22 UTC
Remove infoprovider from closed and resolved bugs.
Comment 17 Björn Michaelsen 2011-12-22 05:51:45 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 18 Roman Eisele 2012-05-07 09:39:42 UTC
This is (at least at the surface) a Writer issue, therefore changed the
'Component' field accordingly.