Bug 30977 - LibreOffice Uyghur UI crash on Windows
Summary: LibreOffice Uyghur UI crash on Windows
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-18 22:43 UTC by Abduqadir Abliz
Modified: 2013-11-23 13:10 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
error message screen shot file at Windows XP and Windows 7 (122.72 KB, application/zip)
2010-10-18 22:51 UTC, Abduqadir Abliz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Abduqadir Abliz 2010-10-18 22:43:06 UTC
LibreOffice version 3.3.1 in Uyghur UI view, Click LibreOffice --> Options --> LibreOffice --> View Or LibreOffice Writer --> tools --> Options --> LibreOffice --> View then LibreOffice program closed automatically. but English and Chinese UI do same operation is normal.
meybe soffice.bin file have error.
Comment 1 Abduqadir Abliz 2010-10-18 22:51:21 UTC
Created attachment 39527 [details]
error message screen shot file at Windows XP and Windows 7
Comment 2 Muthu 2010-10-20 11:19:23 UTC
Could you please reattach the attachment? The current one seems to have problems.

Also, it would be great if you could attach the strace and backtrace. These will help us in identifying the problem faster. 

you could refer to http://wiki.documentfoundation.org/BugReport
Comment 3 Tor Lillqvist 2010-10-25 03:21:41 UTC
Although the bug reporter is on Windows, so no strace equivalent or backtrace is easily available.
Comment 4 Andras Timar 2011-08-02 05:51:11 UTC
It is still a problem in 3.4.2.
LibreOffice crashes at 
http://opengrok.libreoffice.org/xref/libs-gui/vcl/source/gdi/outdev3.cxx#6532
long lc_x1 = pCaretXArray[2*(nMnemonicPos - nIndex)];

(5ec.3e0): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
vclmi!OutputDevice::ImplDrawText+0x718:
67bde6e8 8b0c88          mov     ecx,dword ptr [eax+ecx*4] ds:002b:000000ba=????????

On Linux it is OK. It seems to be specific to Uyghur localization.
Comment 5 Andras Timar 2011-11-10 04:23:00 UTC
I found a workaround. The crash occurs when the translation of "Use system ~font for user interface" has an access key defined in brackets after the Uyghur translation: (~F). When I removed the access key, the crash did not occur. I think it is a good compromise to remove a single access key, as it seems that the root cause of the crash has not be solved yet.

I removed the (~F) from Pootle and I also pushed the fix to git.

For the record, this is the diff:

diff --git a/translations/source/ug/cui/source/options.po b/translations/source/ug/cui/source/options.po
index ace3f21..4935350 100644
--- a/translations/source/ug/cui/source/options.po
+++ b/translations/source/ug/cui/source/options.po
@@ -1300,7 +1300,7 @@ msgstr ""
 
 #: optgdlg.src#OFA_TP_VIEW.CB_SYSTEM_FONT.checkbox.text
 msgid "Use system ~font for user interface"
-msgstr "سىستېما خەت نۇسخىسىنى ئىشلەتكۈچى كۆرۈنمە يۈزىگە ئىشلەت(~F)"
+msgstr "سىستېما خەت نۇسخىسىنى ئىشلەتكۈچى كۆرۈنمە يۈزىگە ئىشلەت"
 
 #: optgdlg.src#OFA_TP_VIEW.CB_FONTANTIALIASING.checkbox.text
 msgid "Screen font antialiasing"