Download it now!
Bug 31082 - cursor visible during Impress presentation
Summary: cursor visible during Impress presentation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Jorendc
URL:
Whiteboard: target:4.1.0
Keywords: difficultyInteresting, easyHack, skillCpp
Depends on:
Blocks:
 
Reported: 2010-10-24 08:59 UTC by Florian Effenberger
Modified: 2015-12-16 00:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Effenberger 2010-10-24 08:59:00 UTC
During the Impress presentation being active in full screen mode, the OS X cursor is still visible.
Comment 1 Noel Power 2010-10-27 04:55:35 UTC
can you have a look thorsten
Comment 2 Alex Thurgood 2010-11-25 13:09:43 UTC
I can confirm this is the case on my Macbook Pro SnowLeopard 10.6.5 (although personally, it doesn't bother me very much).


Alex
Comment 3 Thorsten Behrens (CIB) 2010-11-26 14:35:27 UTC
Urk. Fought that on Mac for a while, then realized this is a general bug.
Comment 4 Thorsten Behrens (CIB) 2010-11-26 15:28:12 UTC
Nope. Need more coffee. But seems this is missing on purpose, a quick 

case POINTER_NULL: pCursor = [NSCursor arrowCursor]; [pCursor hide]; break;

in

NSCursor* AquaSalFrame::getCurrentCursor() const

leads to a completely unresponsive app on areas this is selected. Hm.
Comment 5 Florian Effenberger 2011-01-25 08:51:26 UTC
Tested with 3.3 final on Windows 7: The cursor is visible for 10-20 seconds, before it vanishes. Seems to be way too long as well, but at least it vanishes.
Comment 6 Roman Eisele 2012-05-03 08:30:05 UTC
This is an Impress bug, therefore changed Component accordingly.
Comment 7 Thorsten Behrens (CIB) 2013-02-20 09:07:09 UTC
Freeing bug for EasyHack takers - the code I mentioned earlier is in vcl/aqua/source/window/salframe.cxx - needs a Mac to fiddle with this of course.
Comment 8 Jorendc 2013-04-13 22:43:43 UTC
(In reply to comment #4)
> leads to a completely unresponsive app on areas this is selected. Hm.

What do you mean with that? With quite the same patch, my application still respond the same as without it (so no regression/other behavior). (see https://gerrit.libreoffice.org/#/c/3376/ )

(In reply to comment #5)
> Tested with 3.3 final on Windows 7: The cursor is visible for 10-20 seconds,
> before it vanishes. Seems to be way too long as well, but at least it
> vanishes.

Same on Mac OSX now, with that patch.

Kind regards,
Joren
Comment 9 Commit Notification 2013-04-19 08:19:02 UTC
jorendc committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d351c59d4393aa37ab38139b3a741f15a49dbfe

fdo#31082 cursor visible during impress presentation



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Robinson Tryon (qubit) 2015-12-16 00:21:45 UTC
Migrating Whiteboard tags to Keywords: (EASYHACK, DifficultyInteresting, SkillCpp )
[NinjaEdit]