Bug Hunting Session
Bug 31096 - crash on close
Summary: crash on close
Status: RESOLVED DUPLICATE of bug 31607
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-25 02:07 UTC by Florian Effenberger
Modified: 2011-12-23 13:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
OS X crash report (42.60 KB, text/plain)
2010-10-25 02:07 UTC, Florian Effenberger
Details
crash report (43.29 KB, text/plain)
2010-11-21 05:22 UTC, Florian Effenberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Effenberger 2010-10-25 02:07:04 UTC
Every once in a while, with no identifyable pattern, LibO crashes on exiting. Attached a crashlog by OS X.
Comment 1 Florian Effenberger 2010-10-25 02:07:47 UTC
Created attachment 39758 [details]
OS X crash report
Comment 2 Florian Effenberger 2010-10-25 08:36:00 UTC
Seems to be related to a workaround try for the recent Java VM updates woes:

cd /System/Library/Java/JavaVirtualMachines
sudo ln -s ../../Frameworks/JavaVM.framework/JavaVM JavaVM

Removed the symlink, seems to work again.
Comment 3 Noel Power 2010-10-27 05:30:23 UTC
thorsten I think macos is for you ( but please push back to the list if not )
Comment 4 Thorsten Behrens (CIB) 2010-11-05 08:28:19 UTC
beta3 will have the OOo java update fix merged, local build here runs fine -> fixed.

Florian, please verify with beta3, once that's out.
Comment 5 Florian Effenberger 2010-11-21 05:22:17 UTC
Still have it with beta 3. Attaching crash report.
Comment 6 Florian Effenberger 2010-11-21 05:22:48 UTC
Created attachment 40448 [details]
crash report
Comment 7 Rainer Bielefeld Retired 2010-11-26 08:05:05 UTC
It seems currently only Florian's Mac is affected?
Comment 8 Thorsten Behrens (CIB) 2010-11-26 13:30:02 UTC
Ah, many thanks for the crash report, this really helps to distinguish duplicates - in this case, it's a dupe to bug 31607.

Florian, any chance you could help narrowing it down to a small number of steps to reliable trigger this crash (see the other bug for details)?

*** This bug has been marked as a duplicate of bug 31607 ***
Comment 9 Florian Effenberger 2010-12-04 06:21:55 UTC
Seems to work with RC1. At least had no crash with it anymore.