Bug 31304 - Fatal Error when starting LibreOffice 3.3 for the first time
Summary: Fatal Error when starting LibreOffice 3.3 for the first time
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected)
Hardware: x86 (IA32) Windows (All)
: highest critical
Assignee: Not Assigned
Depends on:
Reported: 2010-11-01 14:45 UTC by appropriatemisbehavior
Modified: 2011-01-12 06:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description appropriatemisbehavior 2010-11-01 14:45:04 UTC

Windows XP fully up to date.

I downloaded LibreOffice today. First I uninstalled OpenOffice 3.2 (I think, it was up to date) and then installed LibreOffice. I got the following message upon starup...

LibreOffice 3.3 - Fatal Error

The program cannot be started.
A general error occurred while accessing your central configuration.

I then re-ran the installation and chose repair. This time I put my Online Armor firewall in learning mode just in case it was hindering. The installation also required a system reboot this time, but not the first. I am still got the same message.

I then tried to open it using an existing .ods file. Got the same message.

If I can tell you anything else, please let me know.
Comment 1 AdamB. 2010-11-02 14:26:34 UTC
Hi i not dev or something but in your place i will check this:
1) I have installed JRE/JDE?
2) I run installation from admin account (with his privileges)?
3) Your AV my case problem (i have Kaspersky IS 2010 and when i installing i must add to trust - ofc after virus saning and check sums :).

Comment 2 appropriatemisbehavior 2010-11-02 15:36:58 UTC

Thanks for the thoughts. I do have Java installed (Oracle branded, maybe I need to look for another. I seem to remember IBM having one). I re-ran the install in Administrator mode, with the anti-virus (Avast, cannot be turned off, but the active modes can temporarily be disabled, which I did) and the firewall in learning mode. Reboot required again, and when I got back in, same result.

Thanks again,

Comment 3 AdamB. 2010-11-03 06:28:46 UTC
Ok try this, brows to C:\Documents and Settings\<your_name>\Application Data\ and delete, or zip old folders OpenOffice.org, remove LibereOffice and tray again - this bug is sometime case by old plugins.

And remove JRE/JDE from your OS in standard version you have tested JRE - ofc. after installation if will run you must select Tools -> OPTIONS/Preferences -> LO- > Java and restart( actually I using 1.6.0_22 version)-cy.
Comment 4 appropriatemisbehavior 2010-11-03 09:13:23 UTC

Ok, I gave this a try. Uninstall LibreOffice. Uninstall Java. Searched C: for any office related files/folders and deleted. Rebooted into Admin mode. Installed LibreOffice. Installed Java (both with firewall in learning mode and anti-virus disabled). Same result.

Thanks for the try.

Comment 5 AdamB. 2010-11-03 10:20:09 UTC
I think this my case by:
1) Avast, try boot in rescue mode -> after BIOS press F8, it will give two (or more) windows options. one is normal and another one is "Microsoft Windows XP Professional"(Rescue Mode) chose this and tray run LO in this spartan resolution and video acceleration.

2)You may have corrupted memory test with this using USB key :
or other : http://www.memtest.org/#screen

3) You can also check your installation files 
i Used LibO_3.3.0_beta2_Win_x86_install_multi.exe 
6fcd0216b34bd7f18b2caf59f21d702e  LibO_3.3.0_beta2_Win_x86_install_multi.exe

Or Use bittorent to check integrity :

Comment 6 appropriatemisbehavior 2010-11-03 13:25:30 UTC

I found the issue. LibreOffice worked in safe mode. I ran memtest 4.10 (something I already had) for one full pass, no errors. I then went back into regular Windows and using Task Manager, shut down everything that will shut down (something I do regularly to run MS Flight Simulator for extra memory). LibreOffice then worked.

After rebooting, I tried shutting things down one at a time, and trying LibreOffice after each. Online Armor firewall was the culprit, even though I had allowed the install and used learning mode, which should have auto created rules. After some working with the firewall for some time, I managed to get it to agree that LibreOffice was OK. It is now working.

It took more than just allowing/trusting soffice.exe and soffice.bin. Each of the different parts (calc.exe etc.) had to be allowed.

Thanks for your assistance,

Comment 7 sophie 2011-01-12 06:35:03 UTC
Closing Sophie