Download it now!
Bug 31318 - Reduce size of the Windows multi-lang installer
Summary: Reduce size of the Windows multi-lang installer
Status: RESOLVED DUPLICATE of bug 32250
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium enhancement
Assignee: Muthu
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-02 06:23 UTC by esperantisto
Modified: 2010-12-10 03:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description esperantisto 2010-11-02 06:23:10 UTC
The Windows installer comes with an infinite number of interface languages, which is unnecessary for most users and only doubles the download size. It is suggested to produce localized builds instead (i.e. containing English + another language, including the respective spellcheck/hyphenation modules, if available).
Comment 1 Thorsten Behrens (CIB) 2010-11-02 06:42:07 UTC
sadly the localized builds duplicate pretty much every bit (save some 3MB localized strings & images), for some 100+ langs worst-case - that's a 15GB weight to build, test, upload & distribute, most of which is a total waste. Therefore, the plan is to reduce the multi-lang overhead to something bearable, and distribute that instead.

Adapting title accordingly.
Comment 2 Thorsten Behrens (CIB) 2010-11-02 06:58:07 UTC
Muthu, you're working on this, I believe.
Comment 3 Don't use this account, use tml@iki.fi 2010-12-10 03:12:59 UTC

*** This bug has been marked as a duplicate of bug 32250 ***