Bug 32250 - RC1 : Windows installer (multi) wants suffficiently free space
Summary: RC1 : Windows installer (multi) wants suffficiently free space
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: x86 (IA32) Windows (All)
: highest blocker
Assignee: Fridrich Strba
URL:
Whiteboard:
Keywords: regression
: 31318 32392 (view as bug list)
Depends on:
Blocks: 31865
  Show dependency treegraph
 
Reported: 2010-12-08 23:07 UTC by Jean-Baptiste Faure
Modified: 2011-01-22 05:21 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2010-12-08 23:07:09 UTC
I test LibO for MS-Windows on a VM XP with only 4 GB virtual hard-disk. I have about 700 MB of free space. There was no problem to install beta 1,2 and 3.
There is something wrong.
For me, if LibO requires so much of free space, it is a blocker: I can't test LibO anymore on XP.
Comment 1 Don't use this account, use tml@iki.fi 2010-12-09 00:23:17 UTC
You need a bigger disk.
Comment 2 Jean-Baptiste Faure 2010-12-09 00:32:39 UTC
(In reply to comment #1)
> You need a bigger disk.

No! It worked well until this RC1. I guess there is a bug in the installer.
End users will not understand how it is possible to have a lighter office suite which require ~4 times than OOo of free space on the hard disk to install.

What has been changed in this installer since beta3 ?

Best regards. JBF
Comment 3 Petr Mladek 2010-12-09 05:12:48 UTC
Fridrich, others, could we do anything with it? 1500MB sounds too much to me.

Note that it has been nominated as 3.3 blocker.
Comment 4 Muthu 2010-12-10 02:21:52 UTC
Duplicate of bug 31318 ???
Comment 5 Jean-Baptiste Faure 2010-12-10 02:52:19 UTC
(In reply to comment #4)
> Duplicate of bug 31318 ???

Installation worked fine on the same machine and HD for beta2. So I guess there is a bug in the computation of the amount of needed free space.
Comment 6 Don't use this account, use tml@iki.fi 2010-12-10 03:12:11 UTC
It's mostly pointless to compare the disk space used by betas and release candidates, when there are changes going on that greatly affect the size of the installer, and the amount of disk space used during the installation. Nobody is claiming that the beta 2 and the rc1 would be very like each others. Of course there are changes.

Yes, this is a duplicate of bug #31318. But as this bug seems to have more excited commenters, let's resolve that one as a duplicate of this one instead, even if that is not really logical.

I still think it is ridiculous to try to run a Windnows installation and expect to be able to install any significant software on a 4 GB disk.
Comment 7 Don't use this account, use tml@iki.fi 2010-12-10 03:12:59 UTC
*** Bug 31318 has been marked as a duplicate of this bug. ***
Comment 8 Jean-Baptiste Faure 2010-12-10 03:48:34 UTC
(In reply to comment #6)
> It's mostly pointless to compare the disk space used by betas and release
> candidates, when there are changes going on that greatly affect the size of the
> installer, and the amount of disk space used during the installation. Nobody is
> claiming that the beta 2 and the rc1 would be very like each others. Of course
> there are changes.
> 
> Yes, this is a duplicate of bug #31318. But as this bug seems to have more
> excited commenters, let's resolve that one as a duplicate of this one instead,
> even if that is not really logical.
> 
> I still think it is ridiculous to try to run a Windnows installation and expect
> to be able to install any significant software on a 4 GB disk.

Hmmm, not very fair and friendly your comment :-(

My XP is on a virtual machine with nothing other than LibO or OOo. I am using this machine for QA tests. That worked fine for years until this RC1. 

Are you sure that there is not a bug in the *computation* of the needed free space ?
Comment 9 Don't use this account, use tml@iki.fi 2010-12-10 04:26:01 UTC
If you compare the size required during installation of an OOo installer that contains just one UI language to that required during the installation of a LibreOffice multi-language installer, it should not come as a surprise that the latter requires more space.
Comment 10 Petr Mladek 2010-12-10 09:11:24 UTC
I have discussed it with Fridrich and Michael. The 3.3-rc1 installer really needed 1500GB. It compressed the files twice to reduce the download size. The result was that the files were duplicated once more on the disk during the installation.

Fridrich told me that they found another solution and there should be less disk space need for the upcomming 3.3-rc2. It should be more comparable with 3.3-beta3.

I would consider this bug as fixed. Feel free to reopen it if you are not happy with 3.3-rc2.
Comment 11 Petr Mladek 2010-12-10 09:19:03 UTC
Really mark as fixed.
Comment 12 Michael Meeks 2010-12-13 03:30:12 UTC
Hi Jean:

> Are you sure that there is not a bug in the *computation* of the
> needed free space ?

Sadly so - for RC1 :-) With the WinShrink branch, as of now I expect it to be ~900Mb, and we are working on shrinking that further - though how much further is unclear to me (thus far).

HTH.
Comment 13 Michael Meeks 2010-12-13 04:07:52 UTC
A breakdown of the uncompressed space is:

http://users.freedesktop.org/~michael/uncompressed.odg

As you see, ~20% of the size is duplicate licenses (still).
Comment 14 Kohei Yoshida 2010-12-15 07:48:40 UTC
*** Bug 32392 has been marked as a duplicate of this bug. ***
Comment 15 Michael Meeks 2010-12-16 03:00:09 UTC
Fridrich removed yet more duplicated licenses, which should help some more; we still have the wizards / templates bulking us up - but this requires rather more development work to straighten out I'm afraid.

Either way - the expectation is that the net result of this is a substantially reduced disk usage for RC2 - and going forward to 3.4 there is lots more scope for shrinkage.
Comment 16 Jean-Baptiste Faure 2010-12-23 00:57:53 UTC
Hi,

Installation of rc2 without problem on my VM XP ! 
You have done a great job. Thanks.

JBF
Comment 17 Michael Meeks 2011-01-05 07:53:21 UTC
> Installation of rc2 without problem on my VM XP !
> You have done a great job. Thanks.

Thanks for the encouragement ! :-) it really makes life sweeter - anyhow there is lots more space to be saved in the multi installer, but hopefully 3.4 will give us some more wins just in the course of business around artwork eg.
Comment 18 sophie 2011-01-22 05:21:23 UTC
Closed - Sophie