Bug 31394 - "Clear Formatting" doesn't work for "Character styles"
Summary: "Clear Formatting" doesn't work for "Character styles"
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-04 13:27 UTC by quhaiyan
Modified: 2012-05-04 06:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description quhaiyan 2010-11-04 13:27:28 UTC
Writer "Clear Formatting" doesn't work

Here is how to duplicate:
[1] Open libre office writer (3.3.0)
[2] Write something like "This is a test"
[3] highlight "This"
[4] Press "F11" to open "Style and Formatting", then choose "Character style", click on "Emphasis" for instance.
[5] "This" will be colored as "Emphasis" style.
[6] Here is the problem:
From the "Style and Formatting" toolbar (not the dialog), from the drop-down list, choose "Clear formatting".
The color is still there.


[Workaround]
Use "Default" style from "Style and Formatting" dialog will clear everything.
Comment 1 Hidden 2010-11-12 11:51:50 UTC
This is intended functionality. This function has more appropriate name in MS Word, 'Revert to Style'.
Comment 2 quhaiyan 2010-11-12 13:36:27 UTC
Hi Hidden,

Thanks for your update.

In open office - Oracle version, this "Clear Formatting" function works as what I expected: all existing styles will be removed, just like the name implied "Clear Formatting". 
If the style from "styles and formatting" is not removed by "clear formatting", then this "Clear formatting" function will become self-contradiction.

I haven't use "Revert to Style" in MS. But it seems to me "Clear formatting" should not do "Revert to style", they looks different for me. 

What do you think?

best regards!
haiyan
Comment 3 Thorsten Behrens (CIB) 2010-11-18 16:08:23 UTC
There's indeed a fix in LibO, that IMO improves the behaviour:

sw-preserve-char-style-on-reset-format.diff, i#47893, alvarezp2000

(please also readup on OOo bug 47893 for background). Closing bug for the while, please make your case if you still think this should be different and/or can be improved further.
Comment 4 rdbusser 2011-07-05 22:09:49 UTC
I'm not really sure if the following is intended. Behaviour in LO 3.3.2 on Win 7:

[1] Create a style 'XYZ bullets'
[2] Add paragraph formatting (e.g. spacing above paragraph 2cm, below paragraph 2cm)
[3] Apply an list with bullets to the style in 'Outline & Numbering > Numbering Style'.
[4] Apply the style to unformatted text. Paragraph formatting appear; bullets appear.
[5] Select the paragraph, select 'Default' for paragraph style.
[6] All formatting disappears, the bullets don't.

The default style has has no numbering style, so bullets should disappear. In fact, no matter which other style is applied to the bulleted paragraph, the damn bullets don't disappear! The only way to get rid of them is manually turn them off.

Best,
Rik
Comment 5 Cor Nouws 2011-08-10 14:12:44 UTC
(In reply to comment #4)
> I'm not really sure if the following is intended. Behaviour in LO 3.3.2 on Win
> 7:

Hi Rik,

This is maybe related, but different from the original report. So you may want to make a seperate report for it?
Thanks - Cor
Comment 6 Cor Nouws 2011-08-10 14:14:14 UTC
According to comment https://bugs.freedesktop.org/show_bug.cgi?id=31394#c3, this is intended behaviour, changed on purpose.
> Close  as NotABug
Comment 7 Roman Eisele 2012-05-04 06:51:43 UTC
This is a Writer issue, therefore changed the 'Component' field accordingly.