Download it now!
Bug 31585 - Writer crashes on mail merge
Summary: Writer crashes on mail merge
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86 (IA32) Windows (All)
: high blocker
Assignee: Not Assigned
URL: http://www.openoffice.org/issues/show...
Whiteboard:
Keywords:
Depends on:
Blocks: 31865
  Show dependency treegraph
 
Reported: 2010-11-12 08:55 UTC by Eric Moret
Modified: 2019-09-25 13:03 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
ooo base file (56.77 KB, application/vnd.oasis.opendocument.base)
2010-11-12 08:55 UTC, Eric Moret
Details
ooo write file (15.48 KB, application/vnd.oasis.opendocument.text)
2010-11-12 08:56 UTC, Eric Moret
Details
writer (45.65 KB, application/x-gzip)
2018-10-29 09:46 UTC, marthasimons
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Moret 2010-11-12 08:55:52 UTC
Created attachment 40242 [details]
ooo base file

I am running ooo 3.2.1 OOO320m18 (Build:9502). I am using an odb bas file to perform a mail merge on an odt file under writer. In the mail merge Wizard, on hitting Next in step 6. (Edit Document), the Status window - creating document opens up and generates my mailing. The crash happens reliably while performing this task. I have 118 items to generate.

My error report id is: rpmrd6n

Attached are the 2 files used for this merge.
Comment 1 Eric Moret 2010-11-12 08:56:29 UTC
Created attachment 40243 [details]
ooo write file
Comment 2 Rainer Bielefeld Retired 2010-11-12 10:15:56 UTC
Reproducible with my own spreadsheet address data base and my own letter form with LibreOffice 3.3.0  -  WIN XP DE [OOO330m9 (Build:1 - build 3.2.99.2)] for printed letter (E-mail not tested yet)

After The crash further Mail Merge tests caused a hang directly after I started assistant from menu 'Tools', so I will have to reboot my PC before I will can do further tests.

Similar to <http://www.openoffice.org/issues/show_bug.cgi?id=108081>?

This is a 3.3 blocker

@Eric Moret:
Please contribute correct information concerning your OS and Platform!
Did you try E-Mail or printed letter?
Comment 3 Drew Jensen 2010-11-12 10:32:09 UTC
running Ubuntu (Studio) 10.04 (64bit), LibO 3.3 Beta 2, Sun Java 1.6.0-18.
Using the files supplied, I ran the wizard, use existing document as letters against the Query query_book, in the ODB file and got 99 files, saved together.

Finished w/ no crash here
Comment 4 Eric Moret 2010-11-12 10:34:21 UTC
I am running Windows XP Pro SP3 English, fully patched as of 11/12/2010 on a
Dell Inspiron B130 laptop.

I was doing a "Printed Letter" mail merge.
Comment 5 Rainer Bielefeld Retired 2010-11-12 23:49:57 UTC
My Libre Office lost ability to create mail merge documents after my test, now it always crashes after I started mail merge assistant. 

@Eric Moret: 
Can you confirm this additional problem?

@Drew Jensen:
So the problem seems to be limited to WIN
Comment 6 Eric Moret 2010-11-14 20:05:03 UTC
@Rainer Bielefeld:
In my case I can re-open my odt file and perform a new mail merge.

I also just found out that this issue does not happen when ooo is out
of focus. Ie I switch to chrome and browse the web while it generates
the merge and it completes without crashing. If I switch to another
ooo application however (Ie base), it will still crash!
Comment 7 Rainer Bielefeld Retired 2010-11-18 02:56:59 UTC
Still [Reproducible], my Mail Merge still is completely broken with "LibreOffice 3.3.0Beta3 - WIN XP ES [OOO330m9 (build 3.2.99.2)]". LibO stops responding after I started mail merge assistant.
Comment 8 Petr Mladek 2010-11-18 08:27:09 UTC
Hmm, I am not able to reproduce it here.

I tested it with LibO-3.3-beta3 on both SLED11-SP1-x86_64 and Windows XP. I did the following steps:

1. opened the attached elements.odt in Writer
2. selected "Tools/Mail Merge Wizard..."
3. pressed 2x "Next"  (took defaults)
4. pressed "Select Address List", added/selected elements.odb;
   pressed "OK" where needed
5. pressed 4x "Next" (took defaults)
6. selected "Save merged document"
7. pressed "Save Documents", defined file name "ttt" and pressed "Save"

Result: 

It genereated ttt_1.odf, ttt_2.odt, ttt_3.odt, ttt_4.odf
   
=> I do not see any problem.

Could you please try the same?
If the above steps work for you, please describe the steps that cause the problem to you.
Comment 9 Alex Thurgood 2010-11-18 09:04:58 UTC
I can reproduce this bug behaviour on Mac OSX 10.6.5 with LibO beta 3. 

@Petr : The problem is not one of generating the documents, because they are generated. However, these documents are not populated with the data from the corresponding database.

If I might just change how you tried to reproduce the bug : 

When you are asked which address list to select, choose the file elements.odb, and then select "Query_Book" from the list of possible tables. If you click on preview, you will see that the query executes correctly and that the table view is populated with data. There are 118 tuples.

Now carry on and do what you described in your own entry. You should notice that the documents which are generated are not populated with the data from the query to which they are bound.



Alex
Comment 10 Alex Thurgood 2010-11-18 09:13:25 UTC
On another front, I tried opening all 118 documents (each weighing in at 12kb) generated by the mail merge by loading them from the File>Open document menu and selecting them all from the File Picker.

LibO gets to loading document 95 out of the 188 and then crashes, spawning a bug report sent to Apple. At next LibO start, I get the recovery dialog (which I cancelled). I guess that this is a memory management problem within LibO and will open up another issue for this particular aspect.


Alex
Comment 11 Alex Thurgood 2010-11-18 09:17:01 UTC
I might add to all of this that LibO did not crash during document production, i.e. during mail merge, it just didn't produce those documents with the data in them. So I can't confirm here that the mailmerge causes LibO to crash, merely that it doesn't bind the data from the selected data source.

Alex
Comment 12 Petr Mladek 2010-11-18 09:59:55 UTC
Sigh, we have too many different views here:

1. It crashed in the step 6 for Eric
2. It worked for Drew
3. It creashed in the very beginning for Rainer
4. It generated wrong documents for Alex

I rather do not talk about the crash when opening all 188 at the same time. You might open separate bug if you think that it is a problem. It is possible that you just ran out of memory.

Okay, so I have questions for everyone ;-)

@Eric: Could you please try it with LibO-3.3-beta3?
       What steps are you exactly using?
       Does it produce right documents when it works (libo works out of focus)?

@Rainer: I do not see the crash on Windows with beta3, so it might be somehow 
         specific to your installation.
         Do you have anything special?
         Extra extensions?
Comment 13 Petr Mladek 2010-11-18 10:03:54 UTC
Sigh, I pressed the enter too early. More question follow:


@Rainer: It would be interesting to know it reinstallation helps or fresh user 
         configuration helps

@Alex: Did it ever worked correctly with OOo?
       I do not understand how the database entries are assigned to the form 
       fields. There is the button "Match fields" but it works only
       for the Address book.
Comment 14 Alex Thurgood 2010-11-18 10:25:05 UTC
@Petr : I have opened a separate bug report for the document load crash, so let's forget about that for the time being.

To answer your question, yes this used to work, at least in OOo 3.1. I have however just tried it in OOo 3.2.1 and I get the same result as here with LibO, i.e. no inserted bound data in each document produced, so this could be a bug that slipped in upstream.


Alex
Comment 15 Alex Thurgood 2010-11-18 10:50:10 UTC
Just created my own ODT referencing fields in a query from one of my own databases and then did the whole mailmerge assistant thing again. It worked well for me, the documents were created with the data bound to them.

So perhaps the problem lies in the ODT document provided by the OP, or the database query ?


Alex
Comment 16 Petr Mladek 2010-11-18 11:00:53 UTC
@Alex: Thanks a lot for testing. It is great that it actually works as expected.

It is possible that the provided documents did not work perfectly and needed some fixes. The original problem was that LibO freezed and Eric was not able to find that it did not work correctly.

I think that we should concentrate on the two freezes/crashes:

@Eric: Are you still able to reproduce the freeze in the wizard step 6. with LibO-3.3-beta3?

@Rainer: Is there anything special with your installation? ...
Comment 18 Eric Moret 2010-11-18 12:36:01 UTC
@Petr Mlade: Steps to reproduce are the following:
1) Create a database connection called Elements and pointing to elements.odb
2) Open elements.odt
3) Click "Data sources" button in toolbar
4) Make sure to select Elements/Queries/query_book in the database view
5) Click the "Mail Merge" button in the database toolbar
6) In the Mail Merge Wizard step 1, select the default "Use the current document"
7) In the Mail Merge Wizard step 2, select the default "Letter"
8) In the Mail Merge Wizard step 3, keep the defaults and go to next step
9) In the Mail Merge Wizard step 4, keep the defaults and go to next step
10)  In the Mail Merge Wizard step 6 (note that step 5 is grayed out and skipped) , keep the defaults and go to next step
11) In the Mail Merge Wizard step 7, keep the defaults and go to next step
12) In the Mail Merge Wizard step 8, keep the defaults and click "Save starting document" button, then click "Finish" button

I just tried using LibreOffice 3.3.0 OOO330m12 (Build:2) libreoffice-build 3.2.99.3 on Windows Vista 64 on a multicore box with 8Gb of RAM and did not see the issue in this configuration. I was able to generate the mailing without a crash and the resulting 118 pages documents got all its fields filled up as expected. I suspect that the issue may not be seen on such fast hardware but I do not have access anymore to the laptop on which I initially reported the crash.
Comment 19 Rainer Bielefeld Retired 2010-11-18 13:56:34 UTC
Some times ago I saw a similar problem with OOo (3.2?), I will check and may be reinstall during weekend.
Comment 20 Thorsten Behrens (CIB) 2010-11-18 15:47:05 UTC
Pending input from Rainer, adapting status
Comment 21 Caolán McNamara 2010-11-20 13:28:53 UTC
Add a ref to fix for proposed fix for #i114850# http://hg.services.openoffice.org/cws/mav58/rev/e9bdd049d292
Comment 22 Rainer Bielefeld Retired 2010-11-28 06:20:33 UTC
For my "hangs immediately" I filed Bug 31792; because of that problem I can't contibute anything here.
This issue is a time bomb, as long as we do not have several WIN tests without problem I continue seeing this as 3.3 blocker.
Comment 23 Erich 2010-11-29 01:22:18 UTC
Following these steps mail merge creates a document with 235 pages, every second an 'empty page' and with no data displayed on the other (identical) pages. No freeze, no hang. (Ad 5): cannot find a > "Mail Merge" button in the database toolbar < but use Extras - Mailmerge Assistant from Writer)
(Vista32, AMD Sempron, OOO330m12 (Build:2), libreoffice-build 3.2.99.3, de-DE)

(In reply to comment #18)
> @Petr Mlade: Steps to reproduce are the following:
> 1) Create a database connection called Elements and pointing to elements.odb
> 2) Open elements.odt
> 3) Click "Data sources" button in toolbar
> 4) Make sure to select Elements/Queries/query_book in the database view
> 5) Click the "Mail Merge" button in the database toolbar
> 6) In the Mail Merge Wizard step 1, select the default "Use the current
> document"
> 7) In the Mail Merge Wizard step 2, select the default "Letter"
> 8) In the Mail Merge Wizard step 3, keep the defaults and go to next step
> 9) In the Mail Merge Wizard step 4, keep the defaults and go to next step
> 10)  In the Mail Merge Wizard step 6 (note that step 5 is grayed out and
> skipped) , keep the defaults and go to next step
> 11) In the Mail Merge Wizard step 7, keep the defaults and go to next step
> 12) In the Mail Merge Wizard step 8, keep the defaults and click "Save starting
> document" button, then click "Finish" button
Comment 24 Petr Mladek 2010-11-29 08:56:19 UTC
Hmm, we have many problems here:

1. Mail merge does not start at all for Rainder -> bug #31792

2. Mail merge crashes in the step 6 when generating documents. It works on faster 
   machine with more memory. It might be related to the bug #31734. It might need 
   some bigger rework.

3. Mail merge crashes in the step 4 -> ooo issue #114850
   Fix at 
   http://hg.services.openoffice.org/cws/mav58/rev/e9bdd049d292

   Probably not related to the original problem but it might be worth backporting.
   Unfortunately, the diff is not trivial. Cedric, Caolan, what do you think?

4. The generated documents does not include the needed data. It was broken also
   with OOo-3.2.1. It helped to recreate the .odt file => it might be problem in 
   the .odt import filter, broken backward compatibility or so.
Comment 25 Rainer Bielefeld Retired 2010-11-29 10:24:00 UTC
Comments in users@de.libreoffice.org Subject 
"Serienbrief- und Dokumentlade-Probleme:"
1 User WinXP 32bit: No crash no hang with libreoffice-build 3.2.99.2
  It seems Volker Heggemann used attached test kit
I User Vista32, OOO330m12 (Build:2), libreoffice-build 3.2.99.3 
  also no crash no hang
Comment 26 Thorsten Behrens (CIB) 2010-11-29 12:32:57 UTC
Regarding problem number 2 (from Petr's list): I have a hunch that OOo bug http://qa.openoffice.org/issues/show_bug.cgi?id=112766 is related to this - any chance the people seeing this crash / problem could try with a *fresh, extension-free install*?
Comment 27 Cédric Bosdonnat 2010-11-30 02:29:10 UTC
(In reply to comment #18)
> I just tried using LibreOffice 3.3.0 OOO330m12 (Build:2) libreoffice-build
> 3.2.99.3 on Windows Vista 64 on a multicore box with 8Gb of RAM and did not see
> the issue in this configuration. I was able to generate the mailing without a
> crash and the resulting 118 pages documents got all its fields filled up as
> expected. I suspect that the issue may not be seen on such fast hardware but I
> do not have access anymore to the laptop on which I initially reported the
> crash.

I tried it here too with a big config: it worked well apart from the fact that it takes ages to generate the 118 documents.

I'm tempted to say that this is a problem inherited from OOo, but everyone knows that the mail merge needs serious perf improvements. Wouldn't it be better to consider these improvements for 3.4? It doesn't sound serious to me to want to fix all these problems at once right before the release...
Comment 28 Cédric Bosdonnat 2010-11-30 02:52:53 UTC
(In reply to comment #21)
> Add a ref to fix for proposed fix for #i114850#
> http://hg.services.openoffice.org/cws/mav58/rev/e9bdd049d292

I just pushed that patch to 3.3 branch: behind its non-trivial appearance it's a one liner fix adding an if( ) on the top of all the code of the method.
Comment 29 Cédric Bosdonnat 2010-12-08 07:51:36 UTC
Marked as fixed... feel free to reopen if it can be reproduced with newer versions
Comment 30 sophie 2011-01-12 07:59:47 UTC
closing - Sophie
Comment 31 Björn Michaelsen 2011-12-22 05:37:25 UTC
Remove infoprovider from closed and resolved bugs.
Comment 32 Björn Michaelsen 2011-12-22 05:54:37 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 33 Roman Eisele 2012-05-04 00:39:29 UTC
This is a Writer issue, therefore changed 'Component' accordingly.
Comment 36 ArtShools 2019-08-07 08:14:56 UTC Comment hidden (spam)
Comment 37 menhealthadvisor 2019-08-07 08:50:46 UTC Comment hidden (spam)
Comment 38 foodandfoodtrips 2019-09-25 13:03:20 UTC Comment hidden (spam)