Bug Hunting Session
Bug 31792 - MAILMERGE: Mail Merge Wizard hangs
Summary: MAILMERGE: Mail Merge Wizard hangs
Status: CLOSED DUPLICATE of bug 32553
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Don't use this account, use tml@iki.fi
URL: http://www.bielefeldundbuss.de/LibO/3...
Whiteboard:
Keywords:
Depends on:
Blocks: 34184
  Show dependency treegraph
 
Reported: 2010-11-20 10:28 UTC by Rainer Bielefeld Retired
Modified: 2011-05-10 05:53 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2010-11-20 10:28:10 UTC
During my tests for Bug 31585 my "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.2)]" lost ability for Mail Merge with Mail Merge Assistant. Even with an empty document LibO will stop responding without any processor load few moments after I I have started menu 'Tools - Mail Merge Wizard ...'.
I uploaded a standard Microsoft Crash report to a.m. URL, I will leave it there until end of December 2010.

Mail merge via print dialog still works without problems

I already tried to uninstall LibO, delete my user profile and reinstall - that did not help.

My 3.1.1 still creates Mail merge documents without problem.
Comment 1 Yifan Jiang 2010-11-22 02:39:41 UTC
Not reproducible on LibO 3.3 Beta3 Linux, I'll see ths when got my Windows build ready.
Comment 2 Yifan Jiang 2010-11-22 19:03:23 UTC
Hi Tor, I didn't see the problem on beta3 Windows either. Would you help to look at the log if there's something wrong there in LibO?
Comment 3 Don't use this account, use tml@iki.fi 2010-11-23 02:53:04 UTC
Sorry, that kind of crash report is useless to us, as far as I know. (At least I have no idea what to do with it.)
Comment 4 Don't use this account, use tml@iki.fi 2010-11-24 02:44:23 UTC
So is it a crash or a hang? The summary and initial description says hang, but then mentions a Microsoft crash report which presumably is generated when a process crashes.
Comment 5 Rainer Bielefeld Retired 2010-11-24 04:01:09 UTC
@Tor Lillqvist:
LibO hangs without any CPU load, stops responding. 
The MS crash report has been created because I have to terminate LibO using task manager (no other possibility), my hope was that the report might show in what situation LibO was when it was terminated with Task Manager.
Comment 6 Rainer Bielefeld Retired 2010-12-05 10:30:49 UTC
No Progress with RC1 (as I feared).
Comment 7 Volker Merschmann 2010-12-05 12:53:16 UTC
I tried with LibreOffice 3.3.0 OOO330m17 (Build:3) libreoffice-build 3.3.0.1 (aka RC1) on WinXP DE (clean installation of LO w/o any existing profile for different reason)
The mail merge assistant worked for me
Comment 8 Stefano Fraccaro 2010-12-07 05:08:45 UTC
The mail merge assistant worked for me

LibO 3.3rc1 Win XP IT
Comment 9 Stefano Fraccaro 2010-12-07 05:13:32 UTC
(In reply to comment #6)
> No Progress with RC1 (as I feared).

Can you post a FileMonitor (http://technet.microsoft.com/en-us/sysinternals/bb896645) log?
Comment 10 Rainer Bielefeld Retired 2010-12-07 05:50:43 UTC
Good Idea, I will try soon.
Comment 11 Rainer Bielefeld Retired 2010-12-12 00:00:33 UTC
Strange thing, yesterday I was able to start mail merge E-Mail several times (and so I found [Bug 32329]), but Today the hang problem is back, so today I will do the FileMonitor test.
Comment 12 Rainer Bielefeld Retired 2011-01-13 09:02:29 UTC
Same problem on my new PC: I ran through all steps of Mail Merge Wizard during my first mail merge on this PC, failed because of Bug 32329, and with my second attempt the hang is back.

Slightly loosing hope ...
Comment 13 Michael Meeks 2011-01-14 03:39:44 UTC
I wonder if this is caolan's python magic: scripting/source/pyprov/mailmerge.py at least on Unix this goes through that (for me). Caolan - any thoughts ?

For me (having entered invalid server details), I get rather a nice delay - 10 seconds or so of hang, before it returns; how patient are you Rainer ? :-)
Comment 14 Caolán McNamara 2011-01-14 03:54:11 UTC
My only thoughts are that I wish I never implemented the mailmerge backend because of the constant moaning about it. If there's a problem in the backend itself, then its such a trivial little .py that anyone can debug it. So if someone has a problem with it then just find the mailmerge.py and add a few prints in it to log to a file.
Comment 15 Rainer Bielefeld Retired 2011-01-14 11:25:17 UTC
If LibO does not hang, MM wizard appears within few seconds after Menu 'Tools -> MM-wizard'. If LibO wants to hang, it does not help to wait several minutes (It tried that).

Just I tried with an empty document, and LibO did not hang. I tried with a document with address fields, really tried to send, failed because of Bug 32329. After that UI is somehow broken, cant use scroll slider with mouse.
After termination of LibO and new start also no hang, today it works (but I also saw that with earlier LibO versions).
Comment 16 Rainer Bielefeld Retired 2011-02-11 08:44:03 UTC
Currently I can't tell whether this particular problem has been solved or only been shifted, E-Mail Mailmerge still crashes on and on and will not send E-Mails
Comment 17 Michael Meeks 2011-02-11 09:13:55 UTC
Hi Rainer; Caolan's comment is that you need to tweak the python to add some debugging information (popup dialogs or whatever) for when it fails. I've no idea how to do that, but with a few minutes of hunting it should be possible surely ?

Until we work out exactly where it is failing, not much can be done; and we simply cannot do that from here - we don't have your mail setup;

Sorry.
Comment 18 Rainer Bielefeld Retired 2011-02-11 09:22:42 UTC
@Michael Meeks:
I will try that hoping to get a hint concerning crashes in 
Bug 34187 - MAILMEGE E-Mail does not send mails

Any Ideas concerning alternative concepts to get something like a crash report?
Comment 19 Rainer Bielefeld Retired 2011-02-12 03:51:48 UTC
I set "dbg = True" in "mailmerge.py", where can I find something like a report?
Comment 20 Petr Mladek 2011-02-17 09:20:16 UTC
I think that oosplash.bin actually hides messages printed by the soffice.bin binary. Please try to run the application in a terminal using:

  /opt/libreoffice/program/soffice -no-oosplash 2>&1 | tee mailmerge-debug.log
Comment 21 Petr Mladek 2011-02-17 10:29:55 UTC
(In reply to comment #20)
> I think that oosplash.bin actually hides messages printed by the soffice.bin
> binary. Please try to run the application in a terminal using:
> 
>   /opt/libreoffice/program/soffice -no-oosplash 2>&1 | tee mailmerge-debug.log

Please forget about this. The problem is not Windows and it does not help there.

We need help from Tor.
Comment 22 Cor Nouws 2011-03-07 04:25:31 UTC
(In reply to comment #19)
> I set "dbg = True" in "mailmerge.py", where can I find something like a report?

Hi,

Caolan was so kind to help me some time ago:
  https://bugs.freedesktop.org/show_bug.cgi?id=32553#c9
Comment 23 Caolán McNamara 2011-03-18 07:02:53 UTC
I think the python emailmerge backend here is something of a red herring.

This bug talks about LibreOffice hanging on doing a emailmerge, but without an exact route to reproduce it. bug 32553 is also a hang on doing emailmerge, but with an exact route to reproduce it which I can fix, so I'm going to assume they're both the same thing.

*** This bug has been marked as a duplicate of bug 32553 ***
Comment 24 Volker Merschmann 2011-05-10 05:04:46 UTC
Rainer, please close if it is fixed.
Comment 25 Rainer Bielefeld Retired 2011-05-10 05:53:14 UTC
I will not handle this bug any longer because we have several more detailed ones.