Download it now!
Bug 32329 - [MAILMERGE] E-Mail server connection fails
Summary: [MAILMERGE] E-Mail server connection fails
Status: CLOSED DUPLICATE of bug 33355
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 RC1
Hardware: All All
: high critical
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-11 23:57 UTC by Rainer Bielefeld Retired
Modified: 2011-02-22 03:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2010-12-11 23:57:03 UTC
I have been using my POP-3 SMTP server for mail merge e-mails for years, and it seems that during my first LibO installation server details have been transferred from OOo 3.1.1, they are identical without having been touched by me, as far as I remember.

But I can't use Mail Merge E-Mail, Server connection fails. although I checked all settings (without finding any mistake), when I do 'Tools -> Options -> LibO Writer -> Mail Merge E-Mail -> Test Settnings', server connection fails with message "LibreOffice could not connect to the outgoing mail server. Check your system's settings and the settings in LibreOffice. Check the server name, the port and the secure connections settings". Additional information: "Establish network connection" failed and also "find outgoing mail server" failed.

And indeed, I was not able do send a mail merge E-mail

Same settings still work fine with OOo 3.1.1
Comment 1 Rainer Bielefeld Retired 2010-12-12 05:10:12 UTC
I was able to reproduce that on a second WIN XP PC for the same E-Mail provider (with the same settings): Works for OOo 3.1.1, but fails with LibO. Missing ability to send E-Mails seems to be a blocker for me.
Comment 2 Alex Thurgood 2011-01-09 03:43:56 UTC
This has also been confirmed by 2 users on the French user list.


Alex
Comment 3 Rainer Bielefeld Retired 2011-01-09 05:26:46 UTC
And still a problem with  "LibreOffice 3.3.0 RC2 - WIN7  Home Premium (64bit) German UI  [OOO330m18 (build 3.3.0.2)]", that has bee installed freshly on a new PC. 

Additionally the problem still is on a third XP PC. 

On all my 3 WIN PC identical settings work fine with OOo 3.1.1

We need much more efforts to find out what happens here, email mailmerge is an important application, for me it's essential. It should not be too difficult for several users to do a test.

Cédric, any Ideas how we can get some progress here?
Comment 4 Michael Meeks 2011-01-14 02:33:35 UTC
Unfortunately (or otherwise) mail merge involves tight integration with another app (the mailer) via some wooly windows interface (AFAIR).

In consequence it is extremely helpful to know what mail client you are using, and what we are trying to drive. Clearly this works ok for some people (Cor eg.)

" Tools -> Options -> LibO Writer -> Mail Merge E-Mail -> Test Settnings', server connection fails with"
message "LibreOffice could not connect to the outgoing mail server."

Right - what mail software are you using ? Outlook ? Thunderbird ? something else ? And I assume this client can connect and send/fetch mail concurrently :-)

Thanks.
Comment 5 Michael Meeks 2011-01-14 02:43:22 UTC
Wow; Tor assures me that we have custom SMTP code included that talks directly to the server, so it is perhaps not a windows / MAPI / senddoc integration issue; hmm.
Comment 6 Rainer Bielefeld Retired 2011-01-14 11:14:57 UTC
I use Seamonkey 2.0.11 as mail client. But that has nothing to do with the mail client, all evidence seems to prove that LibO handles itself communication with mailsever (or for what should it be necessary to contribute information concerning mail server, User Name, ...)
Comment 7 Rainer Bielefeld Retired 2011-01-24 21:31:13 UTC
I checked "Ooo-Dev 3.4.0 multilingual version English UI WIN XP: [OOo300m98 (Build 9568)]", now mail server connection does not work any longer with OOo.

The problem looks very similar to
<http://www.openoffice.org/issues/show_bug.cgi?id=106568>, what has been fixed.
No idea whether Issue 105669 also might have influence.


Issue 91875 seems to be concerning a different problem?
Comment 8 Cédric Bosdonnat 2011-02-01 06:06:28 UTC
(In reply to comment #7)
> I checked "Ooo-Dev 3.4.0 multilingual version English UI WIN XP: [OOo300m98
> (Build 9568)]", now mail server connection does not work any longer with OOo.
> 
> The problem looks very similar to
> <http://www.openoffice.org/issues/show_bug.cgi?id=106568>, what has been fixed.
> No idea whether Issue 105669 also might have influence.

I checked here with non SSL SMTP here and it worked. Could you give some details about your SMTP config? SSL or not, port, gmail or not?
 
> Issue 91875 seems to be concerning a different problem?

Possibly...
Comment 9 Rainer Bielefeld Retired 2011-02-02 07:52:19 UTC
@Cédric:
Please excuse me for my late response. My E-Mail-Account is "normal":
- Port 110
- Security:
  -- no STARTTLS, 
  -- no SSL/TLS
- authentication with username + Password

I will create a test account and contribute authentication data by personal mail, so that you can try under absolutely the same conditions.
Additionally (if necessary) we can meet in IRC for common testing.
Comment 10 Fabian Rodriguez 2011-02-07 17:44:44 UTC
I was able to reproduce this in Ubuntu 10.10 (using LibO from the PPA), trying to use Google's SMTP as indicated at:
http://mail.google.com/support/bin/answer.py?hl=en&answer=13287

Whatever mail server information you enter as the host, the results list always indicates "Establish network connection: succesful" (!) and "Find outgoing mail server: Failed". If I leave all the information blank, both tests succeed (!!).

I've changed this bug platform to "ALL".
Comment 11 Rainer Bielefeld Retired 2011-02-07 22:20:05 UTC
I would like to know whether anyone anywhere in the world already tested E-Mail Mailmerge successfully.

@Fabian Rodriguez 
My result still:
- Establish Network Connection: Failed
- Find outgoing mail Server: Failed
Errors: LibreOffice could not connect to the outgoing mail server. Check your system's settings and the settings in LibreOffice. Check the server name, the port and the secure connections settings

This differs from results with OOo 3.1.1, where this test works without problems.

In 
<libo install>/basis/program/mailmerge.py
I found some hints to Caolan McNamara

I also fond the string "openoffice" several times, but my pa-knowledge is absolutely 0, so I can't tell whether that might cause problems

@Caolan: Can yo contribute some hints?
Comment 12 Cédric Bosdonnat 2011-02-08 00:12:56 UTC
(In reply to comment #10)
> I was able to reproduce this in Ubuntu 10.10 (using LibO from the PPA), trying
> to use Google's SMTP as indicated at:
> http://mail.google.com/support/bin/answer.py?hl=en&answer=13287
> 
> Whatever mail server information you enter as the host, the results list always
> indicates "Establish network connection: succesful" (!) and "Find outgoing mail
> server: Failed". If I leave all the information blank, both tests succeed (!!).

The test for Gmail was perfectly validating with the opensuse package for LibreOffice 3.3.0 final here on my machine. The only trick is that I couldn't connect using the port for SSL (465), but the one using STARTTLS (587).

(In reply to comment #11)
> I would like to know whether anyone anywhere in the world already tested E-Mail
> Mailmerge successfully.

Sure, I managed to get successfully connected to my ISP's SMTP (no SSL) and Gmail's SMTP.

> In 
> <libo install>/basis/program/mailmerge.py
> I found some hints to Caolan McNamara
> 
> I also fond the string "openoffice" several times, but my pa-knowledge is
> absolutely 0, so I can't tell whether that might cause problems

The "openoffice" strings present in that file doesn't harm as they correspond to either configuration nodes that still exist or implementation names.
Comment 13 Cédric Bosdonnat 2011-02-08 07:18:23 UTC
After loads of useless investigations, I finally saw where the problem comes from. I can't reproduce the bug on opensuse builds, but I can reproduce with windows builds.

Running this simple basic command on windows intall:
oMailServiceProvider = createUnoService( "com.sun.star.mail.MailServiceProvider" )

should instanciate the python mail service provider implemented in mailmerge.py, but a css::uno::RuntimeException is thrown:

"no module named pythonloader"

That emailing problem seems to be coming from the python binding...
Comment 14 Cédric Bosdonnat 2011-02-08 07:25:12 UTC

*** This bug has been marked as a duplicate of bug 33355 ***
Comment 15 Caolán McNamara 2011-02-08 07:28:27 UTC
*ah!*, damnit I really should have guessed that. Thanks Cédric :-(
Comment 16 Rainer Bielefeld Retired 2011-02-08 07:40:42 UTC
Bug 33355 - Python scripting not available is a 3.3.1 blocker itself, so I deleted this one from the list. 

And indeed, the error messages came too quickly, I already doubted that there was a real connection check.

Thanks to all!