Bug Hunting Session
Bug 31754 - SLIDESHOW: Chart y-axis label in .ppt exceeds chart area
Summary: SLIDESHOW: Chart y-axis label in .ppt exceeds chart area
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2010-11-19 00:44 UTC by Daniil Bratashov
Modified: 2018-06-01 02:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Diagram example (36.00 KB, application/vnd.ms-powerpoint)
2010-11-19 00:44 UTC, Daniil Bratashov
Details
libreoffice-4.2-alpha with error (17.49 KB, image/png)
2013-08-02 06:19 UTC, Thomas Arnhold
Details
office 2010 without error (23.85 KB, image/png)
2013-08-02 06:20 UTC, Thomas Arnhold
Details
bug in libreoffice 4.3.1.2 (109.44 KB, image/png)
2014-10-23 18:07 UTC, Daniil Bratashov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniil Bratashov 2010-11-19 00:44:03 UTC
Created attachment 40406 [details]
Diagram example

Steps to reproduce:

* open presentation with diagram inside (basic example provided)
* enter presentation mode (F5)
* y-label in graph is misplaced and half-cut in this mode
Comment 1 Don't use this account, use tml@iki.fi 2010-11-19 03:47:17 UTC
For Thorsten?
Comment 2 Rainer Bielefeld Retired 2010-11-20 00:42:02 UTC
[Reproducible] with "test-y.ppt" and "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.2)]". Not reproducible with my own documents.

The sample document is a very particular presentation:
- PPT
- downsized chart
 -- and it's even not a simple chart, but a complete spreadsheet, 
    that has been integrated.

I tried to create an odp to reproduce the problem:
1. Created "Spreadsheet2.odt" with big chart (950x500mm filling all the screen) 
   similar to the one in the sample document 
2. Created new Presentation
3. Inserted "Spreadsheet2.odt" with chart table visible
4. Started presentation mode, problem with axis label not reproducible

You also can see other problems with sample "test-y.ppt", for example when you double click the presentation to edit it, it will suddenly be shown in its original (?) size, big size will remain after you will have left edit mode.

The reported problem is also visible with OOo 3.1.1.

The resize problem does not exist for 3.1.1, what opened my EXCEL VIEWER to show the  spreadsheet with chart.
Comment 3 Daniil Bratashov 2010-12-23 11:16:33 UTC
Also seems that axis label is shown where it should be if graph area was not resized, i.e. something wrong with label movement or label position calculation don't take into account resize of graph area.
Comment 4 Thomas Arnhold 2013-02-08 05:15:09 UTC
Same on Windows 7 Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89). Y-Axis exeeds chart area.
Comment 5 Rainer Bielefeld Retired 2013-02-08 17:56:54 UTC
No longer reproducible as particular SLIDESHOW problem with server installation of  "Version 4.1.0.0.alpha0+ (Build ID: bdfd8de57bf5767ce5c179a5e8705c7587f7b32) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-02-06_22:06:22" ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with own separate User Profile.

Now the y-axis label also in edit edit mode exceeds the chart area at the left 8same way as in more early versions in SLIDESHOW).

Same with 4.0.0.3

But still was reproducible with 3.6.5.3  

@Thomas Arnhold (In reply to comment #4):
Did you really see the label only exceeding the left chart area in SLIDESHOW?
Please consider <http://wiki.documentfoundation.org/BugReport_Details#Version>, and please always contribute information concerning your OS and if necessary
Comment 6 Thorsten Behrens (CIB) 2013-02-19 18:38:54 UTC
Odd bug. on a fresh 4.0.1 rc1 build, edit view is cut off, slideshow looks good. But unfortunately I cannot currently commit any further time to this.
Comment 7 bfoman (inactive) 2013-07-24 13:27:59 UTC
Checked with:
LO 4.2.0.0.alfa0
Build ID: 2013-06-24 own debug build 
Windows 7 Professional SP1 64 bit

Could not reproduce. Slideshow view looks exactly the same as in Powerpoint 2010.
Comment 8 Thomas Arnhold 2013-08-02 06:19:07 UTC
Reproduced with Version: 4.2.0.0.alpha0+ (d49e3805c58b2c08c5cb0483ed620ab6ef86fedd) on Windows 7 64 bit.
Comment 9 Thomas Arnhold 2013-08-02 06:19:40 UTC
Created attachment 83500 [details]
libreoffice-4.2-alpha with error
Comment 10 Thomas Arnhold 2013-08-02 06:20:02 UTC
Created attachment 83501 [details]
office 2010 without error
Comment 11 QA Administrators 2014-10-23 17:31:54 UTC Comment hidden (obsolete)
Comment 12 Daniil Bratashov 2014-10-23 18:05:33 UTC
(In reply to QA Administrators from comment #11)

It is half-fixed, now label is seen, but it is still not in the right place

tested with Libreoffice version: 4.3.1.2 on Slackware linux (-current with SBo repack of official libreoffice binaries).
Comment 13 Daniil Bratashov 2014-10-23 18:07:01 UTC
Created attachment 108309 [details]
bug in libreoffice 4.3.1.2
Comment 14 QA Administrators 2015-12-20 16:19:58 UTC Comment hidden (obsolete)
Comment 15 Daniil Bratashov 2015-12-20 16:59:18 UTC
The bug returned to original behavior shown at libreoffice-4.2-alpha with error. It is still present in LO 5.0.4 on slackware-current.
Comment 16 QA Administrators 2017-01-03 19:50:54 UTC Comment hidden (obsolete)
Comment 17 Daniil Bratashov 2017-01-03 20:37:14 UTC
It is still present on LO 5.2.4.2 (slackbuilds.org repackage for Slackware 14.2 of official RPMs) with original behavior.
Comment 18 QA Administrators 2018-06-01 02:17:21 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug