Bug 31764 - Unopkg add failed with pyUno code
Summary: Unopkg add failed with pyUno code
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected)
3.3.0 Beta3
Hardware: Other Linux (All)
: medium major
Assignee: Petr Mladek
Depends on:
Reported: 2010-11-19 06:54 UTC by Laurent Godard
Modified: 2011-01-15 04:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Note You need to log in before you can comment on or make changes to this bug.
Description Laurent Godard 2010-11-19 06:54:32 UTC
installed .deb libreoffice under ubuntu

$ /opt/libreoffice/program/unopkg add myExtension.oxt 
/opt/libreoffice/program/../basis-link/program/../ure-link/bin/uno.bin: symbol lookup error: /opt/libreoffice/program/../basis-link/program/libpyuno.so: undefined symbol: PyUnicodeUCS2_FromUnicode

ERROR: URP_Bridge : disposed
(tid=4) Unexpected connection closure

unopkg failed.

--> remembers me an old OOo story regarding python building options dealing with UTF-8 vs. UTF-16
Comment 1 Petr Mladek 2010-11-19 08:15:11 UTC
Laurent, would be possible to attach the problematic extension somewhere?
I actually do not know about any extensions written in python.
Comment 2 Petr Mladek 2010-11-19 08:30:45 UTC
I see the symbol PyUnicodeUCS2_FromUnicode in /opt/libreoffice/basis3.3/program/libpython2.6.so.1.0. This is the library distributed with LibO.

I do not see it in /usr/lib64/libpython2.6.so.1.0. This is the system python on SLED11-SP1-x86_64

I guess that it is the same under Ubuntu.

I guess that /opt/libreoffice/program/../basis-link/program/../ure-link/bin/uno.bin tries to use the system libpython2.6.so.1.0 by mistake.
Comment 3 Petr Mladek 2010-11-19 08:40:08 UTC
I see the same error message also when I press the button "Test Setting" in LibO Writer in Tools/Options.../LibreOffice Writer/Mail Merge E-mail"

So, even the internal python stuff is broken.

Rene, I think that you solved problems in this area. Do you have any idea how to go out of this?
Comment 4 Petr Mladek 2010-11-23 05:34:51 UTC
The solution seems to be trivial. It helped me to create the symlink
/opt/libreoffice/basis3.3/program/libpython2.6.so -> libpython2.6.so.1.0

It is the primary path searched by libpyuno.so, see:

--- cut ---
$/opt/libreoffice/basis3.3/program> ldd libpyuno.so 
        libpython2.6.so => /opt/libreoffice/basis3.3/program/./libpython2.6.so (0x00007faef3727000)
--- cut ---

I am going to fix the installer to create it.
Comment 5 Petr Mladek 2010-11-23 07:00:39 UTC
The installation fix is http://cgit.freedesktop.org/libreoffice/bootstrap/commit/?h=libreoffice-3-3&id=a434bc4266e148ff25b52df173da22efd27b186a

Also I have cherrypicked it into git master.
Comment 6 Yifan Jiang 2010-12-02 01:29:25 UTC
Tools->Run Macro... will also crash Libreoffice 3.3 beta3.

The link solution works also well.
Comment 7 sophie 2011-01-15 04:02:23 UTC
Closing - Sophie