Download it now!
Bug 31851 - Artifacts (vertical short lines) in PDF-Export
Summary: Artifacts (vertical short lines) in PDF-Export
Status: RESOLVED DUPLICATE of bug 37559
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-22 23:26 UTC by Rainer Bielefeld Retired
Modified: 2011-05-25 10:37 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Test kit with sampe document and PDF export results (178.16 KB, application/x-compressed)
2010-11-22 23:26 UTC, Rainer Bielefeld Retired
Details
Screenshot showing artifacts (121.46 KB, image/png)
2010-11-23 00:57 UTC, Rainer Bielefeld Retired
Details
Another test case (310.00 KB, application/x-tar)
2011-02-10 07:18 UTC, dbkblk
Details
Screenshot of pdf in Google Chrome (18.79 KB, image/png)
2011-03-09 14:25 UTC, Jeroen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2010-11-22 23:26:14 UTC
Created attachment 40492 [details]
Test kit with sampe document and PDF export results

My "LibreOffice 3.3.0Beta3 - WIN XP DE [OOO330m9 (build 3.2.99.3)]" creates ugly artifacts in PDF export, pls. see attached "sample_Libo.pdf" from Test kit: at temperature probe 10B1T nearby circle containing "T" you see 2 small vertical lines, what are not visible in original document and PDF export from OOo3.4.0-Dev. 
It seems that circles and rounded corners are affected.

Steps to reproduce:
1. open "sample.odg" from test kit
2. Click into empty area in drawing
3. Select all
4. Menu 'File -> Export to PDF - General Lossless, no checkbox checked'
   -> <Export>

It does not matter whether you export lossless or with compression.
It's a small effect, but it makes LibO DRAW useless for me.

MY PC:
Processor: AMD Athlon 64 Bit 3500+
Hauptspeicher: 1GB
Graphic Card: Nvidia GeForce 7300 LE
Monitor : 1024*768
OS: WIN XP SP3
Comment 1 Rainer Bielefeld Retired 2010-11-23 00:57:35 UTC
Created attachment 40495 [details]
Screenshot showing artifacts

New Result: I only see the artifacts with Foxit Reader, not with GSview and AR8.1 I filed a report to Foxit and asked to comment here in the Bug Report.
Comment 2 Rainer Bielefeld Retired 2010-11-23 20:56:46 UTC
The FOXIT report tag ID is #74834
Comment 3 dbkblk 2011-02-10 07:18:59 UTC
Created attachment 43203 [details]
Another test case
Comment 4 dbkblk 2011-02-10 07:23:08 UTC
Any "Draw" object with a shaded surface output a weird behavior when exported to PDF. No matter what the nature of the shading is.

If the object is converted to a bitmap, the bug is gone. However, it works great with squares but could be annoying with ovals or rounds since the corners become white (no more transparency).

I hope you'll fix that, because it reduces a lot the functionnality of Draw.

Thanks for the already hard work done : )
Comment 5 Rainer Bielefeld Retired 2011-02-10 08:10:56 UTC
@dbkblk
Might be related, might be not - "my" problem only was visible with Foxit Reader, and currently I do not us that one as default PDF reader.

BTW, I see the ugly result in your Sans "nom 2.pdf", but I always get a perfect export result from your Sans "nom 2.odg".
Comment 6 Jeroen 2011-03-09 14:25:33 UTC
Created attachment 44287 [details]
Screenshot of pdf in Google Chrome

This is a screenshot of the pdf supplied by Rainer Bielefeld in Google Chrome. You can clearly see the artefacts.
Comment 7 Jeroen 2011-03-09 14:31:24 UTC
The pdf's in Rainer Bielefeld's testkit also show artefacts in Google Chrome and TexWorks (see comment #6), so it does not look like a problem of Foxit reader. The pdf looks fine in Adobe Acrobat Prof. 8 though.

Also converting the odg myself gives a pdf with artefacts in Chrome. Looks like a bug in Draw to me.
Comment 8 Rainer Bielefeld Retired 2011-05-25 10:37:00 UTC
This one seems to be concerning the same problem like
"Bug 37559 - 1x1 extra points in some shapes violate PDF export". Please read Comment 11 and following there before you try to reproduce here!

Steps to reproduce:

1. open sample.odg from test kit here
2. at the left border you find a circle with a "T" in it at test "10B1Z"
3. Zoom that area very big
4. Click circle
5. Menu 'Modify > Ungroup'
6. Click outside drawing and then circle again (now only cicle will be selected)
7. Menu 'Modify > To Polygone'
8. Menu 'Modify > Ungroup'
9. Click 'Edit Points' in Toolbar or press <f8>
   As expected: all points will be shown
   Unexpected: 2 extra points visible outside circle just there where you see the
               fragments in my screenshot from test kit.

I mark this one as DUP because we selected much more information in Bug 37559

*** This bug has been marked as a duplicate of bug 37559 ***