Download it now!
Bug 32052 - hat, vector and tilde doesn't appear
Summary: hat, vector and tilde doesn't appear
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.3.0 Beta3
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 32782 33727 36795 (view as bug list)
Depends on:
Blocks: 31865
  Show dependency treegraph
 
Reported: 2010-12-02 07:33 UTC by Nicolau Rodrigues
Modified: 2011-12-26 12:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with formula and screenshots (19.38 KB, application/vnd.oasis.opendocument.text)
2011-01-03 12:27 UTC, tester8
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolau Rodrigues 2010-12-02 07:33:52 UTC
When preparing vectorial formulas, the vec (an arrow over a variable) a hat over a variable and the tilde over a variable doesn't appear. Only an empty box is displayed. The same happens with widehat, widevec and widetilde.

Cheers,
Comment 1 tester8 2011-01-03 12:24:13 UTC
Reproduced on RC2. Just double click on formula then click on document and you will able to see some empty boxes.

In attachment: document with formula, screenshot in OpenOffice and screenshot in LibreOffice.
Comment 2 tester8 2011-01-03 12:27:18 UTC
Created attachment 41597 [details]
Document with formula and screenshots
Comment 3 tester8 2011-01-08 15:35:44 UTC
*** Bug 32782 has been marked as a duplicate of this bug. ***
Comment 4 Caolán McNamara 2011-01-10 02:30:30 UTC
Hmm, what's the output of

fc-list |grep OpenSymbol

I'm wondering if you have an older version of the "OpenSymbol" font installed systemwide and its getting picked up before the new updated OpenSymbol font bundled with LibreOffice (and OpenOffice.org 3.3)
Comment 5 Petr Mladek 2011-01-10 04:08:26 UTC
I am not able to reproduce the problem.

Could you please provide the fc-list output as suggested by Caolan?

Also, could you please provide more information about your system?
Linux distro, windowmanager, fontfonfig version?
Comment 6 tester8 2011-01-10 06:34:57 UTC
~$fc-list | grep OpenSymbol
OpenSymbol:style=Regular

~$aptitude show ttf-opensymbol | head -n 4
Package: ttf-opensymbol
Status: installed
Automatically installed: no
Version: 1:3.2.0-7ubuntu4.1

~$aptitude show libreoffice3 | head -n 5
Package: libreoffice3
New: yes
Status: installed
Automatically installed: no
Version: 3.3.0-18

~$uname -a
Linux ONE 2.6.32-27-generic #49-Ubuntu SMP Wed Dec 1 23:52:12 UTC 2010 i686 GNU/Linux

Ubuntu 10.04 LTS, Gnome (in 32782 this bug appears on KDE), LO RC2 (unofficial .deb), OO purged before installing.

Bug reproduced with compiz turned on and off.

~$aptitude show metacity | head -n 4
Package: metacity
Status: installed
Automatically installed: no
Version: 1:2.30.1-0ubuntu1

~$aptitude show compiz | head -n 4
Package: compiz
Status: installed
Automatically installed: no
Version: 1:0.8.4-0ubuntu15

~$aptitude show fontconfig | head -n 4
Package: fontconfig
Status: установлен
Automatically installed: no
Version: 2.8.0-2ubuntu1
Comment 7 Caolán McNamara 2011-01-10 06:43:24 UTC
Yeah, its the other already installed opensymbol font which causes this problem

*** This bug has been marked as a duplicate of bug 30729 ***
Comment 8 tester8 2011-01-10 06:52:16 UTC
~$locate opens___.ttf
/opt/libreoffice/basis3.3/share/fonts/truetype/opens___.ttf
/usr/share/fonts/truetype/openoffice/opens___.ttf

I delete the second font and now all works fine.
Thank you.
Comment 9 Rainer Bielefeld Retired 2011-06-07 08:02:35 UTC
No fix!
Comment 10 Rainer Bielefeld Retired 2011-06-08 01:57:26 UTC
*** Bug 36795 has been marked as a duplicate of this bug. ***
Comment 11 Björn Michaelsen 2011-12-22 05:51:56 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 12 Laurent BP 2011-12-26 12:32:15 UTC
*** Bug 33727 has been marked as a duplicate of this bug. ***