Download it now!
Bug 32133 - Overlapping controls on Tools - Options - General panel
Summary: Overlapping controls on Tools - Options - General panel
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.3
Keywords:
: 31694 32322 (view as bug list)
Depends on:
Blocks: 31865
  Show dependency treegraph
 
Reported: 2010-12-06 04:43 UTC by Andras Timar
Modified: 2011-01-22 05:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
overlapping controls (hu) (77.06 KB, image/png)
2010-12-06 04:43 UTC, Andras Timar
Details
proposed patch (6.15 KB, patch)
2010-12-06 20:22 UTC, Kohei Yoshida
Details
general options page with modified layout (52.83 KB, image/png)
2010-12-06 20:25 UTC, Kohei Yoshida
Details
revised patch (6.09 KB, patch)
2010-12-06 20:38 UTC, Kohei Yoshida
Details
new look by the revised patch (52.82 KB, image/png)
2010-12-06 20:39 UTC, Kohei Yoshida
Details
revised patch again (8.02 KB, patch)
2010-12-06 21:24 UTC, Kohei Yoshida
Details
screenshot (linux) (48.48 KB, image/png)
2010-12-06 21:29 UTC, Kohei Yoshida
Details
layout on mac (51.57 KB, image/png)
2010-12-06 21:30 UTC, Kohei Yoshida
Details
layout on windows (50.73 KB, image/png)
2010-12-06 21:31 UTC, Kohei Yoshida
Details
Pb with Calc options under MacOS (82.58 KB, image/png)
2010-12-06 21:38 UTC, Jean-Baptiste Faure
Details
Pb with appearence options for ORB (103.70 KB, image/png)
2010-12-06 21:40 UTC, Jean-Baptiste Faure
Details
RC2 screen shot (20.23 KB, image/png)
2010-12-23 02:53 UTC, RGB
Details
Screenshot help agent button (49.82 KB, image/jpeg)
2010-12-23 04:52 UTC, Stefano Fraccaro
Details
Dialog Options->General (tab) (67.63 KB, image/jpeg)
2010-12-24 02:06 UTC, Luc
Details
patch to fix this (910 bytes, patch)
2011-01-05 09:25 UTC, Kohei Yoshida
Details
another patch to make the button wider. (900 bytes, patch)
2011-01-05 09:31 UTC, Kohei Yoshida
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2010-12-06 04:43:34 UTC
Created attachment 40825 [details]
overlapping controls (hu)

LibreOffice 3.3 RC1 on Windows, Tools - Options - General panel

The two label of the two checkboxes (Use LibreOffice dialogs and Show ODMA DMS dialogs first) are too close to each other and are overlapping in Hungarian localization. Can you put them in two lines again? If there is not enough space, you may consider removing the "Help formatting" line as the help is on the web anyway.
Comment 1 Kohei Yoshida 2010-12-06 20:22:28 UTC
Created attachment 40846 [details]
proposed patch

This patch does the following:

* Moves the ODMA check box into its own row, and pushes everything below down by one row to make room.

* Disables the ODMA check box on non-Windows platforms, instead of hiding it.

* Slightly moves the 'Enable experimental features' check box to align it better.
Comment 2 Kohei Yoshida 2010-12-06 20:25:26 UTC
Created attachment 40847 [details]
general options page with modified layout

This is how the page looks after the change.
Comment 3 Kohei Yoshida 2010-12-06 20:38:01 UTC
Created attachment 40848 [details]
revised patch

Slightly fixed spacing to make it look a bit better.
Comment 4 Kohei Yoshida 2010-12-06 20:39:35 UTC
Created attachment 40849 [details]
new look by the revised patch

This is how it looks now.
Comment 5 Kohei Yoshida 2010-12-06 20:53:00 UTC
Ahh, forget it.  This patch will push the "enable experimental features" check box outside the visible area on Mac!
Comment 6 Kohei Yoshida 2010-12-06 21:09:32 UTC
Ok.  I have no choice but to remove the Help formatting option.
Comment 7 Kohei Yoshida 2010-12-06 21:24:42 UTC
Created attachment 40850 [details]
revised patch again

revised patch.  This removes the controls for the formatting help.
Comment 8 Kohei Yoshida 2010-12-06 21:29:11 UTC
Created attachment 40851 [details]
screenshot (linux)

New layout on Linux.
Comment 9 Kohei Yoshida 2010-12-06 21:30:59 UTC
Created attachment 40852 [details]
layout on mac

New layout on Mac which enables the print dialog option and disable the ODMA option.  The screenshot was taken on Linux.
Comment 10 Kohei Yoshida 2010-12-06 21:31:41 UTC
Created attachment 40853 [details]
layout on windows

New layout on Windows which enables the ODMA check box but disables the print dialog option.
Comment 11 Jean-Baptiste Faure 2010-12-06 21:37:12 UTC
Hi,

There is the same sort of problem under MacOS for Calc options.
And for all OS in Options > LibreOffice > Appearence for ORB item.

Best regards. JBF
Comment 12 Jean-Baptiste Faure 2010-12-06 21:38:23 UTC
Created attachment 40854 [details]
Pb with Calc options under MacOS
Comment 13 Jean-Baptiste Faure 2010-12-06 21:40:25 UTC
Created attachment 40855 [details]
Pb with appearence options for ORB
Comment 14 Kohei Yoshida 2010-12-06 21:49:45 UTC
Please file a separate bug for that.  Handling all of this in a single bug would make the patch size bigger, making it harder on the reviewer.

Thanks.
Comment 15 Katarina Behrens 2010-12-07 01:56:31 UTC
*** Bug 31694 has been marked as a duplicate of this bug. ***
Comment 16 Jan Holesovsky 2010-12-07 07:22:16 UTC
Kohei: Thank you!  I've signed that off & pushed.  When it appears in master, we should clean up all that cut'n'paste in that file ;-)
Comment 17 Jean-Baptiste Faure 2010-12-07 13:07:07 UTC
(In reply to comment #14)
> Please file a separate bug for that.  Handling all of this in a single bug
> would make the patch size bigger, making it harder on the reviewer.
> 
> Thanks.

Ok, done. Bugs reports:
- https://bugs.freedesktop.org/show_bug.cgi?id=32197
- https://bugs.freedesktop.org/show_bug.cgi?id=32198

Thanks. JBF
Comment 18 Rainer Bielefeld Retired 2010-12-11 23:36:33 UTC
Modified VERSION due to information from DUPs
Comment 19 Rainer Bielefeld Retired 2010-12-11 23:38:21 UTC
*** Bug 32322 has been marked as a duplicate of this bug. ***
Comment 20 RGB 2010-12-23 02:52:22 UTC
Problem is still present on RC2 under 64 bits Linux. A screenshot will follow.
Comment 21 RGB 2010-12-23 02:53:44 UTC
Created attachment 41396 [details]
RC2 screen shot
Comment 22 RGB 2010-12-23 02:57:07 UTC
(In reply to comment #20)
> Problem is still present on RC2 under 64 bits Linux. A screenshot will follow.

Forgot to mention: kde user here (4.3.5). I also renamed libvclplug_kdelx.so on basis-link/program folder to force LibO use gtk plugin, but there is no difference.
Comment 23 Stefano Fraccaro 2010-12-23 04:52:44 UTC
Created attachment 41398 [details]
Screenshot help agent button

Text of "Recovery help agent" button is not fully readable in italian, need bigger width
Comment 24 Stefano Fraccaro 2010-12-23 04:56:51 UTC
Screenshot from LibO RC2 in Windows XP

(In reply to comment #23)
> Created an attachment (id=41398) [details]
> Screenshot help agent button
> 
> Text of "Recovery help agent" button is not fully readable in italian, need
> bigger width
Comment 25 Rainer Bielefeld Retired 2010-12-23 10:31:52 UTC
@RGB:
What information do you have that the fix should have been integrated into code for RC2?
Comment 26 RGB 2010-12-23 12:04:02 UTC
(In reply to comment #25)
> @RGB:
> What information do you have that the fix should have been integrated into code
> for RC2?

The same info you provide on the report: i.e. no info. If the fix was not integrated on a release provided two weeks after the fix itself (which means a "release candidate" was known to be a "bad candidate"), then a short statement on the report itself (or the release notes) could help to avoid confusion.
Comment 27 RGB 2010-12-23 16:32:04 UTC
Just installed LibO 3.3rc2 from openSUSE repo and the problem is not present there.
Comment 28 Rainer Bielefeld Retired 2010-12-23 23:54:48 UTC
@RGB:
So it might be useful to check before reopening. Here I see "target:3.3", and that's later than 3.3 RC2. 

I left a hint and request on 
<http://wiki.documentfoundation.org/BugReport_Details#Whiteboard>
and in [Libreoffice] mailing list.

I would like to close the bug for now, but your comment concerning openSUSE makes me hesitating.
Comment 29 Rainer Bielefeld Retired 2010-12-24 01:39:04 UTC
Bug 32633 seems to show a similar problem
Comment 30 Luc 2010-12-24 02:06:29 UTC
Created attachment 41415 [details]
Dialog Options->General (tab)
Comment 31 Luc 2010-12-24 02:07:16 UTC
I just uploaded the screenshot (Dutch) from RC2. The bug is still present. So please don close this report.
Comment 32 Petr Mladek 2011-01-04 07:37:29 UTC
I can reproduce the problem from the comment #23, so we should make the button bigger.

Also, I see the problem from the comment #30. It is broken in KDE and plain desktop. It works fine in GNOME and Windows. So, the new layout broke the dialog in many window managers. You might try is using:

   OOO_FORCE_DESKTOP=none /opt/libreoffice/program/soffice

Kohei, could you please have a look?
Comment 33 Kohei Yoshida 2011-01-05 09:03:34 UTC
BTW how does the dialog look on Mac?  Anyone?
Comment 34 Kohei Yoshida 2011-01-05 09:25:43 UTC
Created attachment 41671 [details]
patch to fix this

There was indeed a mis-calculation when re-locating the controls, which pushed the controls way too much upward.

The bug did not affect Gnome and Windows which both implement native file picker, which in turn makes the "use libreoffice file open dialog" check box visible.  When that check box is visible, it skips parts of the re-location code where the bug was.
Comment 35 Kohei Yoshida 2011-01-05 09:31:35 UTC
Created attachment 41673 [details]
another patch to make the button wider.

This will make the Reset help agent button wider by 20 pixels.  I didn't verify to see the Italian text fit, but hopefully that's plenty enough space.
Comment 36 Kohei Yoshida 2011-01-05 12:57:33 UTC
Ok.  Petr has signed off both my patches.  They are now in the 3.3 branch.
Comment 37 Luc 2011-01-21 10:28:17 UTC
(In reply to comment #36)
> Ok.  Petr has signed off both my patches.  They are now in the 3.3 branch.


Bug fixed in RC4
OOO330m19 (Build:6)  (Dutch, NL version)
Comment 38 sophie 2011-01-22 05:03:19 UTC
Verified - Closed - Sophie