Download it now!
Bug 32204 - Calc objects (calc8), with text-wrap enabled, pasted into Writer docs display/print INCORRECT CONTENT
Summary: Calc objects (calc8), with text-wrap enabled, pasted into Writer docs display...
Status: RESOLVED DUPLICATE of bug 32236
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-07 17:18 UTC by _
Modified: 2011-12-23 15:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
localc_wrap.ods.zip, spreadsheet used in example (7.41 KB, application/zip)
2010-12-08 08:46 UTC, _
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ 2010-12-07 17:18:34 UTC
Steps to reproduce:

(i) open a new Calc spreadheet
(ii) paste a sentence into two cells
(iii) turn OFF text-wrap for one cell, resize to fit
(iv) turn ON text-wrap for the other, reduce column width to force wrap.

  e.g.,

    http://img30.imageshack.us/img30/7898/localc.png

(v) open a new Writer doc
(vi) copy-n-paste (insert as 'calc8' object) each invidual cell from Calc sheet into Writer doc

now, NOTE:

(1) the UNwrapped cell pastes/displays correctly
(2) the WRAPPED cell pastes, but displays content INCORRECTLY, wrapping/overwriting lines with prior text
(3) if EDIT of the incorrectly displayed cell is enabled, the contents are CORRECTLY display -- only in EDIT mode.  closing EDIT mode, returning back to display returnns back to the incorrect display

e.g.,

  http://img821.imageshack.us/img821/5635/lowriter.png


i.e., any/all Calc sheets with text-wrap ON fail to dislpay correctly in Writer, atm.

fyi, i'm running,

 LibreOffice 3.3.0
 OOO330m17 (Build:3)
 libreoffice-build 3.3.0.1

installed from pkgs,

 rpm -qa | egrep -i "office-3.3|office-writer"
  libreoffice-writer-extensions-3.3.0.1-12.1.x86_64
  libreoffice-writer-3.3.0.1-12.1.x86_64
  libreoffice-3.3.0.1-14.2.x86_64

on,

 lsb_release -a
  LSB Version:    core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch
  Distributor ID: SUSE LINUX
  Description:    openSUSE 11.3 (x86_64)
  Release:        11.3
  Codename:       n/a

sourced from pkg repos @,

 http://download.opensuse.org/repositories/LibreOffice:/Unstable/openSUSE_11.3
Comment 1 Petr Mladek 2010-12-08 03:21:52 UTC
dev001, could you please attach a sample spreadsheet that could be use to reproduce the bug. It would help developers to debug this problem...
Comment 2 _ 2010-12-08 08:46:46 UTC
Created attachment 40924 [details]
localc_wrap.ods.zip, spreadsheet used in example

as requested, actual spreadsheet attach for http://img30.imageshack.us/img30/7898/localc.png
Comment 3 _ 2010-12-10 12:02:26 UTC
fyi,

if instead of formatting the cell to AUTO-wrap, i turn OFF autowrap, then in-cell edit the text to multiple lines with hard-returns (Ctrl-Return), and then calc8-paste the spreadsheet cells into a text document, as described above, the display-mode & edit-mode views of the now manually-wrapped, multi-line cells are both correct/consistent.
Comment 4 Cédric Bosdonnat 2010-12-13 05:56:20 UTC
Duplicate and fixed in the meantime

*** This bug has been marked as a duplicate of bug 32236 ***