Download it now!
Bug 32313 - Crashing Open document instance, no FILEOPEN
Summary: Crashing Open document instance, no FILEOPEN
Status: RESOLVED DUPLICATE of bug 31109
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-11 02:46 UTC by skimble04
Modified: 2013-11-23 13:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace soffice (1.48 KB, application/x-xz)
2011-03-26 11:37 UTC, sigstop
Details
strace (11.36 KB, application/x-xz)
2011-03-26 11:38 UTC, sigstop
Details

Note You need to log in before you can comment on or make changes to this bug.
Description skimble04 2010-12-11 02:46:39 UTC
When attempting to open the 'open document folder' gui, it crashes with a sigserv of 11 but no backtrace, which apperas to be turned off. The usage of the cpu then climbs until its all being used by a swriter instance and has to be killed off manually to regain control of the machine. Being unable to open any files is a real show stopper!

This is on CentOS 5.5 currently up to date.
Comment 1 Cédric Bosdonnat 2010-12-16 02:08:12 UTC
Without more information, I fear we can't help here.
Please read:
http://wiki.documentfoundation.org/BugReport

And submit the gdb backtrace.
Comment 2 skimble04 2010-12-16 11:33:51 UTC
I am using KDE, and it is with OOo writer running in another desktop. LO is now refusing to open the File > open document gui, but i know from past exeperience that it would refuse to open it, crashing instead with a SIGSERV
Comment 3 skimble04 2010-12-16 11:44:03 UTC
(In reply to comment #2)
> I am using KDE, and it is with OOo writer running in another desktop. LO is now
> refusing to open the File > open document gui, but i know from past exeperience
> that it would refuse to open it, crashing instead with a SIGSERV of 11 and no backtrace saying that it appears to have been compiled with backtrace turned off. 

This is using LibreOffice 3.3.0 
OOO330m9 (Build:1)
libreoffice-build 3.2.99.2, and the same thing happens with LO RC1.

I have tried deleting the .libreoffice folder in KDE thinking that it was some problem with my local settings, so i went with the default ones but it still refuses to work. I have checked my path and it is pointing correctly to my documents folder, and dont know what to do next.
Comment 4 Jan Holesovsky 2010-12-20 20:40:29 UTC
Please, what does it mean 'it is with OOo writer running in another desktop'?  Like, that you run both OOo and LO at the same time?  What if you turn off OOo, do you still see the bug?

Also - we really need to see the gdb backtrace, see comment 1.

Thank you!
Comment 5 skimble04 2010-12-21 00:39:52 UTC
On 21 December 2010 08:36, Sharon Kimble <skimble04@gmail.com> wrote:
>
> Yes, OOo is running in another desktop on the machine, along with LO both at the same time. And it makes no difference if i unload OOo, i still cannot open any document in LO.
> gdb log attached.
>
> Thank you
> Sharon.
>
> On 21 December 2010 04:40, <bugzilla-daemon@freedesktop.org> wrote:
>>
>> https://bugs.freedesktop.org/show_bug.cgi?id=32313
>>
>> --- Comment #4 from Jan Holesovsky <kendy@suse.cz> 2010-12-20 20:40:29 PST ---
>> Please, what does it mean 'it is with OOo writer running in another desktop'?
>> Like, that you run both OOo and LO at the same time?  What if you turn off OOo,
>> do you still see the bug?
>>
>> Also - we really need to see the gdb backtrace, see comment 1.
>>
>> Thank you!
>>
>> --
>> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
>> ------- You are receiving this mail because: -------
>> You are on the CC list for the bug.
>> You reported the bug.
>
>
>
> --
> A taste of linux http://www.sharons.org.uk/taste/index.html
> efever http://www.efever.blogspot.com/
> Centos 5.5, KDE 3.5.4-25, OpenOffice 3.2.1
> Registered Linux user 334501



--
A taste of linux http://www.sharons.org.uk/taste/index.html
efever http://www.efever.blogspot.com/
Centos 5.5, KDE 3.5.4-25, OpenOffice 3.2.1
Registered Linux user 334501
Comment 6 skimble04 2010-12-23 14:15:29 UTC
And i've just downloaded the 3.3 RC 2 and installed that, and that has
the same problem too, i cant open any files!

Sharon.

On 21 December 2010 08:39, Sharon Kimble <skimble04@gmail.com> wrote:
> On 21 December 2010 08:36, Sharon Kimble <skimble04@gmail.com> wrote:
>>
>> Yes, OOo is running in another desktop on the machine, along with LO both at the same time. And it makes no difference if i unload OOo, i still cannot open any document in LO.
>> gdb log attached.
>>
>> Thank you
>> Sharon.
>>
>> On 21 December 2010 04:40, <bugzilla-daemon@freedesktop.org> wrote:
>>>
>>> https://bugs.freedesktop.org/show_bug.cgi?id=32313
>>>
>>> --- Comment #4 from Jan Holesovsky <kendy@suse.cz> 2010-12-20 20:40:29 PST ---
>>> Please, what does it mean 'it is with OOo writer running in another desktop'?
>>> Like, that you run both OOo and LO at the same time?  What if you turn off OOo,
>>> do you still see the bug?
>>>
>>> Also - we really need to see the gdb backtrace, see comment 1.
>>>
>>> Thank you!
>>>
>>> --
>>> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
>>> ------- You are receiving this mail because: -------
>>> You are on the CC list for the bug.
>>> You reported the bug.
>>
>>
>>
>> --
>> A taste of linux http://www.sharons.org.uk/taste/index.html
>> efever http://www.efever.blogspot.com/
>> Centos 5.5, KDE 3.5.4-25, OpenOffice 3.2.1
>> Registered Linux user 334501
>
>
>
> --
> A taste of linux http://www.sharons.org.uk/taste/index.html
> efever http://www.efever.blogspot.com/
> Centos 5.5, KDE 3.5.4-25, OpenOffice 3.2.1
> Registered Linux user 334501
>
Comment 7 Jan Holesovsky 2010-12-28 06:28:56 UTC
BTW, is that KDE3, or KDE4?

What if you enable Tools -> Options... -> General -> Use LibreOffice dialogs, does it stop crashing then?
Comment 9 skimble04 2010-12-29 20:01:18 UTC
On 28 December 2010 14:28,  <bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=32313
>
> --- Comment #7 from Jan Holesovsky <kendy@suse.cz> 2010-12-28 06:28:56 PST ---
> BTW, is that KDE3, or KDE4?

KDE 3.5.4.-25

> What if you enable Tools -> Options... -> General -> Use LibreOffice dialogs,
> does it stop crashing then?

Well, I'll be blowed! The open files dialog works without any problem
and i can open files with it! Thanks, problem solved! But it sounds
like there is a bug in the program that this workaround sorts out, but
thanks, i'm now a happy bunny again!

Sharon.
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.
>
Comment 10 skimble04 2010-12-29 20:02:42 UTC
On 28 December 2010 14:31,  <bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=32313
>
> --- Comment #8 from Jan Holesovsky <kendy@suse.cz> 2010-12-28 06:31:21 PST ---
> Also, an strace and a backtrace might help here:
>
> http://wiki.documentfoundation.org/BugReport#How_to_get_strace_log_.28on_Linux.29
> http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29
>
Jan.
Do you still want the strace and backtrace in view of the fact that
the problem is now solved?

Sharon.

> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.
>
Comment 11 sigstop 2011-03-26 11:37:07 UTC
Created attachment 44892 [details]
backtrace soffice

Sorry, no symbols, don't have the computer and bandwidth to build my own.
LibreOffide 3.3.1 (on Slackware from original rpms)
Comment 12 sigstop 2011-03-26 11:38:04 UTC
Created attachment 44893 [details]
strace

strace of file open dialog (LibreOffice 3.3.1 on Slackware from original rpms)
Comment 13 sigstop 2011-03-26 11:44:58 UTC
I had the same problem, using LibreOffice's own dialogs fixes the problem. Nevertheless, at first it worked for "several" times (installed today). I didn't do any substantial (root) changes between working/not-working states.
Simply moving ~/.libreoffice didn't help either.

German language-package is installed, setting to English (USA) didn't help.

I use LibreOffice 3.3.1 (from original rpms) on Slackware 13.37. Sorry, no debug symbols, strace and gdb-bt attached.
Comment 14 sigstop 2011-03-26 11:50:48 UTC
(In reply to comment #13)
> I had the same problem, using LibreOffice's own dialogs fixes the problem.
> Nevertheless, at first it worked for "several" times (installed today). I
> didn't do any substantial (root) changes between working/not-working states.
> Simply moving ~/.libreoffice didn't help either.
> 
> German language-package is installed, setting to English (USA) didn't help.
> 
> I use LibreOffice 3.3.1 (from original rpms) on Slackware 13.37. Sorry, no
> debug symbols, strace and gdb-bt attached.

And I don't use a major gui (evilwm), it doesn't have its own dialogs if that matters. But as I said, it worked before.

To OP: Please post your traces as this is not solved/fixed but circumnavigated.
Comment 15 Petr Mladek 2011-05-02 08:39:37 UTC
It looks similar to the bug 31109 and should get fixed in 3.3.3 release.

Feel free to reoplen this bug if it does not work there.

*** This bug has been marked as a duplicate of bug 31109 ***
Comment 16 Björn Michaelsen 2011-12-22 05:36:43 UTC
Remove infoprovider from closed and resolved bugs.
Comment 17 Björn Michaelsen 2011-12-22 05:53:09 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.