Download it now!
Bug 32368 - Link both Ctrl+Y as Ctrl+Shift+Z as shortcut keys for Redo
Summary: Link both Ctrl+Y as Ctrl+Shift+Z as shortcut keys for Redo
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Jorendc
URL:
Whiteboard: target:4.1.0
Keywords:
: 64444 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-13 18:30 UTC by Chris Wilson
Modified: 2013-05-14 16:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Wilson 2010-12-13 18:30:33 UTC
In most Gnome applications, Undo actions are performed with the CTRL+Z keyboard shortcut and Redo actions can be performed with CTRL+SHIFT+Z. In LibreOffice, Undo is CTRL+Z but Redo is CTRL+Y. This is an inconsistency in the user experience and can lead to some frustration among users who used Gnome based desktops and are used to the keyboard shortcuts used there.
Comment 1 Yifan Jiang 2010-12-13 21:39:02 UTC
Enhancement request. 

It is also interesting to know if any emacs users feel uncomfortable with C-Y to redo? :)
Comment 2 Cédric Bosdonnat 2010-12-14 00:38:53 UTC
Well, do we want different shortcuts for each and every desktop?
Comment 3 Yifan Jiang 2010-12-14 01:32:09 UTC
Hi Chris, 

Does the customize short-cut key(Tool->customize->keyboard) help to resolve the problem? The C-S-z seems not natively occupied by other functions in LibO.
Comment 4 Chris Wilson 2010-12-14 02:42:57 UTC
Hi Yifan,

I hadn't realised LibreOffice and OpenOffice weren't native Gnome applications as I don't use word processors (LaTeX for me). I'm doing work downstream in Ubuntu and someone reported this bug to us and I reported it here so it could be fully triaged.

I'll suggest that we modify the shortcut key ourselves when we ship the package.
Comment 5 Diggory Hardy 2011-04-29 08:42:44 UTC
Hi all,

Well, Ctrl+Shift+Z is also the standard KDE shortcut for redo, so I don't think it's quite necessary to have a different shortcut for every desktop. Since Ctrl+Shift+Z doesn't have any other assignment in LibreOffice, isn't it reasonable to add that as a shortcut for redo?

The other point about platform-specific modifications is another way to go about this kind of thing, but it does have one drawback: LibreOffice won't behave the same way across platforms. If I ever use applications like firefox or libreoffice on Windows, I expect them to behave in the way that I'm used to on linux, and I expect most people do too (within reason).
Comment 6 Jorendc 2013-05-10 20:34:48 UTC
*** Bug 64444 has been marked as a duplicate of this bug. ***
Comment 7 Hugo Osvaldo Barrera 2013-05-10 21:02:33 UTC
(In reply to comment #5)
> [...]
> The other point about platform-specific modifications is another way to go
> about this kind of thing, but it does have one drawback: LibreOffice won't
> behave the same way across platforms. If I ever use applications like
> firefox or libreoffice on Windows, I expect them to behave in the way that
> I'm used to on linux, and I expect most people do too (within reason).

I belive there's probably more *nix-only users, than users that constantly switch between platforms.
Since you mentioned firefox, it too uses Ctrl+Shift+Z for redo on *nix.

I don't expect LO to behave the same on OSX either, since the standard there is Cmd+Shift+Z (and there isn't even ctrl to do Ctrl+Y).

Since Ctrl+Shift+Z is not occupied by default, LO could just ship both hotkeys (Ctrl+Shift+Z AND Ctrl+Y). That would satisfy constantly-OS-switching users as well.
Comment 8 Jorendc 2013-05-10 21:07:20 UTC
I don't know it's possible to link 2 shortcut keys to one action.

I asked on the UX-advice (user experience advice) mailinglist for advice/input (see http://lists.freedesktop.org/archives/libreoffice-ux-advise/2013-May/002033.html)

Kind regards,
Joren
Comment 9 Jorendc 2013-05-11 10:43:05 UTC
UX-advice recommended to link both ctrl+y and ctrl+shift+z to the redo command. So I send a patch to gerrit for review: https://gerrit.libreoffice.org/#/c/3853/

Kind regards,
Joren
Comment 10 Commit Notification 2013-05-14 14:33:44 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=833cafe4eb9e0bd6b599e8bcbb6d77f4f2243034

fdo#32368 - Link both Ctrl+Y as Ctrl+Shift+Z as shortcut keys for Redo



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Jorendc 2013-05-14 16:57:48 UTC
Part of my commit message:

As discussed on the UX-advice and bug report itself,
we agreed to link both shortcut keys to the redo command.

Due http://opengrok.libreoffice.org/xref/core/framework/source/inc/accelerators/acceleratorcache.hxx#75 :
/*map commands to keys in relation 1:n. First key is interpreted as preferred one!*/ the shortcut key that is mentioned in the menu entry is ctrl+y (or cmd+y for Mac users).

So for everyone: you will still see ctrl+y as shortcut key in the menu entries, but ctrl+shift+z is also a Redo-command now. (it isn't possible to show 2 shortcuts in the menu entry).

Kind regards,
Joren