Bug 32435 - MSI branding not locale sensitive
Summary: MSI branding not locale sensitive
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: Other All
: medium blocker
Assignee: Michael Meeks
URL:
Whiteboard:
Keywords:
: 32389 (view as bug list)
Depends on:
Blocks: 31865
  Show dependency treegraph
 
Reported: 2010-12-16 03:53 UTC by Michael Meeks
Modified: 2011-01-23 03:29 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Neutral branding for installer (50.81 KB, image/bmp)
2011-01-09 11:49 UTC, Christoph
Details
Neutral branding for installer (ooobanner) (5.77 KB, image/bmp)
2011-01-09 11:51 UTC, Christoph
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2010-12-16 03:53:57 UTC
As above, while the initial NSIS wrapper is branded correctly for BrOffice in RC2 the internal MSI file continues to have LibreOffice artwork branding for pt-BR, with string branding for BrOffice ;-)

More work is required to unwind quite how to brand an MSI file per locale.
Comment 1 Michael Meeks 2011-01-06 02:11:39 UTC
*** Bug 32389 has been marked as a duplicate of this bug. ***
Comment 2 Michael Meeks 2011-01-06 02:26:00 UTC
So - I don't believe we have time for .0 to sort out the internal MSI branding to be per locale.

What I suggest is that we leave the external (ie. NSIS / first-page) branding to be per-locale (as now) - so we will see LibreOffice, and/or BrOffice artwork first.

And then - for the MSI, we have only text branding (in the title / install text), and non-branded install artwork: at least for the first release; this seems the only realistic option now.
Comment 3 Michael Meeks 2011-01-07 13:54:48 UTC
Christophe created some nice de-branded draft images; as/when we have them we just need to drop them into the instsetoo_native and do some testing I think.
Comment 4 Christoph 2011-01-09 11:49:57 UTC
Created attachment 41807 [details]
Neutral branding for installer
Comment 5 Christoph 2011-01-09 11:51:00 UTC
Created attachment 41809 [details]
Neutral branding for installer (ooobanner)
Comment 6 Christoph 2011-01-09 11:54:36 UTC
Added the current versions of rather neutral TDF branded product artwork for the installer.

SVG source graphics and exported PNG/BMP graphic elements available at:
http://wiki.documentfoundation.org/File:LibreOffice-Initial-Artwork-Package.zip

Off-topic note: The remaining artwork has not yet been updated to match the graphic file names in GIT. Work topic has been added for Marketing/Design Team.
Comment 7 Michael Meeks 2011-01-10 03:30:36 UTC
Christophe - thank you so much for that ! :-) looks beautiful. Just checked it in, will be in RC3.
Comment 8 Michael Meeks 2011-01-10 04:56:19 UTC
verified in a test build.
Comment 9 sophie 2011-01-23 03:29:55 UTC
Closing - Sophie