Bug 32517 - EDITING: Writer with Runtime Error Dialog in scrolling of .doc file
Summary: EDITING: Writer with Runtime Error Dialog in scrolling of .doc file
Status: RESOLVED DUPLICATE of bug 31243
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC3
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-19 22:01 UTC by lindrix
Modified: 2011-03-23 08:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Doc file in the crash (311.50 KB, application/msword)
2010-12-20 16:24 UTC, lindrix
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lindrix 2010-12-19 22:01:16 UTC
Hi. My LibreOffice/BrOffice copy´s showing a runtime error when i am scrolling a .doc file of 33 pages in the Writer. In link below it have screenshot sequence of the error:

1: page 22:
http://picasaweb.google.com/lh/photo/DHT4jWAr_Dxml14iszngVw?feat=directlink

2: page 22/23: error: 
http://picasaweb.google.com/lh/photo/tnCY8CFcFyO_rv8ohogBtQ?feat=directlink

3: page 22/23: error with video blurred: 
http://picasaweb.google.com/lh/photo/En3tVtz-_vb_fTXVD5GFBg?feat=directlink

Thanks you by yours attention.
Comment 1 Yifan Jiang 2010-12-19 23:01:49 UTC
@lindrix: would you help to attach the original problem doc? The screenshot does not give much help.

If the problem is happening on a specific file only, we could hardly treat it as a blocker. Please refer to the following for more details:

http://wiki.documentfoundation.org/Release_Criteria

Would you help confirm that? Thanks.
Comment 2 lindrix 2010-12-20 16:24:35 UTC
Created attachment 41326 [details]
Doc file in the crash

Here the file involved at crash.
Comment 3 lindrix 2010-12-20 16:40:00 UTC
@Yifan:

The bug induce a crash in writer, having done the closing total of others instances of aplication.

Reality i do refering as blocker, and it happened with a .doc file.

I happened what you me help to report this bug or to find the cause.
Comment 4 Jan Holesovsky 2010-12-20 21:08:15 UTC
Reproduced on Linux with the attached file.
Comment 5 Jan Holesovsky 2010-12-20 21:24:22 UTC
Actually, this is fixed by the fix of bug 31243 in RC2, so closing.  Thank you for the report!
Comment 6 lindrix 2010-12-20 22:24:55 UTC
beauty! earned!
Comment 7 lindrix 2010-12-25 13:49:17 UTC
Friends,
I am installed the rc2 version of libreoffice, but the bug what i am reported it continues. Dialog error runtime not show, but libreoffice warns what going to reboot (crash).
Comment 8 lindrix 2010-12-25 13:50:48 UTC
The file what cause the bug is in attachments.
Comment 9 sophie 2011-01-14 03:30:18 UTC
Lindrix, I've verified under RC3 and can't reproduce the issue. I'm closing the bug, please reopen if you still meet problems - Sophie
Comment 10 PEDoX 2011-01-17 10:30:01 UTC
(In reply to comment #7)
> but libreoffice warns what going
> to reboot (crash).

I have same bug on Libre RC3 version. Any *.doc or *.odt file used and scrolling make crash of application.
Comment 11 lindrix 2011-01-17 13:37:04 UTC
sophie,

The problem with .doc files still exist even at RC3.
Comment 12 tester8 2011-01-25 04:55:54 UTC
Not reproduced with LO RC4 Ubuntu 10.04 x86.
Comment 13 Alex Thurgood 2011-01-26 01:31:28 UTC
I can not reproduce the crash on RC4 with MacOSX 10.6.6.


Alex
Comment 14 Katarina Behrens 2011-03-23 08:29:08 UTC
Not reproducible anymore, marking as duplicate then

*** This bug has been marked as a duplicate of bug 31243 ***