Bug 32716 - Show progress bar when opening a calc document with several DDE() links
Summary: Show progress bar when opening a calc document with several DDE() links
Status: CLOSED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: File-Progress-Bar
  Show dependency treegraph
 
Reported: 2010-12-29 03:54 UTC by Torge Riedel
Modified: 2017-12-27 16:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Torge Riedel 2010-12-29 03:54:27 UTC
I have several calc documents linking with about 20 or more DDE() links to other calc documents. When opening a document it takes a bit time (between 10 and 20 seconds) to update these links. A progress bar should be shown so the user sees that there is something in progress, cause otherwise the user might think that calc hangs.
Comment 1 Roman Eisele 2012-05-03 09:45:23 UTC
This is a Calc issue, therefore changed the 'Component' field accordingly.
Comment 2 Torge Riedel 2014-03-23 17:51:42 UTC
Still valid in 4.1.3.2
Comment 3 Yousuf Philips (jay) (retired) 2017-06-16 12:47:05 UTC
Hi Torge,

It would be appreciated if you can supply a zipped sample of spreadsheets where this issue can be seen.

Xisco, Cor: Can you guys supply a sample like this?
Comment 4 Cor Nouws 2017-08-11 15:40:03 UTC
DDE is deprecated, so lets say WontFix.

Or Torge, does this apply for otherwise linked data as well?

What about including this progress in the file -open progress bar?
Comment 5 Torge Riedel 2017-12-26 10:34:26 UTC
I googled around and as I understood I should create references like described here: https://wiki.openoffice.org/wiki/Documentation/OOo3_User_Guides/Calc_Guide/Referencing_other_documents

Is this correct? I was able to replace all DDE links with such references and using INDIRECT() cause my links must be configurable (select filename from a cell).

Well, since lot of referenced docs still contain DDE links I am not sure whether the time of updating the links is caused by DDE and/or the "new" way of reference.

It would take a while to create a sample, cause my calc docs contain financial data. Nothing to share.

@Cor: After opening the document I got a message box asking me whether to update the links. This is a good first help, cause if I am sure, that no other docs contain modifications I can simple click "No" and do not have to wait.

Since my scenario might be a rare one, I do not currently see a need for a progress bar any more.
Comment 6 Buovjaga 2017-12-26 19:34:17 UTC
Thanks, Torge. Let's close.