Download it now!
Bug 32737 - EDITING - Copy and paste crashes Libreoffice
Summary: EDITING - Copy and paste crashes Libreoffice
Status: CLOSED DUPLICATE of bug 32930
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: x86-64 (AMD64) Mac OS X (All)
: high blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 34290 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-30 01:14 UTC by Roberto Resecco
Modified: 2011-12-22 05:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice Crash report (41.62 KB, text/plain)
2010-12-30 02:37 UTC, Roberto Resecco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roberto Resecco 2010-12-30 01:14:31 UTC
To reproduce:

LibreOffice not running
select a text
press CMD-c to copy text into clipboard
open LibreOffice Writer
press CMD-v to paste selected text
The program crashes
Comment 1 Yifan Jiang 2010-12-30 02:00:36 UTC
Not a problem on SLED and Windows.

Hi Thorsten, 

It looks like a severe problem on Mac. Would you help reproduce it? Thank you!

p.s, I'm not sure how to gather logs on OSX, is that in Library/log? If it is convenient to tell people gather logs, shall we put the instruction here:

http://wiki.documentfoundation.org/BugReport
Comment 2 Roberto Resecco 2010-12-30 02:37:10 UTC
Created attachment 41526 [details]
LibreOffice Crash report

This file is reported in /var/log/system.log
Comment 3 Roberto Resecco 2010-12-30 02:39:14 UTC
Dec 30 11:34:47 mazingaz soffice[1867]: [JVM Detection] FillMatcher: failed to get JavaVM.framework version
Dec 30 11:34:48 mazingaz com.apple.launchd.peruser.501[211] ([0x0-0x84084].org.libreoffice.script[1867]): Job appears to have crashed: Bus error
Dec 30 11:34:49 mazingaz ReportCrash[1878]: Saved crash report for soffice[1867] version 3.3.0 (???) to /Users/roberto/Library/Logs/DiagnosticReports/soffice_2010-12-30-113449_mazingaz.crash
Comment 4 Roberto Resecco 2010-12-30 02:46:39 UTC
(In reply to comment #3)
> Dec 30 11:34:47 mazingaz soffice[1867]: [JVM Detection] FillMatcher: failed to
> get JavaVM.framework version
> Dec 30 11:34:48 mazingaz com.apple.launchd.peruser.501[211]
> ([0x0-0x84084].org.libreoffice.script[1867]): Job appears to have crashed: Bus
> error
> Dec 30 11:34:49 mazingaz ReportCrash[1878]: Saved crash report for
> soffice[1867] version 3.3.0 (???) to
> /Users/roberto/Library/Logs/DiagnosticReports/soffice_2010-12-30-113449_mazingaz.crash

The above is an excerpt from /var/log/system.log file
Comment 5 Alex Thurgood 2011-01-05 07:01:07 UTC
I can not reproduce on Mac OSX 10.6.5 running LibO 3.3 beta2.

I opened a PDF file, selected the text, pressed Cmd-C. Started LibO, opened a new writer document. Pressed Cmd-V. The copied text gets inserted correctly. No crash. 

How big is the selected text that you copy into the Writer document ?

Which version of Mac OSX ?

Alex
Comment 6 Roberto Resecco 2011-01-17 01:36:02 UTC
1. few lines (say 4)
2. OSX 10.6.6 - but also happened with 10.6.5
3. LibOff rc2 but also rc3

--

ADDENDUM
I made the test using another user on my mac. This time no crash!
Is there any config file/directory/setting that may cause the problem?

roberto

--
Comment 7 Alex Thurgood 2011-01-24 08:43:56 UTC
Try deleting the LibreOffice folder in your /User/Library/Application Support folder.

When you restart LibO, the folder will be created. However, any configuration changes or personalisation (e.g. extensions, dictionaries, colours, etc) you have made previously will be lost. If you don't want to delete them just rename the LibreOffice folder to OldLibreOffice or something like that. That way, you can always copy back the bits you are interested in after recreation of the LibreOffice folder. This may even help you pin down the root of the problem leading to the crash.



Alex
Comment 8 Alex Thurgood 2011-01-24 08:44:19 UTC
Besides, you should try this again with RC4 just to be sure.


Alex
Comment 9 Roberto Resecco 2011-01-24 09:15:40 UTC
to #8: the behaviour is even worse: LibO RC4 crashes also when I start typing

to #7: It hanged the first time I ran LibO RC4 after renaming ~/Library/Application Support/LibreOffice to ~/Library/Application Support/OLDLibreOffice. I Had to force app shutdown. I reran the app, LibO started and it all seems to work now.

roberto

--
Comment 10 gooly 2011-02-04 02:18:55 UTC
This pretty annoying bug ist still open. I have this now for more that a year, previously in OpenOffice now in LibreOffice :(

Actually I am running:
LibreOffice 3.3.0 
OOO330m19 (Build:5)
tag libreoffice-3.3.0.3

on Windows 7, 64 bit.

Not every time that I press ctrl-v (or ctrl-V and then select 'unformated text'),
but at least 1 out of three LibreOffice (like OpenOffice) totally crashes.
It is not only the writer! But as well calc!!
Comment 11 gooly 2011-02-23 00:54:19 UTC
Seems to be a problem of all Libre-Offiversion:
Bug 32930, Bug 33562, Bug 32737, Bug 34290
Comment 12 Cédric Bosdonnat 2011-03-03 01:17:27 UTC
*** Bug 34290 has been marked as a duplicate of this bug. ***
Comment 13 Cédric Bosdonnat 2011-03-03 01:19:39 UTC

*** This bug has been marked as a duplicate of bug 32930 ***
Comment 14 Rainer Bielefeld Retired 2011-05-22 06:08:40 UTC
@reporter:
can you please check whether bug does no longer exist for you due to 
"Bug 32930 - LO crashes after copy&paste of webpage into Writer"?
If not, please feel free to reopen this report.
Comment 15 Björn Michaelsen 2011-12-22 05:54:12 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.