Download it now!
Bug 32930 - LO crashes after copy&paste of webpage into Writer
Summary: LO crashes after copy&paste of webpage into Writer
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 32737 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-09 00:19 UTC by gleppert
Modified: 2011-05-22 06:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Strace log for this bug (946.93 KB, application/zip)
2011-01-09 03:57 UTC, gleppert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2011-01-09 00:19:30 UTC
LibreOffice crashes immediately after copy&paste of a webpage into Writer. I installed LO 3.3 RC2 and I am using it for two days now. Since then, I encountered several times the following crash of the application:

1. Open an empty Writer document.
2. Open (in Firefox) a web page. Let's say we are using the webpage www.bahn.de and we are searching for a train from Köln to Bonn. 
3. Then copy the search results with ctrl-A and ctrl-C into Writer ctrl-v.
4. Writer will crash almost immediately. On my computer this is reproducible. It is not crashing always, but very very often by doing this.

System: Ubuntu 10.4 on 32-Bit Intel, Gnome
LibreOffice: 3.3 RC2
Comment 1 gleppert 2011-01-09 00:29:00 UTC
Interestingly enough I cannot reproduce the bug by copying the webpage into libreoffice started with strace -o /tmp/strace.log -f -tt -s 512 libreoffice. In this case, it does not crash. 

By doing the same after starting LibreOffice via the gnome menu: "Applications (Anwendungen)"-"Office (Büro)"- "LibreOffice Writer", the application again crashed immediately.
Comment 2 Alex Thurgood 2011-01-09 01:48:49 UTC
Hi,

Tried this on my Mac OSX 10.6.5, but Writer doesn't crash. I copied the front page of the The Register website. Apart from some of the graphics not showing up, everything else was copied (over several pages), but Writer stood up to the test.


Alex
Comment 3 Rainer Bielefeld Retired 2011-01-09 03:30:31 UTC
NOT Reproducible with "LibreOffice 3.3.0 RC2 - WIN7  Home Premium (64bit) German UI  [OOO330m18 (build 3.3.0.2)]"
Comment 4 gleppert 2011-01-09 03:57:30 UTC
Created attachment 41789 [details]
Strace log for this bug
Comment 5 gleppert 2011-01-09 03:58:04 UTC
Now I could reproduce the bug while having started Writer with strace:

I was using the command: strace -o /tmp/strace.log -f -tt -s 512 /opt/libreoffice/program/swriter

Then I was copying the startpage of www.sourceforge.net as described in the original bug entry. LibreOffice crashed.

Strace.log is attached as zip-folder
Comment 6 Michael Meeks 2011-01-13 02:44:47 UTC
The strace shows it crashing when loading a cached piece of java LanguageTool extension:

/home/gerald/.libreoffice/3/user/uno_packages/cache/uno_packages/RMNjjj_/LanguageTool-1.1.oxt/com/sun/xml/bind/v2/model/impl/RuntimeBuiltinLeafInfoImpl$12.class

at least, I think so :-) We removed the LanguageTool in RC2 by popular demand: it requires Java and is poorly translated.

So - I'm going to de-blocker-ise this; though thanks for finding it !

gleppert: can you move away your ~/.libreoffice directory (so it can be moved back to repeat the problem), and check it this re-occurs ?

Then - if you could run soffice.bin inside gdb so we could get a stack trace that would be very useful (you prolly want to install debuginfo packages) also reporting your Java version may help. Finally RC3 is coming out today; might be worth trying that (though I don't anticipate improvement).

I'll make this a blocker for 3.3.1 instead (so we don't drop it).

Alex, Rainer - thanks too for the cross-platform testing ! :-)
Comment 7 gleppert 2011-01-13 04:25:26 UTC
Thank you for your reply. 

Indeed, Writer does not crash anymore after moving away the .libreoffice directory. I did several checks and it works fine!

How do I run soffice.bin inside gdb ?

The Java version is java-6-sun-1.6.0.22
Comment 8 Michael Meeks 2011-02-10 12:57:11 UTC
well; its a pain (gdb-wise); you need to run javaldx first - and act on the output (set it to LD_LIBRARY_PATH AFAIR) to get the environment setup - then run soffice.bin inside gdb.

Either way - if this is only for people with an older (or broken) LanguageTool, then it is presumably one of that obscure class of nasty Java bugs that ... so I'll downgrade it from being a blocker for 3.3.1.

Thanks,
Comment 9 gooly 2011-02-23 00:54:23 UTC
Seems to be a problem of all Libre-Offiversion:
Bug 32930, Bug 33562, Bug 32737, Bug 34290
Comment 10 Cédric Bosdonnat 2011-03-03 01:19:39 UTC
*** Bug 32737 has been marked as a duplicate of this bug. ***
Comment 11 Don't use this account, use tml@iki.fi 2011-03-07 06:21:40 UTC
Changing platform as bugs on Windows (indirectly) and Mac OS X have been marked as duplicates of this.
Comment 12 gleppert 2011-05-06 12:12:46 UTC
Tested this bug again on my computer. I cannot confirm it anymore. There is no crash. 

I don't close this bug, because there are so many duplicates related to it. Can anyone have a look at the duplicates, whether they are also resolved?

System: Ubuntu 10.10/gnome 2, LibreOffice 3.3.2 PPA, German UI, Languagetool 1.3.1, Java runtime environment java-6-sun-1.6.0.24
Comment 13 Petr Mladek 2011-05-11 07:04:02 UTC
It was related to LanguageTool that is not longer bundled with LO. It is hard to reproduce => lovering priority and severity.
Comment 14 Rainer Bielefeld Retired 2011-05-22 06:11:33 UTC
I left a hint in the other (DUPlicated) bugs and will close this one for now due to latest comments concerning reasons for the bug. It's useless to leave a bug open if no one will take care furthermore.
Comment 15 Rainer Bielefeld Retired 2011-05-22 06:14:09 UTC
Please excuse the SPAM, WFM, of course!