Bug Hunting Session
Bug 32784 - autocorrect of ordinal numbers does work only with English language
Summary: autocorrect of ordinal numbers does work only with English language
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: All Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 54405 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-02 09:55 UTC by Rpnpif
Modified: 2013-04-07 11:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rpnpif 2011-01-02 09:55:18 UTC
In Writer, type 1st get 1^st. This is not usable in French language.
The French ordinal number 1er should get 1^er and 2e get 2^e.

Autocorrect options is partially adapted to French language.

See specification http://www.dsi.univ-paris5.fr/typo.html and http://wiki.services.openoffice.org/wiki/Localized_AutoCorrection_of_Ordinal_Numbers_%281st_2nd%29.
Comment 1 Andras Timar 2011-04-30 10:08:40 UTC
In LibreOffice 3.4 beta 3 I typed 1er and 2e and I got 1^er and 2^e. So it works for me.
Comment 2 Horst 2012-09-11 20:51:05 UTC
*** Bug 54405 has been marked as a duplicate of this bug. ***
Comment 3 Horst 2012-09-17 19:05:20 UTC
I like to reopen this bug.
It worked fine in 3.5 but no longer in 3.6.x.x.

I could only test the EN-US where you expect 1st to display 1^st, what it does not.
Comment 4 Horst 2012-09-17 22:19:32 UTC
Resolved in 3.6.2.rc
Can not check bug 44294, if solved for portuguese
Changed Status back to RESOLVED
Comment 5 Horst 2012-09-17 22:20:40 UTC
Sorry Typo bug 44293
Comment 6 Rainer Bielefeld Retired 2013-04-07 08:56:49 UTC
No known fix, so WFM

revert wrong Version change

@Horst, please consider:
<http://wiki.documentfoundation.org/BugReport_Details#Version>
If you also did this mistake in other Bugs please undo your Version changes there!
Comment 7 Rpnpif 2013-04-07 11:11:46 UTC
OK. It works fine for me with 4.0 release.