Bug Hunting Session
Bug 32797 - LibreOffice Writer freezing while saving a file or export as pdf
Summary: LibreOffice Writer freezing while saving a file or export as pdf
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Luboš Luňák
URL:
Whiteboard:
Keywords:
: 33074 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-03 07:20 UTC by reportingbugs
Modified: 2013-11-23 13:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
SaveAs-Problem Backtrace (17.58 KB, text/plain)
2011-01-03 07:20 UTC, reportingbugs
Details
PDF-Problem Backtrace (16.90 KB, text/plain)
2011-01-03 07:21 UTC, reportingbugs
Details
strace for SaveAs-Problem (411.91 KB, application/x-bzip2)
2011-01-03 12:47 UTC, reportingbugs
Details
strace for pdf-problem (386.15 KB, application/x-bzip2)
2011-01-03 12:48 UTC, reportingbugs
Details
Strace log for problem on LO 3.3.2 (462.46 KB, application/x-bzip2)
2011-04-21 06:03 UTC, moabi2000
Details

Note You need to log in before you can comment on or make changes to this bug.
Description reportingbugs 2011-01-03 07:20:41 UTC
Created attachment 41586 [details]
SaveAs-Problem Backtrace

Operating System:
Debian 4.1.2-25 lenny2

Kernel-Version:
Linux 2.6.26-1-686

KDE-Version:
3.5.10

LibreOffice-Version:
LibreOffice 3.3.0 
OOO330m18 (Build:4)

Summary:

LibreOffice freezes when I want to save a document about the "save as..."-dialog.

Also LibreOffice freezes when I want to export a document about the "Export directly as PDF"-dialog.

This actions result in a permanent LibreOffice freeze. I can only quit LibreOffice by killing the process in the console. 

I have added two backtraces. Once for the problem with the "save as.."-dialog and the other backtrace is about the "Export directly as PDF" problem.
Comment 1 reportingbugs 2011-01-03 07:21:35 UTC
Created attachment 41587 [details]
PDF-Problem Backtrace
Comment 2 Jan Holesovsky 2011-01-03 10:08:42 UTC
This is in KDE3, right?  Can you please provide us with a strace too?

How to get a strace:

http://wiki.documentfoundation.org/BugReport#How_to_get_strace_log_.28on_Linux.29

Thank you!
Comment 3 reportingbugs 2011-01-03 12:47:23 UTC
Created attachment 41598 [details]
strace for SaveAs-Problem
Comment 4 reportingbugs 2011-01-03 12:48:48 UTC
Created attachment 41599 [details]
strace for pdf-problem
Comment 5 reportingbugs 2011-01-03 12:50:25 UTC
(In reply to comment #2)
> This is in KDE3, right?  Can you please provide us with a strace too?
> 
> How to get a strace:
> 
> http://wiki.documentfoundation.org/BugReport#How_to_get_strace_log_.28on_Linux.29
> 
> Thank you!

Hi,

I have created two strace-files for the "saveas" and "pdf" -problem. 

To your question:
Yes, this is KDE3.

Regards,
Matthias
Comment 6 Luboš Luňák 2011-01-05 02:17:49 UTC
As a workaround you can disable KDE3 file dialogs in Options->General->Use LibreOffice dialogs.
Comment 7 reportingbugs 2011-01-05 03:49:07 UTC
(In reply to comment #6)
> As a workaround you can disable KDE3 file dialogs in Options->General->Use
> LibreOffice dialogs.

Hi,

thank you very much for your help. This workaround helps.

Regards,
Matthias
Comment 8 Luboš Luňák 2011-01-18 06:08:57 UTC
*** Bug 33074 has been marked as a duplicate of this bug. ***
Comment 9 Luboš Luňák 2011-01-21 11:54:21 UTC
Fixed in master.
Comment 10 moabi2000 2011-04-21 06:01:14 UTC
I have the same problem with 3.3.2. Running on Fedora 14 kernel 2.6.38, under ratpoison.

The same workaround 'use libreoffice dialogs' fixes the problem.

strace log attached.

cheers
M.
Comment 11 moabi2000 2011-04-21 06:03:07 UTC
Created attachment 45914 [details]
Strace log for problem on LO 3.3.2
Comment 12 Luboš Luňák 2011-04-21 07:26:29 UTC
Upgrade.
Comment 13 moabi2000 2011-05-03 03:30:31 UTC
(In reply to comment #12)
> Upgrade.

To what? I'm running the latest version from http://www.libreoffice.org/download/
Comment 14 Luboš Luňák 2011-05-03 04:57:32 UTC
To the upcoming 3.4 or see above for a workaround.