Bug Hunting Session
Bug 32849 - PDF: White table borders look grey
Summary: PDF: White table borders look grey
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-05 07:55 UTC by Jorge
Modified: 2011-08-22 03:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
odt test file with the table (10.28 KB, application/vnd.oasis.opendocument.text)
2011-01-05 07:55 UTC, Jorge
Details
3.4.3 RC1 created simple odt file with table (9.06 KB, application/vnd.oasis.opendocument.text)
2011-08-19 05:18 UTC, Carlo Strata
Details
3.4.3 RC1 created simple odt file with table, pdf export (13.59 KB, application/pdf)
2011-08-19 05:19 UTC, Carlo Strata
Details
Screenshots, see Comment 7 (181.97 KB, application/x-download)
2011-08-21 02:40 UTC, Rainer Bielefeld Retired
Details
Libò / Evince screenshots compares (501.23 KB, application/pdf)
2011-08-21 04:10 UTC, Carlo Strata
Details
3.4.3 RC1 created odt file, pdf export, defaul and border width changed tables (16.06 KB, application/pdf)
2011-08-21 08:34 UTC, Carlo Strata
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge 2011-01-05 07:55:31 UTC
Created attachment 41667 [details]
odt test file with the table

When exporting a table to a pdf file, some borders of the cell - supposedly white - got printed grey, and inside the same cell there are white borders between lines of text.
Comment 1 Carlo Strata 2011-08-19 05:18:32 UTC
Created attachment 50372 [details]
3.4.3 RC1 created simple odt file with table
Comment 2 Carlo Strata 2011-08-19 05:19:33 UTC
Created attachment 50373 [details]
3.4.3 RC1 created simple odt file with table, pdf export
Comment 3 Carlo Strata 2011-08-19 05:21:37 UTC
I confirm the bug remains in Libò 3.4.3 RC1.

I'm not sure if this issue is somewhat related with issue 37488.
Comment 4 Carlo Strata 2011-08-19 05:22:59 UTC
(In reply to comment #3)
> I confirm the bug remains in Libò 3.4.3 RC1.
> 
> I'm not sure if this issue is somewhat related with issue 37488.

Sorry, I meant bug 37488.
Comment 5 Carlo Strata 2011-08-19 05:34:00 UTC
As I reported here:
http://nabble.documentfoundation.org/QA-3-4-3-rc1-pdf-exported-table-upper-border-may-disappear-and-it-is-not-always-printed-tp3265473p3265473.html

I just test again it with the new 3.4.3 rc1 build, italian localization, linux, x8-64. This is a long ago bug (sure since 3.3.x).

I have attached two very small files to this bug (one odt and the pdf exported one version).

If you open the pdf one and zoom it you may see the upper table border to disappear or, sometime, it appear as grey in color.

I have tested this and got always the same results in viewing on:

- linux x86-64:
-- Evince 2.30.3 (with poppler/cairo (0.12.3) pdf backend);
-- Okular Version 0.12.2 (KDE Backend PDF Versione 0.4.1);

- Windows Vista SP2 HP 64 bit:
-- Adobe Acrobat Reader 10.1.0.

To replicate my bug follow this few steps:

- open the odt file;

- export it to pdf;

- open it on your preferred pdf viewer;

- zoom the upper table border it will disappear soon.

I think pdf export quality and stability is very important...
We cannot repeat old go-oo experiences anymore, i.e.:
http://bugzilla.novell.com/show_bug.cgi?id=615812

I'm here to hekp testing/solving.

Have a nice day,

Carlo
Comment 6 digital ant 2011-08-20 18:50:17 UTC
Running Mac OSX Snow Leopard (10.6.8) Intel i7:

-LibO 3.4.2 Final - Cannot confirm using the ODT provided - the produced PDF looks exactly like the ODT in print preview. To continue, I created another ODT in writer, added a table and changed border colors of a few of the cells - they all showed up correct. However, the entire top border of the table was missing. 

-LibO 3.4.3 rc1 - all table border colors seem to save correctly into pdf's. All of my print previews from the odt's match what i see in the pdf - 3.4.3 rc1 seems to fix the top border missing.
Comment 7 Rainer Bielefeld Retired 2011-08-21 02:08:45 UTC
I see different differences in view in ODT and PDF, that all differs between various OOo and LibO versions, see screenshots. Before we can think about PDF export problems, we have to check what's the correct .odt view.


@Jorge, @Carlo Strata:
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
Then please:
- Write a meaningful Summary
- Attach screenshots with comments (you can add information using LibO DRAW
  and then attach your screenshot with comments as PDF) if necessary, because
  you can not know what others will see with your sample
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- what exactly is unexpected
  -- and why do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC (especially: video card)
  -- concerning your OS (exact version)
  -- concerning your LibO version and localization (UI language)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read a.m. URL
Fur submitting bug reports you should try <http://wiki.documentfoundation.org/BugReport_Details>

Please file Bug reports with status UNCONFIRMED if your are not absolutely sure that you contributed all required background information and that the problem will be reproducible with information you can provide? 

@Jorge:
How did you create your test document? Wit Version mentioned in your report?
With with "LibreOffice 3.4.2  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:203)]" I see see right grey border from first column missing in PDF export (lossless, viewing in AR X), but to me that seems to be something completely different to the problem you reported ("got printed grey?" Really print from PDF or "shown in PDF"?)

@Carlo Strata
Good report, bit IMHO at the wrong place! I see the effect you reported for Tables at the top of the page, but I can't see why you believe that it might be the same problem as the one from original report. Please explain!
Do not Nominate for 35673 and do not touch pickers in existing bugs before you have more experience!
Comment 8 Rainer Bielefeld Retired 2011-08-21 02:40:24 UTC
Created attachment 50421 [details]
Screenshots, see Comment 7
Comment 9 Carlo Strata 2011-08-21 04:10:52 UTC
Created attachment 50422 [details]
Libò / Evince screenshots compares
Comment 10 Carlo Strata 2011-08-21 04:40:50 UTC
@digital ant

Sure from my description you cannot deduce/understand that to see the trouble you have to zoom some times and not only once.


@ Rainer Bielefeld

Sorry for my lacks in information, but I think having posted in the right place instead: this is because border disappearing or changing in color are, imho too, two faces of the same medal, thing.

If you take a look to my new pdf Libò / Evince compares attached pdf and read my hypothesis upper to each Evince screenshot, I think you will agree with me (and I hope so because here we have a wrong quality big problem).

In my job I send away mauny Libò generated pdf files and I am far away to spread a bad Libò pdf fame all over the world. So it is for me since go-oo time... with the nightmare Novell bugzilla bug I have pointed out in Comment 5.

My hypothesis is that pdf tavle rendering mix (and render) table border and/or table limits with the results we all are seeing.

I hope we fix this bug because we cannot spread these PDFs make people believing that this is the Libò quality! We have to deep investigate this problem and to learn from our bugs... :-)

I will also completely read soon the guide to post/file a bug that you kindly point me out.

My notebook pc:
- ACER Aspire 8920G;
- CPU Intel Centrino EM64T capable, dual core;
- 4 Gbyte DDR2 RAM (2 Gbyte x 2 sodimm);
- an old but updated OpenSuSE 11.2, kernel 2.6.38.6-5-default, x86-64;
- Gnome 2.30.2, KDE 4.6.3;
- nVidia GeForce 9500M, 512 Mbyte dedicated (V)RAM;
- nVidia proprietary driver version 275.09.07.

The Windows PC (that in which I tested the PDFs with Adobe Acrobat Reader 10.1.0):
- CPU AMD Athlon 4X (recent one);
- Asus motherboard;
- AMD/ATI video card (3740HD to be verified);
- AMD/ATI recent video driver (may be three mounts ago);
- Microsoft windows Vista HP 64 bit SP2 updated;
- Adobe Acrobat Reader 10.1.0 (32 bit).

If you need exact information about the Windows pc ask me for that so I post here immediately.

Have a nice Sunday,

Carlo
Comment 11 Jean-Baptiste Faure 2011-08-21 07:59:03 UTC
In the case of the problem reported by Carlo, I can confirm that:
1/ The upper border seems to be gray  when exported in pdf (on the screen, I do not know when printed)
2/ when zooming up to 400% in evince the upper border disappears

But: if you set the line width to 0,5 pt instead of 0,25 pt both defects vanish.
Perhaps an artifact due to the low screen resolution compared to printer resolution.

Best regards. JBF
Comment 12 Carlo Strata 2011-08-21 08:29:33 UTC
Hi Everyone,

I come back because I have just performed some more tests.

Yes, as just and already noted by Jean-Baptiste, I have tried too to set border width to 1 pt and pdf export appear to be ok.

But then I also try to decrease it back to 0.25 and so it seems to be ok as well. :-)

So I suspect that *default setting tables* (I actually create them with the new table toolbar button or pressing ctrl-F12) may have a little (?) bug in border and, possibly (color?), other parameters (some "dusty" parameters) that yield that wrong pdf files.

All default tables are suffering for that problem.

See my new attached pdf file.

Carlo
Comment 13 Carlo Strata 2011-08-21 08:34:40 UTC
Created attachment 50427 [details]
3.4.3 RC1 created odt file, pdf export, defaul and border width changed tables
Comment 14 Rainer Bielefeld Retired 2011-08-21 11:15:07 UTC
@Carlo
Currently the only interesting question is whether your problem has to do anything with the one of the original export and if yes what. Yes, I know, LibO, Writer, Table, Border, ...  - but we have lots of other, different problems with these key words.

Nevertheless, your problem also is reproducible with 3.3.3, so it's not ipossible that your prolbem has teh same roots as the one from original report.

But again: The only comments interesting from you here are reasons why you think that your problem is the same as the reported one, everything else is without interest. And that can not be checked finally before we have requested information form reporter. May be you can check with reporter's sample whether the problem there also disappears with selecting thicker lines?
Comment 15 Jorge 2011-08-21 12:59:33 UTC
@Rainer

The only thing i'm sure it's not the same issue.

The bug i reported was on LibO 3.3.0rc1 and linux x86_64, and with the following steps:
1.- Create a table with white borders of 1px.
2.- Fill the cells with some color.
3.- Check the borders in print preview, everything fine.
4.- Export that odf file to a pdf.
5.- Check that pdf file with a viewer like evince, etc.. and i see some grey borders when every border has to be white.

Now with LibO 3.4.2 i can't reproduce this bug, so for me this bug is closed.


(In reply to comment #14)
> @Carlo
> Currently the only interesting question is whether your problem has to do
> anything with the one of the original export and if yes what. Yes, I know,
> LibO, Writer, Table, Border, ...  - but we have lots of other, different
> problems with these key words.
> 
> Nevertheless, your problem also is reproducible with 3.3.3, so it's not
> ipossible that your prolbem has teh same roots as the one from original report.
> 
> But again: The only comments interesting from you here are reasons why you
> think that your problem is the same as the reported one, everything else is
> without interest. And that can not be checked finally before we have requested
> information form reporter. May be you can check with reporter's sample whether
> the problem there also disappears with selecting thicker lines?
Comment 16 Rainer Bielefeld Retired 2011-08-21 22:30:42 UTC
Closing to Jorge's comment, and my own results, white borders work fine

@Jorge:
Thank you for feedback!
There still might be some additional problems visible with your complex first document concerning the paragraph borders. If you also see such problems with a new 3.4.3 or later document please report a new bug and add me to CC. I would prefer to check such things with a new document, because there might be damages in old documents what will confuse investigations unnecessarily.

@Carlo Strata:
I will file a new bug for your problem and add you to CC, please do not add any comments here concerning your upper border problem.
Comment 17 Carlo Strata 2011-08-22 03:35:50 UTC
I'm sorry for mismatching the places for my bug posts: I thought it was the right one! :-(

And I won't duplicate cases, but to rich information about them to solve the bugs rapidly...

@Rainer:
I have no problem to open a bug by myself (with the only last attachment, of course), but thank you very much if you make it for me.

Have a nice week,

Carlo