Bug Hunting Session
Bug 32852 - [Linux] video / `GLIBCXX_3.4.11' not found
Summary: [Linux] video / `GLIBCXX_3.4.11' not found
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-05 10:26 UTC by NoOp
Modified: 2011-05-23 05:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NoOp 2011-01-05 10:26:27 UTC
[Version]
AllLanguages=en-US
buildid=330m18(Build:4)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.3
ProductBuildid=4
ProductMajor=330
ProductMinor=18
ProductSource=OOO330
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH};
BundledLanguages=${AllLanguages})

Ubuntu 10.04 2.6.32-27-generic (Gnome)

While attempting to play an .avi video in Impress I get sound but no
video. I am seeing the following when running from the terminal:

(soffice:22820): GStreamer-WARNING **: Failed to load plugin
'/usr/lib/gstreamer-0.10/libgstffmpeg.so':
/opt/libreoffice/program/../basis-link/ure-link/lib/libstdc++.so.6:
version `GLIBCXX_3.4.11' not found (required by
/usr/lib/libdirac_encoder.so.0)
** Message: don't know how to handle video/x-xvid,
framerate=(fraction)2997/100, width=(int)704, height=(int)384,
pixel-aspect-ratio=(fraction)32/33

And when checking the libreoffice folders, I see:
$ strings /opt/libreoffice/ure/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_FORCE_NEW
$ strings /opt/libreoffice3/ure/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_FORCE_NEW

My system libstdc++.so.6:
$ strings /usr/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

$ apt-cache policy gstreamer0.10-ffmpeg
gstreamer0.10-ffmpeg:
  Installed: 0.10.10-1
  Candidate: 0.10.10-1
  Version table:
 *** 0.10.10-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

If I:
$ sudo cp /usr/lib/libstdc++.so.6 /opt/libreoffice3/ure/lib/
and
$ sudo cp /usr/lib/libstdc++.so.6 /opt/libreoffice/ure/lib/
the video now runs without issue.

Can LibORC3 include an updated libstdc++.so.6 so that others do not have
the same issue? Thanks.
Comment 1 NoOp 2011-02-14 09:09:55 UTC
Same issue with 3.3.1 RC1 and now Ubuntu 10.10:
2.6.35-26-generic #46-Ubuntu SMP Sun Jan 30 08:10:51 UTC 2011 i686 GNU/Linux

$ strings /opt/libreoffice/ure/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_FORCE_NEW

$ cat /opt/libreoffice/program/versionrc
[Version]
AllLanguages=en-US
buildid=330m19(Build:7)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.3
ProductBuildid=7
ProductMajor=330
ProductMinor=19
ProductSource=OOO330
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})

$ strings /usr/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

Make the modification:
$ sudo cp /usr/lib/libstdc++.so.6 /opt/libreoffice/ure/lib/
check:
$ strings /usr/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

Create new Impress presentation. Insert test .avi. Sound *and* Video now work properly.
Comment 2 Rainer Bielefeld Retired 2011-03-13 00:28:25 UTC
@NoOp:
Still a problem with 3.3.2RC?
Comment 3 NoOp 2011-03-14 15:57:07 UTC
(In reply to comment #2)
> @NoOp:
> Still a problem with 3.3.2RC?

Yes. No change at all. Have you not even attempted to test? Does your:
$ strings /opt/libreoffice/ure/lib/libstdc++.so.6 | grep GLIBCXX
show anything different than:

$ strings /opt/libreoffice/ure/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_FORCE_NEW

My system:
$ strings /usr/lib/libstdc++.so.6 | grep GLIBCXX
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

$ cat /opt/libreoffice/program/versionrc
[Version]
AllLanguages=en-US
buildid=330m19(Build:201)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.3
ProductBuildid=201
ProductMajor=330
ProductMinor=19
ProductSource=OOO330
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})

To test:

1. I removed the old /opt/libreoffice (3.3.1) and ~/.libreoffice and then installed LO 3.3.2 RC1. Then, as previously, I opened a fresh Impress presentation, checked the .avi in media player - it plays only sound. Added to the presentation and that of course only plays the sound w/no video. 

2. Got the above info regarding GLIBCXX. then modified /opt/libreoffice/ure/lib/libstdc++.so.6 as shown in my previous comments/reports:
$ sudo cp /usr/lib/libstdc++.so.6 /opt/libreoffice/ure/lib/
and of course, the video now works.
Comment 4 NoOp 2011-03-15 11:03:08 UTC
Reinstalled libreoffice3-ure_1.7.0-19_i386.deb to get the LO libstdc++.so.6 back.

And ran from the cli. Here are the error msgs:

$ /opt/libreoffice/program/soffice test3_LO.odp

(soffice:26465): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /opt/libreoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libdirac_encoder.so.0)
** Message: don't know how to handle video/x-xvid, framerate=(fraction)2997/100, width=(int)704, height=(int)384, pixel-aspect-ratio=(fraction)32/33

(soffice:26465): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /opt/libreoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libdirac_encoder.so.0)
** Message: don't know how to handle video/x-xvid, framerate=(fraction)2997/100, width=(int)704, height=(int)384, pixel-aspect-ratio=(fraction)32/33

(soffice:26465): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /opt/libreoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libdirac_encoder.so.0)
** Message: don't know how to handle video/x-xvid, framerate=(fraction)2997/100, width=(int)704, height=(int)384, pixel-aspect-ratio=(fraction)32/33

(soffice:26465): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /opt/libreoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libdirac_encoder.so.0)
** Message: don't know how to handle video/x-xvid, framerate=(fraction)2997/100, width=(int)704, height=(int)384, pixel-aspect-ratio=(fraction)32/33
GtkSalObject::SetForwardKey

(soffice:26465): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /opt/libreoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libdirac_encoder.so.0)
** Message: don't know how to handle video/x-xvid, framerate=(fraction)2997/100, width=(int)704, height=(int)384, pixel-aspect-ratio=(fraction)32/33

(soffice:26465): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /opt/libreoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libdirac_encoder.so.0)
** Message: don't know how to handle video/x-xvid, framerate=(fraction)2997/100, width=(int)704, height=(int)384, pixel-aspect-ratio=(fraction)32/33

libreoffice3-ure_1.7.0-19_i386.deb still contains an outdated libstdc++.so.6.
Comment 5 Yifan Jiang 2011-03-16 00:29:51 UTC
Hi NoOp, would you also help bring us the avi which caused the problem?
Comment 6 NoOp 2011-03-16 09:21:42 UTC
It's 9.3MB so I'm not sure if it will take, but I'll give it a try.
Comment 7 NoOp 2011-03-16 09:27:52 UTC
Nope. It's too large:

"The file you are trying to attach is 9549 kilobytes (KB) in size. Non-patch attachments cannot be more than 1000 KB."

I'll either need to find a smaller avi, or find a host to upload the avi.
Comment 8 NoOp 2011-03-16 09:55:39 UTC
OK. Found a site to upload the avi:
http://www.tempfiles.net/download/201103/149268/FlashsoKjat.html
You'll need to wait 60 sec for the link to bring up the download & then click:
Download file : 	click here
Comment 9 Rainer Bielefeld Retired 2011-03-16 22:50:52 UTC
NOT Reproducible] with reporter's sample movie "FlashsoKjat.avi" and "LibreOffice 3.3.2RC1  – WIN7  Home Premium  (64bit) German UI [OOO330m19 (Build:201 / tag 3.3.2.1)]".

1. I opened new presentation
2. 'Insert > Movie / Sound'
3. browsed for sample movie, <open>
4. Movie has been inserted, preview shown
5. <Play> button of media player started movie
6. I stopped movie
7. <f9> to start presentation
    Presentation starts, movie also starts with sound and pictures

So everything looks well.

Something noticeable:
The movie seems to contain a subtitle:
- VLC player needed to create a font cache (to show subtitles?), gave a message
  Then subtitle with filename "FlashsoKjat.avi" was shown at the bottom of the 
  movie window (appears and disappears smoothly)
- WINAMP did not show any subtitle at all
- WIN Media player shows file name enduring at the top left corner
- LibO Media player does not show any subtitle at all

Only a very very vague suspect: may be that that subtitle causes problem under particular circumstances? But I doubt that that might have to do with the GLIBCXX issue.
Comment 10 NoOp 2011-03-16 23:11:15 UTC
Perhaps you failed to read:

Platform: linux

Perhaps if you'd left the subject as it originally was, others (maybe you as well) would have understood that it is a *linux* issue.

"[Linux] LibORC2: Impress video / `GLIBCXX_3.4.11' not found "

I suspect that you failed to read *any* of the information in this bug report.
Comment 11 Yifan Jiang 2011-03-17 03:07:48 UTC
The testing sample can be played with video and audio on SLED 11 sp1 with Libreoffice 3.3.1. 

Since the log is quite explicit, let's see if someone else could reproduce the problem?

My environment:

$ rpm -qa | grep ^gst | grep ffm
gstreamer-0_10-ffmpeg-0.10.10-999.pm.1000.1

$ rpm -qf /opt/libreoffice/ure/lib/libstdc++.so.6 
libreoffice3-ure-1.7.0-7

$ strings /opt/libreoffice/ure/lib/libstdc++.so.6 | grep -i glibc
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBC_2.0
GLIBC_2.1
GLIBC_2.3
GLIBC_2.1.3
GLIBC_2.2
GLIBCXX_FORCE_NEW
Comment 12 NoOp 2011-03-17 18:15:03 UTC
Modified Summary & Component: the issue occurs in Impress/Presention, Writer/Text Document, Calc/Spreadsheet, and Draw/Drawing - anywhere that a video can be insterted. Not tested in any other components. Please note that this issue is linux specific and does not need testing in Windows.
Comment 13 NoOp 2011-03-17 18:25:42 UTC
@Yifan: Thanks for testing. 

I doubt that this will be of much use, but my current:

$ apt-cache policy gstreamer0.10-ffmpeg
gstreamer0.10-ffmpeg:
  Installed: 0.10.11-1
  Candidate: 0.10.11-1
  Version table:
 *** 0.10.11-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages
        100 /var/lib/dpkg/status
$ apt-cache policy libstdc++6
libstdc++6:
  Installed: 4.5.1-7ubuntu2
  Candidate: 4.5.1-7ubuntu2
  Version table:
 *** 4.5.1-7ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status
$ ldd soffice.bin | grep libstdc
	libstdc++.so.6 => /opt/libreoffice/program/./../basis-link/ure-link/lib/libstdc++.so.6 (0x002ca000)

I wonder if this could be a "LD_LIBRARY_PATH" issue? I wouldn't think so since LO uses & supplies it's own libstdc++.so.6 file(s).
Comment 14 Jean-Baptiste Faure 2011-03-19 13:18:55 UTC
(In reply to comment #9)
> NOT Reproducible] with reporter's sample movie "FlashsoKjat.avi" and
> "LibreOffice 3.3.2RC1  – WIN7  Home Premium  (64bit) German UI [OOO330m19
> (Build:201 / tag 3.3.2.1)]".
> 
> 1. I opened new presentation
> 2. 'Insert > Movie / Sound'
> 3. browsed for sample movie, <open>
> 4. Movie has been inserted, preview shown
> 5. <Play> button of media player started movie
> 6. I stopped movie
> 7. <f9> to start presentation
>     Presentation starts, movie also starts with sound and pictures

Not reproducible too for me (exactly the same steps and same movie) with LibreOffice 3.3.2 rc2 under Ubuntu 10.04 x86_64 (French UI).

NB: slide show starts with F5, not F9. ;-)

Best regards. JBF
Comment 15 NoOp 2011-03-19 19:54:50 UTC
@Jean-Baptiste Faure: Thanks and appreciate you testing. Can you please advise the output of:

$ strings /opt/libreoffice/ure/lib/libstdc++.so.6 | grep GLIB

Thanks.
Comment 16 Jean-Baptiste Faure 2011-03-20 00:48:59 UTC
(In reply to comment #15)
> @Jean-Baptiste Faure: Thanks and appreciate you testing. Can you please advise
> the output of:
> 
> $ strings /opt/libreoffice/ure/lib/libstdc++.so.6 | grep GLIB
> 
> Thanks.

It is :

GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBC_2.3
GLIBC_2.2.5
GLIBCXX_FORCE_NEW

On another hand if I did the test with OOo 3.3.2 rc2 I have OOo 3.3.1 from PPA installed.

Output of strings /usr/lib/libstdc++.so.6 | grep GLIB :
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBC_2.2.5
GLIBC_2.3
GLIBC_2.4
GLIBC_2.3.4
GLIBC_2.3.2
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

Best regards. JBF
Comment 17 NoOp 2011-03-20 16:40:36 UTC
Thanks again for testing & info. I'll explore "LD_LIBRARY_PATH" to see if that may be causing the issue. If I have a chance tomorrow I'll test on a clean Ubuntu 10.04 and 10.10 system to see if I have the same results. Until then I can only assume that it's an issue somewhere in my user system settings (not LO settings as I've tested with new).
Comment 18 NoOp 2011-03-22 15:18:03 UTC
I finally tested on a clean Ubuntu 10.10 install (LO 3.3.2 RC2/final) and the video plays after installing:
gstreamer0.10-ffmpeg
gstreamer0.10-fluendo-mp3
gstreamer0.10-plugins-ugly
(same are installed on this system)
without any modification to /opt/libreoffice/ure/lib/libstdc++.so.6

So I can only assume that something else is causing the issue on this an my other systems. I'll do some additional testing to see if I can sort out the problem. But in light of others also not having the issue I'll close the bug for now. Again, thanks for testing.
Comment 19 NoOp 2011-03-23 11:57:31 UTC
As a followup: I found the issue. The problem was libavcodec-extra-52/libavcodec-unstripped-52 packages that I had installed.

Taking the hint from the error message, I uninstalled libdirac-encoder0:
====
Commit Log for Wed Mar 23 11:27:42 2011
Completely removed the following packages:
libdirac-encoder0

Removed the following packages:
gstreamer0.10-plugins-bad
libavcodec-extra-52
libavcodec-unstripped-52
vlc
vlc-nox
vlc-plugin-notify
vlc-plugin-pulse
xvidcap

Installed the following packages:
libavcodec52 (4:0.6-2ubuntu6)
===
and tested. The video played properly.

I then reinstalled vlc, libdirac-encoder0:
====
Commit Log for Wed Mar 23 11:30:23 2011

Installed the following packages:
libdirac-encoder0 (1.0.2-3)
vlc (1.1.4-1ubuntu1.4)
vlc-nox (1.1.4-1ubuntu1.4)
vlc-plugin-notify (1.1.4-1ubuntu1.4)
vlc-plugin-pulse (1.1.4-1ubuntu1.4)
====
and it still works. 

So it appears that the issue is from one of the following:
- gstreamer0.10-plugins-bad
- libavcodec-extra-52
- libavcodec-unstripped-52

Testing one-by-one (reinstalling):
1. gstreamer0.10-plugins-bad
  Works - no issue.
2. libavcodec-extra-52 (removes libavcodec52 (4:0.6-2ubuntu6)):
  Breaks it. Sound only + 
(soffice:11095): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstffmpeg.so': /opt/libreoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libdirac_encoder.so.0)
** Message: don't know how to handle video/x-xvid, framerate=(fraction)2997/100, width=(int)704, height=(int)384, pixel-aspect-ratio=(fraction)32/33
3. libavcodec-unstripped-52 causes the same breakage.

So the problem is libavcodec-extra-52/libavcodec-unstripped-52. Those packages were pulled in and installed by xvidcap (I'll file an Ubuntu bug against that).
Reinstalled libavcodec52 (4:0.6-2ubuntu6) which removes libavcodec-extra-52/libavcodec-unstripped-52, and everything is working (sound and video).

Again, thanks for testing.
Comment 20 Filippo 2011-05-23 05:02:23 UTC
(In reply to comment #19)
> As a followup: I found the issue. The problem was
> libavcodec-extra-52/libavcodec-unstripped-52 packages that I had installed.
> 
> Taking the hint from the error message, I uninstalled libdirac-encoder0:
> ====
> Commit Log for Wed Mar 23 11:27:42 2011
> Completely removed the following packages:
> libdirac-encoder0
> 
> Removed the following packages:
> gstreamer0.10-plugins-bad
> libavcodec-extra-52
> libavcodec-unstripped-52
> vlc
> vlc-nox
> vlc-plugin-notify
> vlc-plugin-pulse
> xvidcap
> 
> Installed the following packages:
> libavcodec52 (4:0.6-2ubuntu6)
> ===
> and tested. The video played properly.
> 
> I then reinstalled vlc, libdirac-encoder0:
> ====
> Commit Log for Wed Mar 23 11:30:23 2011
> 
> Installed the following packages:
> libdirac-encoder0 (1.0.2-3)
> vlc (1.1.4-1ubuntu1.4)
> vlc-nox (1.1.4-1ubuntu1.4)
> vlc-plugin-notify (1.1.4-1ubuntu1.4)
> vlc-plugin-pulse (1.1.4-1ubuntu1.4)
> ====
> and it still works. 
> 
> So it appears that the issue is from one of the following:
> - gstreamer0.10-plugins-bad
> - libavcodec-extra-52
> - libavcodec-unstripped-52
> 
> Testing one-by-one (reinstalling):
> 1. gstreamer0.10-plugins-bad
>   Works - no issue.
> 2. libavcodec-extra-52 (removes libavcodec52 (4:0.6-2ubuntu6)):
>   Breaks it. Sound only + 
> (soffice:11095): GStreamer-WARNING **: Failed to load plugin
> '/usr/lib/gstreamer-0.10/libgstffmpeg.so':
> /opt/libreoffice/program/../basis-link/ure-link/lib/libstdc++.so.6: version
> `GLIBCXX_3.4.11' not found (required by /usr/lib/libdirac_encoder.so.0)
> ** Message: don't know how to handle video/x-xvid,
> framerate=(fraction)2997/100, width=(int)704, height=(int)384,
> pixel-aspect-ratio=(fraction)32/33
> 3. libavcodec-unstripped-52 causes the same breakage.
> 
> So the problem is libavcodec-extra-52/libavcodec-unstripped-52. Those packages
> were pulled in and installed by xvidcap (I'll file an Ubuntu bug against that).
> Reinstalled libavcodec52 (4:0.6-2ubuntu6) which removes
> libavcodec-extra-52/libavcodec-unstripped-52, and everything is working (sound
> and video).
> 
> Again, thanks for testing.
I have this same issue on a fedora 14 
and LibreOffice 3.4 RC1 (2011-05-20).   

In my case the problem comes from   
/usr/lib/libdirac_decoder.so.0 which is 
integrated in the dirac-libs package.

A dirty workaround  is to add the line   

  export LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH

in /opt/libreoffice3.4/program/soffice 
so that the /usr/lib/libstdc++.so.6 library 
is loaded instead of the one which comes with LO.