Bug Hunting Session
Bug 32872 - neither "Fontwork Alignment" nor "Fontwork Character Spacing" respond to click
Summary: neither "Fontwork Alignment" nor "Fontwork Character Spacing" respond to click
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta2
Hardware: Other All
: medium critical
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
: 36489 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-06 04:54 UTC by Takeshi Abe
Modified: 2011-05-02 08:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Takeshi Abe 2011-01-06 04:54:38 UTC
Overview:
Nothing occurred when clicking button "Fontwork Alignment" at Fontwork Toolbar.
Same as "Fontwork Character Spacing".

Steps to Reproduce:
1) Open a new writer doc.
2) Select Fontwork Toolbar (by Alt+V -> T -> K)
3) Click left-most button "Fontwork Gallery" at Fontwork Toolbar
4) Select a Fontwork Style and push "OK"

Actual Results:
Then a Fontwork inserted, but neither "Fontwork Alignment" nor
"Fontwork Character Spacing" respond to click.
See
http://office-watching.com/data0024/Image33RC2-1.png
http://office-watching.com/data0024/Image33RC2-2.png

Expected Results:
clicking button "Fontwork Alignment" (or "Fontwork Character Spacing")
shows its drop-down.
See
http://office-watching.com/data0024/Image321-1.png
http://office-watching.com/data0024/Image321-2.png
for the behavior of OOo 3.2.1.

Additional Information:
It is reproducible on Windows 7/XP and Debian.
Comment 1 Regina Henschel 2011-01-06 05:03:43 UTC
Corresponding OOo issue
http://www.openoffice.org/issues/show_bug.cgi?id=115922
Comment 2 Yifan Jiang 2011-01-07 01:02:43 UTC
Thanks for the info, reproduced on 3.3 RC2 SLED 11 sp1/Windows xp. So it could be an all platform issue. 

I am not sure if we have a workaround to adjust the space and alignment... ...

Hi Cedric, would you mind to have a look? It is a general problem happening in all components, so please re-assign if we have a better candidate to deal with it. Thank you!
Comment 3 Scott 2011-01-25 15:01:41 UTC
Still bust in LibreOffice 3.3 final. This also affects the character spacing button on the same toolbar.
Comment 4 Cédric Bosdonnat 2011-02-04 01:44:46 UTC
Fixed in master branch by this commit:
http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=05ef821abdff1ec4712cd4b054a21e4180b2298f

Request for integration in libreoffice-3-3 branch on going.
Comment 5 Jan Holesovsky 2011-02-04 02:28:19 UTC
Signed-off & cherry picked to libreoffice-3-3.
Comment 6 Zack 2011-04-27 15:26:48 UTC
Reopening as a result of Bug 36489.  I can confirm this as well.

Scott wrote:

> Take a look at the details in bug 32872.  The issue is occurring again in 3.4
> Beta 2.
Comment 7 Zack 2011-04-27 15:27:13 UTC
*** Bug 36489 has been marked as a duplicate of this bug. ***
Comment 8 Scott 2011-04-29 11:24:46 UTC
Any time frame on a fix? Thx in advance.
Comment 9 Cédric Bosdonnat 2011-05-02 08:16:46 UTC
(In reply to comment #8)
> Any time frame on a fix? Thx in advance.

Urk... the new .component files reintroduced the same naming problem. Fixed again by:
 http://cgit.freedesktop.org/libreoffice/libs-core/commit/?id=f61c32e66e01dee136151493615e76a3363ecc13

Request for review and integration in -3-4 is pending.