Download it now!
Bug 32876 - Keyboard shortcuts for go to Begin and End of line are not overriding default behaviour
Summary: Keyboard shortcuts for go to Begin and End of line are not overriding default...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2011-01-06 07:29 UTC by gcrichton
Modified: 2012-08-31 10:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gcrichton 2011-01-06 07:29:30 UTC
On OS X the Begin/End keys (next to page up/down) usually move the cursor to the beginning or end of a document rather than the beginning or end of a line.
LibreOffice, like many other applications, overrides this behaviour to move the cursor to the start or end of the current line rather than document.
However, in RC2 this keyboard shortcut override is not working and using the keys will move the cursor to the start or end of the document.

Looking in Tools - Customize - Keyboard shows that for Writer the shortcuts are set to begin/end of line. I tried also setting the options for LibreOffice wide shortcuts doing the same. Behaviour is still to move to the start/end of the document.
Comment 1 gcrichton 2011-03-29 02:54:23 UTC
Issue is present in 3.3.2 release. The diagonal up/down arrow keys next to fn and delete still move the cursor to the beginning and end of the document, rather than the beginning and end of the line as set in the keyboard preferences (which is the default behaviour set with 'Rest').

I have just checked and this issue is present in OpenOffice,org 3.3.2 so may be an upstream change.
Comment 2 Jeffrey 2011-06-21 07:21:34 UTC
CANNOT be reproduced in LibreOffice 3.4  340m1(Build:12) on OpenSuse KDE. It seems that the matter has been resolved in one way or another.

I agree that the Begin (Home) and End keys are set to line begin and line end by default, but when I experimented with this, I was able to modify the keyboard configuration so Begin and End would take you to the beginning and end of the page.

Here are the steps:
1. Tools -> Customize -> Keyboard
2. Under Category, select "Navigate"
3. Under Function, a new set of functions should appear
4. Choose "Select to Page Begin"
5. Choose "Home" or "Begin" under the Shortcut Keys
6. Select Modify

Now when I enter the Begin button with a page full of text, it will take me to the top of the page, highlighting all the text between the crossbar and the beginning of the page. The same can be done for End.

I do not know whether this was fixed with a new release but it seems to me that it is fine now in LibreOffice 3.4  340m1(Build:12). Can anyone confirm this? If not I will mark this as resolved.
Comment 3 Björn Michaelsen 2011-12-23 11:35:18 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 gcrichton 2012-01-03 04:56:30 UTC
Confirmed it is still an issue.
LibreOffice 3.5.0 
Build ID: ef91e38-b1d4df6-090bcba-45cf606-05891e7
OS X 10.7.2

Sorry for the delay. I had replaced my keyboard with a bluetooth Apple one which does not have the arrow keys so I had to source a wired keyboard.

In my LibreOffice Keyboard settings the arrow keys are set to 'To Line Begin' and 'To End of Line' (slightly inconsistent text I know) and CMD+ down arrow is for 'To Document End' - I cannot see a 'To Document Begin'.
On a three page doc the following happens:

key: up arrow
expected: cursor to line begin 
observed: cursor to document begin

key: down arrow
expected: cursor to line end 
observed: cursor to document end

key: CMD + up arrow
expected: cursor to document begin
observed: cursor to document begin

key: CMD + down arrow
expected: cursor to document end
observed: cursor to document end

So, it may be that the CMD modifier is always applied even when not pressed.
Comment 5 sasha.libreoffice 2012-02-23 02:49:31 UTC
Thanks for additional testing. Currently we can not find tester with Mac os X. It is reproducible on another computer?
Comment 6 Florian Reisinger 2012-08-14 13:58:32 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 13:59:48 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 Florian Reisinger 2012-08-14 14:04:25 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 9 Florian Reisinger 2012-08-14 14:06:36 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian