Download it now!
Bug 33151 - Danish and Hungarian help content, from extensions, used in other help localizations
Summary: Danish and Hungarian help content, from extensions, used in other help locali...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.3.0 RC3
Hardware: All Windows (All)
: high major
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-15 07:07 UTC by Rainer Bielefeld Retired
Modified: 2012-02-17 01:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Pls. see original report (96.09 KB, image/png)
2011-01-15 07:07 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-01-15 07:07:52 UTC
Created attachment 42073 [details]
Pls. see original report

I saw that in "LibreOffice 3.3.0 RC3 - WIN7  Home Premium (64bit) English UI  [OOO330m19 (build 5 / tag 3.3.0.3)]", same with German UI.

I can't remember to have seen that in RC2see this very visible problem as a 3.3 blocker
Comment 1 Andras Timar 2011-01-15 08:19:19 UTC
What's the problem? Crash, data loss? If not, why does it block the release?

Dictionary extensions come with their own help (localized of course, because using Danish or Hungarian thesaurus makes only sense, if somebody understands the language.) Users who do not need Danish or Hungarian dictionaries, should not install them.
Comment 2 Rainer Bielefeld Retired 2011-01-15 11:05:01 UTC
I don't have installed Danish or Hungarian UI or Help, and I can only hope that all those lots of other useless installed dictionaries won't flood my Help with additional itmes.

You can't sell a brand new car with fender benders, although it will run without problems.
Comment 3 Rainer Bielefeld Retired 2011-01-15 23:15:46 UTC
I checked whether I might have had installed Danish or Hungarian UI, Help contents or dicti0onaries. I only found Bug 32126, for which I installed Danish UI on my old PC, but not on this one. I never installed something Hungarian.
Comment 4 Andras Timar 2011-01-16 00:08:47 UTC
(In reply to comment #3)

Check the source.
http://cgit.freedesktop.org/libreoffice/libs-extern-sys/tree/dictionaries/da_DK/help?h=libreoffice-3-3
http://cgit.freedesktop.org/libreoffice/libs-extern-sys/tree/dictionaries/hu_HU/help?h=libreoffice-3-3
These two pages come from dictionaries which are implemented as extensions. When I remove these dictionaries with the installer, their helps are removed, too.

By the way, it would have been the same with the (unlocalizable) English help of NLPSolver, if it did not contain a bug. Help of NLPSolver does not get into the help tree, because the required help.tree file is missing from its source code.
Comment 5 Rainer Bielefeld Retired 2011-01-16 00:33:24 UTC
> Check the source.

Please excuse me, I don't know what to do with those links. 

Also I do not know how to use "the installer". I can't uninstall Danish or Hungarian language pack with the WIN installer, because I do not have installed them, and it's impossible to uninstall those dictionaries with the extension manager.
Comment 6 Andras Timar 2011-01-16 00:41:43 UTC
(In reply to comment #5)
> > Check the source.
> 
> Please excuse me, I don't know what to do with those links. 

OK, never mind. They just show where those pages are coming from.

> 
> Also I do not know how to use "the installer". I can't uninstall Danish or
> Hungarian language pack with the WIN installer, because I do not have installed
> them, and it's impossible to uninstall those dictionaries with the extension
> manager.

I think all dictionaries are installed by default by the Windows installer. Maybe this should be fine tuned in later releases in order to meet the users' needs (I don't know how). Anyway, when I open Windows Start menu - Settings - Control Panel - Add/Remove Programs and I select LibreOffice and choose Modify, the installer starts and I can de-select e.g. the Danish dictionary from Optional Components - Dictionaries section.
Comment 7 Rainer Bielefeld Retired 2011-01-16 02:14:28 UTC
Now I see. I tried to uninstall  language packages, but I should have tried to uninstall dictionaries. Unfortunately my WIN7 refuses to uninstall with messag "Please close LibO before ...", but may be I am too ham-handed with my new WIn7.

If the problem reeally is limited to those 2 dicts. please feel free to remove this Bug from blockers
Comment 8 Petr Mladek 2011-01-17 08:46:50 UTC
Andras, it seems to be related to
http://cgit.freedesktop.org/libreoffice/libs-extern-sys/commit/?h=libreoffice-3-3&id=24e8e3a3a616a800621a1646b985a51a245bdee1
http://cgit.freedesktop.org/libreoffice/libs-extern-sys/commit/?h=libreoffice-3-3&id=3b5868783fc92ae79d4b5c27228ad174738c75c8

The help text is available only in the Hungarian, resp. Danish localization. Unfortunately, it is shown in all help translations.

One solution would be to allow translation of these pages, add them to pootle and let them translatied.

Another solution would be to modify the setting and show it inly in the particular help localizations. If it would need some support in the LO help code, feel free to reassign it to a developer.

Another solution would be to install the dictionaries only when the related UI localizations is enabled. In this case, please reassign it to Fridrich Strba.

The worst solution would be to disable the help content at all.

Andras, could you please have a look?

I agree with Rainer that we need not block the 3.3.0 release because of this. Though, it would be fine to have a better solution for 3.3.1.
Comment 9 Petr Mladek 2011-01-17 09:50:36 UTC
BTW: This not related to the Online help. This problem is visible in the local help. In fact, the help from extensions is not shown at all if you you online help, see the bug #33209

=> updating the summary
Comment 10 Rainer Bielefeld Retired 2011-01-17 11:17:53 UTC
@Petr:
May be you can write some hints on 
<http://wiki.documentfoundation.org/BugReport_Details#Documentation>
To avoid misunderstandings concerning different terms and definitions for Help?

Thank you!
Comment 11 Petr Mladek 2011-02-01 07:41:16 UTC
(In reply to comment #10)
> @Petr:
> May be you can write some hints on 
> <http://wiki.documentfoundation.org/BugReport_Details#Documentation>
> To avoid misunderstandings concerning different terms and definitions for Help?

Nice page. I added some notes about differences between the local and online help.
Comment 12 Rainer Bielefeld Retired 2011-03-06 10:01:37 UTC
Not a blocker, but may be annoying for someone who has installed several help packages.
Comment 13 compunologist 2011-06-27 01:37:25 UTC
(In reply to comment #0)
> Created an attachment (id=42073) [details]
> Pls. see original report
> 
> I saw that in "LibreOffice 3.3.0 RC3 - WIN7  Home Premium (64bit) English UI 
> [OOO330m19 (build 5 / tag 3.3.0.3)]", same with German UI.
> 
> I can't remember to have seen that in RC2see this very visible problem as a 3.3
> blocker

I have exactly the same bug appearing in the "Help" section of LibreOffice v3.4.0 [OOO340m1 (Build:12)] on a Windows Vista Business (32bit) English UI system.

I have installed "LibO_3.4.0_Win_x86_install_multi.exe" & "LibO_3.4.0_Win_x86_helppack_en-US.exe" after uninstalling LibreOffice 3.3.2 (where the problem was nonexistent)
Comment 14 Andras Timar 2011-11-21 06:39:15 UTC
I removed the help.tree files. So the content tree will look cleaner. The actual help pages can be found by searching for keywords or by free text search.
Comment 15 Harald Koester 2012-02-17 01:29:57 UTC
In Version 3.5.0 there are no longer Hungarian and Danish contents in German Help. From my view the problem is solved in this version. (Win XP)