Bug 33235 - Russian spellcheck dictionary will not be installed
Summary: Russian spellcheck dictionary will not be installed
Status: RESOLVED DUPLICATE of bug 33571
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.0 RC3
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-18 03:59 UTC by Alexandr
Modified: 2011-01-29 06:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr 2011-01-18 03:59:08 UTC
Russian spellcheck doesn't work in default installation. 

There is an option during setup to choose Russian dictionary. So I (as an average user) expected russian spellcheck to work.
But after installation spellcheck doesn't work. I've looked into manage extenstion - there is Russian hyphenation dictionary and thesaurus extension installed and not the spellcheck dictionary. 

Is it possible to add also russian spellcheck dictionary?
Comment 1 Rainer Bielefeld Retired 2011-01-18 05:39:42 UTC
My "LibreOffice 3.3.0 RC3 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 5 / tag 3.3.0.3)]" (Multi languages) also has a Russian hyphenation dictionary and thesaurus extension (I never asked for that), but no spell check dict. That is without logic.

@Alexandr:
Dict from 
<http://extensions.services.openoffice.org/en/project/Russian-rk-dictionary> seems to work fine (restart LibO after installation).

@Sophie:
any idea concerning this problem?
Comment 2 Alexandr 2011-01-18 06:30:21 UTC
(In reply to comment #1)
> My "LibreOffice 3.3.0 RC3 - WIN7  Home Premium (64bit) German UI  [OOO330m19
> (build 5 / tag 3.3.0.3)]" (Multi languages) also has a Russian hyphenation
> dictionary and thesaurus extension (I never asked for that), but no spell check
> dict. That is without logic.
> 
> @Alexandr:
> Dict from 
> <http://extensions.services.openoffice.org/en/project/Russian-rk-dictionary>
> seems to work fine (restart LibO after installation).
> 
> @Sophie:
> any idea concerning this problem?

Thank you, Rainer, for the link! 

In my opinion, the idea to put all dictionaries into distribuition and to allow users to choose disctionaries during setup is very good (espessially now, when it is not clear where to find dictionaries - link from LibreOffice leads to LibreOffice site without dictionaries and a user should google to look for it on http://extensions.services.openoffice.org/), but it should be improved.
Comment 3 Desert Fox 2011-01-26 09:24:01 UTC
We can use Alexander Lebedev's Russian spellcheck dictionary. It's distributed under BSD license and therefore can be freely bundled with LibreOffice distro. Russian version of Mozilla Firefox includes this very dictionary for 2,5 years now with mostly positive feedback (https://addons.mozilla.org/firefox/addon/russian-spellchecking-dic-3703).

Lebedev's Russian dictionary - ftp://scon155.phys.msu.su/pub/russian/ispell/
License file - ftp://scon155.phys.msu.su/pub/russian/ispell/LICENSE
Readme file - ftp://scon155.phys.msu.su/pub/russian/ispell/README
Lebedev's contact page - http://scon155.phys.msu.su/eng/lebedev.html
Comment 4 Alexander L. Slovesnik 2011-01-29 06:44:27 UTC
(In reply to comment #3)
> We can use Alexander Lebedev's Russian spellcheck dictionary. It's distributed
> under BSD license and therefore can be freely bundled with LibreOffice distro.
> Russian version of Mozilla Firefox includes this very dictionary for 2,5 years
> now with mostly positive feedback
> (https://addons.mozilla.org/firefox/addon/russian-spellchecking-dic-3703).
> 
> Lebedev's Russian dictionary - ftp://scon155.phys.msu.su/pub/russian/ispell/
> License file - ftp://scon155.phys.msu.su/pub/russian/ispell/LICENSE
> Readme file - ftp://scon155.phys.msu.su/pub/russian/ispell/README
> Lebedev's contact page - http://scon155.phys.msu.su/eng/lebedev.html

Alexander Lebedev's Russian spellcheck dictionary has been added in LibreOffice in Bug 33571.

*** This bug has been marked as a duplicate of bug 33571 ***