Bug Hunting Session
Bug 33368 - EDITING: Libreoffice writer hangs when saving .doc WORD document
Summary: EDITING: Libreoffice writer hangs when saving .doc WORD document
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC4
Hardware: x86 (IA32) Linux (All)
: highest critical
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
: 33630 33858 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-22 09:13 UTC by reynaldo
Modified: 2013-11-13 19:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
libreoffice hangs when "exporting" this attachment (37.50 KB, application/msword)
2011-01-22 09:14 UTC, reynaldo
Details
Stack trace of the freeze (4.78 KB, text/plain)
2011-01-24 12:09 UTC, Arnaud Versini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description reynaldo 2011-01-22 09:13:06 UTC
1.- Open the attachment
2.- Make a slightest modification (or Saves As)
3.- Save (yes to keep current format)
4.- Progress bar (bottom) hangs indefinitely. Have to kill process.

Right before the progress bar it says: "Exporting document"

I also noticed that if you delete the first reference in the second page-

[1] J. Smith, Proc. of the 1993 Electronic Components and Technology Conference (ECTC), Atlanta, Georgia, August 12-15, pp. 21-33, 1993.

-it saves the document without problems.
Comment 1 reynaldo 2011-01-22 09:14:57 UTC
Created attachment 42312 [details]
libreoffice hangs when "exporting" this attachment
Comment 2 Rainer Bielefeld Retired 2011-01-22 23:14:43 UTC
[Reproducible] with sample doucment and "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag 3.3.0.4)]" on 
64 bit AMD Phenom II X4 955 Processor 32.2 GHz, 4GB RAM, 
Graphic Card: NVIDIA GeForce GT 430

Also that the hang disappears when reference will be deleted is reproducible.
Comment 3 Noel Power 2011-01-24 04:00:26 UTC
and worse still the rc ( 9 I guess ) I downloaded from openoffice last week doesn't seem to fail :-/
Comment 4 Arnaud Versini 2011-01-24 12:09:02 UTC
Created attachment 42394 [details]
Stack trace of the freeze
Comment 5 Zack 2011-01-27 16:33:54 UTC
I have experienced the same problem on Windows 7 64bit with my own files.
Comment 6 zemudkram 2011-01-30 19:15:59 UTC
Affects me too, Ubuntu 10.10 / amd64.  Cannot save to doc or save a docx
Comment 7 Zack 2011-02-01 07:11:25 UTC
*** Bug 33630 has been marked as a duplicate of this bug. ***
Comment 8 Cédric Bosdonnat 2011-02-02 04:55:01 UTC
This loop has been fixed in master branch in the meantime by this commit:
http://cgit.freedesktop.org/libreoffice/writer/commit/?id=7307c9e0f901c40bb1baf2560fc4abc410dd2dd8

Could anyone review it for integration in libreoffice-3-3 branch?
Comment 9 Cédric Bosdonnat 2011-02-02 05:25:29 UTC
caolan, approved the fix for 3.3 on IRC. Cherry-picked it.
Comment 10 Vadim Usmanov 2011-02-03 11:14:18 UTC
*** Bug 33858 has been marked as a duplicate of this bug. ***
Comment 11 VALENTINUS 2011-02-09 03:36:36 UTC
Confirm! Can not save in Write file *. odt with complex formatting as *. doc.
If you do not close Write by hand (kill the process soffice.bin) the process of saving *. odt as *. doc will take all the free disk space.

In OpenOffice.org Write it is working correctly - saving *. odt as *. doc *. odt as *. doc. is OK.

LibreOffice 3.3.0 final
OS: Linux (Ubuntu 10.04)

RUS: LO Write: виснет при сохранении документа .odt в .doc
При сохранении сложноформатированного (многостраничного) документа .odt в .doc Write виснет. При этом, если не завершить процесс Write вручную, он "забьет" всё свободное пространство диска.